summaryrefslogtreecommitdiff
path: root/dev-haskell/cryptohash-sha256
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/cryptohash-sha256
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/cryptohash-sha256')
-rw-r--r--dev-haskell/cryptohash-sha256/Manifest3
-rw-r--r--dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.100.1.ebuild29
-rw-r--r--dev-haskell/cryptohash-sha256/metadata.xml26
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-haskell/cryptohash-sha256/Manifest b/dev-haskell/cryptohash-sha256/Manifest
new file mode 100644
index 000000000000..b548cd29c432
--- /dev/null
+++ b/dev-haskell/cryptohash-sha256/Manifest
@@ -0,0 +1,3 @@
+DIST cryptohash-sha256-0.11.100.1.tar.gz 10885 SHA256 57b02338e9648639335788b422dd4c744543cb0991347472e2e3628a33c2f5d6 SHA512 df6a8c7a4796f3b94faf0c1073b552eccf7dfbe6ab1489fef391e6342f34b3cb29991d1313aa5da11a90cb37bcd43c23eea12073ad4c7190926005de952c39e2 WHIRLPOOL 40b6b78e3631085765cea2d5868de95939d52e41b1de36b9ccb862b0b4cdfe8b144516ef551ab0c659b6652849d53e66ec6984f3bcdebae59bf3354c24f42060
+EBUILD cryptohash-sha256-0.11.100.1.ebuild 882 SHA256 536cb0f773566253d06576825aaf8ab6be272e9f609b762912c11a85a2a0ee0c SHA512 67f8bbee528779f375f3f1f8a3689634f8e51953395c0be19f4ade5a284c9fef87eabf7ec18ba28fac2c38cd90e5ce29169102c13479e07e14d628582ba34c57 WHIRLPOOL acf278da648d90764d404ab49179fb4e1b142a70977d962e7b9ab2580cd4ae6b33564d919d34c6fd85024986d58d9b0542bc2146f9a0398c693cda56ea546292
+MISC metadata.xml 1142 SHA256 de39fc64bdf93b4948b5ccd2297c8f8cafad0a80ef8fd58d6b4b3547d2131686 SHA512 992cbdbfeabf1b1b5d70b451ec96adbf782fd2ba4f49dd1acd796d19fabb0d54bc5dcbcf968b0c9d99335f972abe0d0aa4b6f042a3152ca1705396cb5fb4c76a WHIRLPOOL ea456aa8a531b09c054015e3f1ac09b4d977d5f63db2cf4b6ffc880b0730b69daed903cf63c1ca95d0f9fc6e66eb99adbf15cfda0f2374c5f4958337d45187f4
diff --git a/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.100.1.ebuild b/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.100.1.ebuild
new file mode 100644
index 000000000000..7389ba6c9f44
--- /dev/null
+++ b/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.100.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast, pure and practical SHA-256 implementation"
+HOMEPAGE="https://github.com/hvr/cryptohash-sha256"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/base16-bytestring-0.1.1 <dev-haskell/base16-bytestring-0.2
+ >=dev-haskell/sha-1.6.4 <dev-haskell/sha-1.7
+ >=dev-haskell/tasty-0.11 <dev-haskell/tasty-0.12
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.9 )
+"
diff --git a/dev-haskell/cryptohash-sha256/metadata.xml b/dev-haskell/cryptohash-sha256/metadata.xml
new file mode 100644
index 000000000000..095ef6762db6
--- /dev/null
+++ b/dev-haskell/cryptohash-sha256/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A practical incremental and one-pass, pure API to the
+ &lt;https://en.wikipedia.org/wiki/SHA-2 SHA-256 hash algorithm&gt;
+ with performance close to the fastest implementations available in other languages.
+
+ The implementation is made in C with a haskell FFI wrapper that hides the C implementation.
+
+ NOTE: This package has been forked off @cryptohash-0.11.7@ because the @cryptohash@ has been
+ deprecated and so this package continues to satisfy the need for a lightweight package
+ providing the SHA256 hash algorithm without any dependencies on packages other than
+ @base@ and @bytestring@.
+
+ Consequently, this package can be used as a drop-in replacement for @cryptohash@'s
+ "Crypto.Hash.SHA256" module, though with a clearly smaller footprint.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">hvr/cryptohash-sha256</remote-id>
+ </upstream>
+</pkgmetadata>