summaryrefslogtreecommitdiff
path: root/dev-haskell/cryptohash-sha256
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/cryptohash-sha256
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/cryptohash-sha256')
-rw-r--r--dev-haskell/cryptohash-sha256/Manifest3
-rw-r--r--dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.100.1.ebuild29
-rw-r--r--dev-haskell/cryptohash-sha256/metadata.xml26
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-haskell/cryptohash-sha256/Manifest b/dev-haskell/cryptohash-sha256/Manifest
new file mode 100644
index 000000000000..e35a030f4cf1
--- /dev/null
+++ b/dev-haskell/cryptohash-sha256/Manifest
@@ -0,0 +1,3 @@
+DIST cryptohash-sha256-0.11.100.1.tar.gz 10885 BLAKE2B 09f33b351b72bb9b8892409b5b140bd446f98cb7fdc349f483a3b719753c0a0ca08c0557ccff2bc4bfedb4336b3c5d046d15548cc8e3a404d69efcf2a5c744c2 SHA512 df6a8c7a4796f3b94faf0c1073b552eccf7dfbe6ab1489fef391e6342f34b3cb29991d1313aa5da11a90cb37bcd43c23eea12073ad4c7190926005de952c39e2
+EBUILD cryptohash-sha256-0.11.100.1.ebuild 882 BLAKE2B b5ef661cbf1c993d33eab61ba6f72c36d3f821cfc75ea217c746eb364d5ff981317a33b96d7c622af55bb009988193206a8341c20053b387469953125ae974f2 SHA512 67f8bbee528779f375f3f1f8a3689634f8e51953395c0be19f4ade5a284c9fef87eabf7ec18ba28fac2c38cd90e5ce29169102c13479e07e14d628582ba34c57
+MISC metadata.xml 1142 BLAKE2B 0cad5264e9d4ede629d9ca0ead9b4f523b1fc78f845db2c3ef27198e089499ea09a272e4070ca0212cbcdc983dbcdecff11e13e9e445a46fe5b0d0371e4ffca6 SHA512 992cbdbfeabf1b1b5d70b451ec96adbf782fd2ba4f49dd1acd796d19fabb0d54bc5dcbcf968b0c9d99335f972abe0d0aa4b6f042a3152ca1705396cb5fb4c76a
diff --git a/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.100.1.ebuild b/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.100.1.ebuild
new file mode 100644
index 000000000000..7389ba6c9f44
--- /dev/null
+++ b/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.100.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast, pure and practical SHA-256 implementation"
+HOMEPAGE="https://github.com/hvr/cryptohash-sha256"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/base16-bytestring-0.1.1 <dev-haskell/base16-bytestring-0.2
+ >=dev-haskell/sha-1.6.4 <dev-haskell/sha-1.7
+ >=dev-haskell/tasty-0.11 <dev-haskell/tasty-0.12
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.9 )
+"
diff --git a/dev-haskell/cryptohash-sha256/metadata.xml b/dev-haskell/cryptohash-sha256/metadata.xml
new file mode 100644
index 000000000000..095ef6762db6
--- /dev/null
+++ b/dev-haskell/cryptohash-sha256/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A practical incremental and one-pass, pure API to the
+ &lt;https://en.wikipedia.org/wiki/SHA-2 SHA-256 hash algorithm&gt;
+ with performance close to the fastest implementations available in other languages.
+
+ The implementation is made in C with a haskell FFI wrapper that hides the C implementation.
+
+ NOTE: This package has been forked off @cryptohash-0.11.7@ because the @cryptohash@ has been
+ deprecated and so this package continues to satisfy the need for a lightweight package
+ providing the SHA256 hash algorithm without any dependencies on packages other than
+ @base@ and @bytestring@.
+
+ Consequently, this package can be used as a drop-in replacement for @cryptohash@'s
+ "Crypto.Hash.SHA256" module, though with a clearly smaller footprint.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">hvr/cryptohash-sha256</remote-id>
+ </upstream>
+</pkgmetadata>