summaryrefslogtreecommitdiff
path: root/dev-haskell/crypton
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/crypton
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/crypton')
-rw-r--r--dev-haskell/crypton/Manifest3
-rw-r--r--dev-haskell/crypton/crypton-0.32.ebuild43
-rw-r--r--dev-haskell/crypton/metadata.xml23
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-haskell/crypton/Manifest b/dev-haskell/crypton/Manifest
new file mode 100644
index 000000000000..4ae71ebd0871
--- /dev/null
+++ b/dev-haskell/crypton/Manifest
@@ -0,0 +1,3 @@
+DIST crypton-0.32.tar.gz 618042 BLAKE2B 685f8db1be7b7ffffa79e3eea6b66a6ffe573c70268a15c0b34717c369ff15a17c24b6edd275f6e21a64eb9bcf5646f18e77599eec6796191ae9126d50b466ce SHA512 0c544f8213c607c9d063569b45491bced3bd9b1d6aaf59c414a80b6a9f887e75c2da00c539d2ef8abd770f52e03122640fe5219361d1fad0c0b3fb52dc636590
+EBUILD crypton-0.32.ebuild 1362 BLAKE2B e43e9dea6b1b18cb8f3cfac62da9e996a6e5b65cf3ea44574b8b98b802c5b9489a9f5f3a84a769a7eb9c69ed26544a00137aae45b92a0bb775b818df98830d86 SHA512 057a492c90141baeecfb6d1de1df5c4cb07ba390e8cea3346222db43a46d517ce72f16ead25fdb94fc5bba69a4bfa6a21bfece427ff77e287d1aab3bab4ba165
+MISC metadata.xml 1325 BLAKE2B 0a28e0c76f605d3cfab2405c96f4ad7f175ac3ac4b623114e3586dc221e60a04d989713981574ebd5d2cf44a98fff7a35e54784017e109108c60722f6a775e45 SHA512 4f2cfbcd379ae82206cdc43b95a747592d340031fa055ed780742ea8aa34a325335ac8dfeff4343b5f41c960f803db1e5b9857bed8b3f2768ae21ba68edd8261
diff --git a/dev-haskell/crypton/crypton-0.32.ebuild b/dev-haskell/crypton/crypton-0.32.ebuild
new file mode 100644
index 000000000000..baf8e2b05f65
--- /dev/null
+++ b/dev-haskell/crypton/crypton-0.32.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Cryptography Primitives sink"
+HOMEPAGE="https://github.com/kazu-yamamoto/crypton"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="check-alignment +integer-gmp old-toolchain-inliner +support-aesni +support-deepseq +support-pclmuldq +support-rdrand support-sse +target-attributes"
+
+RDEPEND=">=dev-haskell/basement-0.0.6:=[profile?]
+ >=dev-haskell/memory-0.14.18:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ virtual/libc
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-kat
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag check-alignment check_alignment) \
+ $(cabal_flag integer-gmp integer-gmp) \
+ $(cabal_flag old-toolchain-inliner old_toolchain_inliner) \
+ $(cabal_flag support-aesni support_aesni) \
+ $(cabal_flag support-deepseq support_deepseq) \
+ $(cabal_flag support-pclmuldq support_pclmuldq) \
+ $(cabal_flag support-rdrand support_rdrand) \
+ $(cabal_flag support-sse support_sse) \
+ $(cabal_flag target-attributes use_target_attributes)
+}
diff --git a/dev-haskell/crypton/metadata.xml b/dev-haskell/crypton/metadata.xml
new file mode 100644
index 000000000000..79ded3fd0fa2
--- /dev/null
+++ b/dev-haskell/crypton/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="check-alignment">extra check on alignment in C layers, which cause lowlevel assert errors. for debugging only.</flag>
+ <flag name="integer-gmp">Whether or not to use GMP for some functions</flag>
+ <flag name="old-toolchain-inliner">use -fgnu89-inline to workaround an old compiler / linker / glibc issue.</flag>
+ <flag name="support-aesni">allow compilation with AESNI on system and architecture that supports it</flag>
+ <flag name="support-deepseq">add deepseq instances for cryptographic types</flag>
+ <flag name="support-pclmuldq">Allow compilation with pclmuldq on architecture that supports it</flag>
+ <flag name="support-rdrand">allow compilation with RDRAND on system and architecture that supports it</flag>
+ <flag name="support-sse">Use SSE optimized version of (BLAKE2, ARGON2)</flag>
+ <flag name="target-attributes">use GCC / clang function attributes instead of global target options.</flag>
+ </use>
+ <upstream>
+ <remote-id type="hackage">crypton</remote-id>
+ <remote-id type="github">kazu-yamamoto/crypton</remote-id>
+ </upstream>
+</pkgmetadata>