summaryrefslogtreecommitdiff
path: root/dev-haskell/data-accessor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-22 14:43:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-22 14:43:09 +0100
commitc0a9f2400f704c438b0cef4f4105e7bb6c3cbbff (patch)
treef03dacf9fcbf88186d23a1c68620015cca2a06b2 /dev-haskell/data-accessor
parent4c4bbf21230bd972cf759b2a40b782aa4149fc1f (diff)
gentoo auto-resync : 22:08:2022 - 14:43:09
Diffstat (limited to 'dev-haskell/data-accessor')
-rw-r--r--dev-haskell/data-accessor/Manifest3
-rw-r--r--dev-haskell/data-accessor/data-accessor-0.2.3.ebuild24
-rw-r--r--dev-haskell/data-accessor/metadata.xml70
3 files changed, 0 insertions, 97 deletions
diff --git a/dev-haskell/data-accessor/Manifest b/dev-haskell/data-accessor/Manifest
deleted file mode 100644
index a0760fdc7c7a..000000000000
--- a/dev-haskell/data-accessor/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST data-accessor-0.2.3.tar.gz 10324 BLAKE2B 1db06e59b36c882310d3cf597a3642c3fb7b1b30df41d4fc0eb7f21087fd1f55ce70c8d7b460cd64384034395ab98ebc9ddf1059060f9dbfbf70012a11da0ee3 SHA512 7e875010f9835e3706d9d760e9490e567d14498cb86d485a6b29793d95172e1c5d767aee181eef7e0f160966b93144164cd5b6dc474fb44c1367b4a90d1490b4
-EBUILD data-accessor-0.2.3.ebuild 574 BLAKE2B 9cb96993330b2e62095184970150133f91297f22cae045fd169280cb5c43a6ae6f6e4c70561cae224525ed8b200bdd511458c68838dfe65c8a88ed9749db1355 SHA512 d0c8cf74834e528539b5da45a0778452018ad25a309453a37b33a32c12fc158428ff9c8eaec6c4c121680e8b70b5ca656f089783d0561e609644403ebba62521
-MISC metadata.xml 2767 BLAKE2B 01f825c5505ffe325b0b905cd9894b3aa3bbba82ec94ef156c9c8162cdb42596495e751c2a939740ce70fb0e2971d0302d569060f7032e5254509c5febc9caf8 SHA512 77ebd1dfb6cfac58e61b05d5feea8a99a5c6a9adc1f696be1ec78ba2511529dbe686ebfb83470da8d8d318d6556c2a18b1d044acfce60b58b7028b49b3662bbc
diff --git a/dev-haskell/data-accessor/data-accessor-0.2.3.ebuild b/dev-haskell/data-accessor/data-accessor-0.2.3.ebuild
deleted file mode 100644
index 6f1e60db11b7..000000000000
--- a/dev-haskell/data-accessor/data-accessor-0.2.3.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Utilities for accessing and manipulating fields of records"
-HOMEPAGE="https://www.haskell.org/haskellwiki/Record_access"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-lang/ghc-7.8.2:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
-"
diff --git a/dev-haskell/data-accessor/metadata.xml b/dev-haskell/data-accessor/metadata.xml
deleted file mode 100644
index c5088ca5b3fe..000000000000
--- a/dev-haskell/data-accessor/metadata.xml
+++ /dev/null
@@ -1,70 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- In Haskell 98 the name of a record field
- is automatically also the name of a function which gets the value
- of the according field.
- E.g. if we have
-
- data Pair a b = Pair
- first :: a, second :: b
-
- then
-
- &gt; first :: Pair a b -&gt; a
- &gt; second :: Pair a b -&gt; b
-
- However for setting or modifying a field value
- we need to use some syntactic sugar, which is often clumsy.
-
- modifyFirst :: (a -&gt; a) -&gt; (Pair a b -&gt; Pair a b)
- modifyFirst f r\@(Pair
- first=a
- ) = r
- first = f a
-
- With this package you can define record field accessors
- which allow setting, getting and modifying values easily.
- The package clearly demonstrates the power of the functional approach:
- You can combine accessors of a record and sub-records,
- to make the access look like the fields of the sub-record belong to the main record.
-
- Example:
-
- &gt; *Data.Accessor.Example&gt; (first^:second^=10) (('b',7),"hallo")
- &gt; (('b',10),"hallo")
-
- You can easily manipulate record fields in a 'Control.Monad.State.State' monad,
- you can easily code 'Show' instances that use the Accessor syntax
- and you can parse binary streams into records.
- See @Data.Accessor.Example@ for demonstration of all features.
-
- It would be great if in revised Haskell versions the names of record fields
- are automatically 'Data.Accessor.Accessor's
- rather than plain @get@ functions.
- For now, the package @data-accessor-template@ provides Template Haskell functions
- for automated generation of 'Data.Acesssor.Accessor's.
- See also the other @data-accessor@ packages
- that provide an Accessor interface to other data types.
- The package @enumset@ provides accessors to bit-packed records.
-
- For similar packages see @lenses@ and @fclabel@.
- A related concept are editors
- &lt;http://conal.net/blog/posts/semantic-editor-combinators/&gt;.
- Editors only consist of a modify method
- (and @modify@ applied to a 'const' function is a @set@ function).
- This way, they can modify all function values of a function at once,
- whereas an accessor can only change a single function value,
- say, it can change @f 0 = 1@ to @f 0 = 2@.
- This way, editors can even change the type of a record or a function.
- An Arrow instance can be defined for editors,
- but for accessors only a Category instance is possible ('(.)' method).
- The reason is the @arr@ method of the @Arrow@ class,
- that conflicts with the two-way nature (set and get) of accessors.
- </longdescription>
-</pkgmetadata>