summaryrefslogtreecommitdiff
path: root/dev-haskell/ekg-json/ekg-json-0.1.0.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-haskell/ekg-json/ekg-json-0.1.0.6-r1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-haskell/ekg-json/ekg-json-0.1.0.6-r1.ebuild')
-rw-r--r--dev-haskell/ekg-json/ekg-json-0.1.0.6-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/ekg-json/ekg-json-0.1.0.6-r1.ebuild b/dev-haskell/ekg-json/ekg-json-0.1.0.6-r1.ebuild
new file mode 100644
index 000000000000..058d32387d91
--- /dev/null
+++ b/dev-haskell/ekg-json/ekg-json-0.1.0.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="JSON encoding of ekg metrics"
+HOMEPAGE="https://github.com/tibbe/ekg-json"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.4:=[profile?]
+ >=dev-haskell/ekg-core-0.1:=[profile?] <dev-haskell/ekg-core-0.2:=[profile?]
+ <dev-haskell/text-1.3:=[profile?]
+ <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.5 && < 4.11' 'base >= 4.5' \
+ 'aeson >=0.4 && < 1.3' 'aeson >=0.4'
+}