summaryrefslogtreecommitdiff
path: root/dev-haskell/fingertree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/fingertree
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/fingertree')
-rw-r--r--dev-haskell/fingertree/Manifest3
-rw-r--r--dev-haskell/fingertree/fingertree-0.1.1.0.ebuild29
-rw-r--r--dev-haskell/fingertree/metadata.xml23
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-haskell/fingertree/Manifest b/dev-haskell/fingertree/Manifest
new file mode 100644
index 000000000000..bbc7727d5404
--- /dev/null
+++ b/dev-haskell/fingertree/Manifest
@@ -0,0 +1,3 @@
+DIST fingertree-0.1.1.0.tar.gz 14415 BLAKE2B b05ce26d0275ac9910607927914759008ed1c7e8ceeeeebbe6200ec5a96e39efc10372a69edc71cde01bbd8f5ba8600e7dd7ec7e31e676225127a133607e5edb SHA512 47d7387e11cf05a2df323c6af76a12e6cf02a857f7131203400cbc6ba9ee4c3c9e2c721a8423e6456a385f5ea0c4aedd0e9a2600d2d33609c0457cd259337016
+EBUILD fingertree-0.1.1.0.ebuild 740 BLAKE2B e6bacaa43900911a09405a0b3d6e78f1d3d243769f85cb83755634c82c9770f73942981ef5cc1af0431b63cc81080aed33d1d6b44144714badab3283e7612a41 SHA512 ab07e2fc6f1d8d8cce7884f9023835fc2a68b117c93e5a70ff105ade2c6c65ebcce7fc49e745b3c54642a1769278399914079f63f2a7d99e2c8418474d867c46
+MISC metadata.xml 824 BLAKE2B 282a5af4cf2bdb333afd0079c4c845bf6dc5d09574828dcd74742a18e3ef6c09578199f6117f0d7bd707ab23e16f9dd44a30e8b0d3b2f2d54f78807e934b805a SHA512 94278f3b50b18615d69752ef69012cf4996f4bbc90e2195688a47510290fff8d6a1bdb32cb04ec0a5b728d01221d5e15250bcf4dbddac6e05a3619e90ed60c8d
diff --git a/dev-haskell/fingertree/fingertree-0.1.1.0.ebuild b/dev-haskell/fingertree/fingertree-0.1.1.0.ebuild
new file mode 100644
index 000000000000..395439ae1202
--- /dev/null
+++ b/dev-haskell/fingertree/fingertree-0.1.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generic finger-tree structure, with example instances"
+HOMEPAGE="http://hackage.haskell.org/package/fingertree"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2 )
+"
diff --git a/dev-haskell/fingertree/metadata.xml b/dev-haskell/fingertree/metadata.xml
new file mode 100644
index 000000000000..e1edfac92e74
--- /dev/null
+++ b/dev-haskell/fingertree/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A general sequence representation with arbitrary
+ annotations, for use as a base for implementations of
+ various collection types, with examples, as described
+ in section 4 of
+
+ * Ralf Hinze and Ross Paterson,
+ \"Finger trees: a simple general-purpose data structure\",
+ /Journal of Functional Programming/ 16:2 (2006) pp 197-217.
+ &lt;http://www.soi.city.ac.uk/~ross/papers/FingerTree.html&gt;
+
+ For a tuned sequence type, see @Data.Sequence@ in the
+ @containers@ package, which is a specialization of
+ this structure.
+ </longdescription>
+</pkgmetadata>