summaryrefslogtreecommitdiff
path: root/dev-haskell/generics-sop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/generics-sop
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/generics-sop')
-rw-r--r--dev-haskell/generics-sop/Manifest3
-rw-r--r--dev-haskell/generics-sop/generics-sop-0.2.4.0.ebuild25
-rw-r--r--dev-haskell/generics-sop/metadata.xml37
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-haskell/generics-sop/Manifest b/dev-haskell/generics-sop/Manifest
new file mode 100644
index 000000000000..a66177198e87
--- /dev/null
+++ b/dev-haskell/generics-sop/Manifest
@@ -0,0 +1,3 @@
+DIST generics-sop-0.2.4.0.tar.gz 32986 SHA256 481f73f122970efc24fe9dea71077e265d260834d975dd41395671d9a86a1863 SHA512 ce0d92214e622c58febced5684ba92b117e413d5718c6fdea1471f0fc5ea48ea53b212a536618086228542985f304dc4434c75c6ab919a72e6f49ccce342d866 WHIRLPOOL 8ee0469f5a9685b904bd7d86a8949cf3f527c8f0d207632b796f215499d9864fea3766e185536109dbf722f6395c4bed9e49e66a695dd748afb19510dbc04012
+EBUILD generics-sop-0.2.4.0.ebuild 682 SHA256 640986d1699258ccab650481c6d812e1c019554721d2149b308d9ba2af858e53 SHA512 6d227c2fe4372ff57180656db92547b0c4988fc85cfa49f132dd79a30603608d9a53f61c53a90cfde7012a9711274a9aff1e15d30a57fb47b0d5ddd6ab48136d WHIRLPOOL 444cb2ac3fe71261e9f378f96591364c6366abbf1c75782e563c608281d1a48f562ba314681753b0f834d6f3ee529ec2576da58cc14206a388882a9464b154ef
+MISC metadata.xml 1381 SHA256 a6cdffe7b0faf21994c797b4de67a9826a371a456da0563d01b9acafb7ec8970 SHA512 75abab067f073654bc8323421e2a758400965935603e68639e3b2fe7e8069b04205830c6e2bd9fa05ae2f1fc310ad7a2a35310872b46572f4b846f72c005ca19 WHIRLPOOL 03608b9463c9dcd9ef1db884ca185ba278cce54b9f380e8be478a64375e492498042789aa788e92c9125eee6ea1404e295cf46709f080bebafde85e087c08849
diff --git a/dev-haskell/generics-sop/generics-sop-0.2.4.0.ebuild b/dev-haskell/generics-sop/generics-sop-0.2.4.0.ebuild
new file mode 100644
index 000000000000..b62e41cc55d5
--- /dev/null
+++ b/dev-haskell/generics-sop/generics-sop-0.2.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generic Programming using True Sums of Products"
+HOMEPAGE="http://hackage.haskell.org/package/generics-sop"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-0.6:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
diff --git a/dev-haskell/generics-sop/metadata.xml b/dev-haskell/generics-sop/metadata.xml
new file mode 100644
index 000000000000..af041149fe29
--- /dev/null
+++ b/dev-haskell/generics-sop/metadata.xml
@@ -0,0 +1,37 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A library to support the definition of generic functions.
+ Datatypes are viewed in a uniform, structured way:
+ the choice between constructors is represented using an n-ary
+ sum, and the arguments of each constructor are represented using
+ an n-ary product.
+
+ The module "Generics.SOP" is the main module of this library and contains
+ more detailed documentation.
+
+ Examples of using this library are provided by the following
+ packages:
+
+ * @&lt;https://hackage.haskell.org/package/basic-sop basic-sop&gt;@ basic examples,
+
+ * @&lt;https://hackage.haskell.org/package/pretty-sop pretty-sop&gt;@ generic pretty printing,
+
+ * @&lt;https://hackage.haskell.org/package/lens-sop lens-sop&gt;@ generically computed lenses,
+
+ * @&lt;https://hackage.haskell.org/package/json-sop json-sop&gt;@ generic JSON conversions.
+
+ A detailed description of the ideas behind this library is provided by
+ the paper:
+
+ * Edsko de Vries and Andres Löh.
+ &lt;http://www.andres-loeh.de/TrueSumsOfProducts True Sums of Products&gt;.
+ Workshop on Generic Programming (WGP) 2014.
+
+ </longdescription>
+</pkgmetadata>