summaryrefslogtreecommitdiff
path: root/dev-haskell/git
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-22 14:43:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-22 14:43:09 +0100
commitc0a9f2400f704c438b0cef4f4105e7bb6c3cbbff (patch)
treef03dacf9fcbf88186d23a1c68620015cca2a06b2 /dev-haskell/git
parent4c4bbf21230bd972cf759b2a40b782aa4149fc1f (diff)
gentoo auto-resync : 22:08:2022 - 14:43:09
Diffstat (limited to 'dev-haskell/git')
-rw-r--r--dev-haskell/git/Manifest4
-rw-r--r--dev-haskell/git/files/git-0.3.0-monadfail.patch103
-rw-r--r--dev-haskell/git/git-0.3.0.ebuild41
-rw-r--r--dev-haskell/git/metadata.xml19
4 files changed, 0 insertions, 167 deletions
diff --git a/dev-haskell/git/Manifest b/dev-haskell/git/Manifest
deleted file mode 100644
index 10147498fd24..000000000000
--- a/dev-haskell/git/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX git-0.3.0-monadfail.patch 3097 BLAKE2B 5d826420a9372f79371872eab74b107a8e0b47f7fa125e30a2ecce77844fcda977a528bd5c010d1b2f75a33c68336bccf2ccca74e1114589d2111617a12b905d SHA512 3ea3775ac72cda8182bbf134795f33025ff922d087485ab1fc2abb2e3b260580d3598c56fa85c93b59cda363fe732a0f44959569d809f21cf315f136b11ed0e5
-DIST git-0.3.0.tar.gz 45846 BLAKE2B 93eb07d136085a0512f51b67e2e3b906fc7bee2c63e1bb621570a6123da0e08e87c829c88f7f17ddaf2a9f3cb3b8d5ddc485f83a14c814da86f2863fe17087f5 SHA512 f50061a6b3bccb063f7af74cbdcad33561b45c353ce35b8071ad03b0dd0b6e0d215381d6145dfeeff8bb66fbcef0379a9d749a8a1c1f8e45857b0c6bc4574f29
-EBUILD git-0.3.0.ebuild 1160 BLAKE2B 8272efd6f046c3d95f65a886d788ed3f40adb225bfffdca0cfa7341baace350384ac5922e8111876305473f19d1f99e2c8666b227a9ea223a07c47a99fabd06f SHA512 ba19073392e5e818cb85a17763df12084bf88fb4bc9deeb3f5164d21f71d88a65286f9af4c2b69c6bda9ad9c1b63ea0005251abe1bcdb54c9e2b483a7ee4bc58
-MISC metadata.xml 659 BLAKE2B 7ed1e58b1726b5c6e7bea58ab06b4874ee253e4869f74595dc4c5ee96ce55fb17395833d3bff5dfe74050b30acf3b6def113765048387b096c50d761f3588014 SHA512 d994c900cf5ccbbe8aa437c1908b49d2c1fe60d65e0a3498f3bfadc456fc1e84bfc3988b942903872d0380a42b5575447df38044edc026abb9f474e15a0ae4d2
diff --git a/dev-haskell/git/files/git-0.3.0-monadfail.patch b/dev-haskell/git/files/git-0.3.0-monadfail.patch
deleted file mode 100644
index ffca3a1534e1..000000000000
--- a/dev-haskell/git/files/git-0.3.0-monadfail.patch
+++ /dev/null
@@ -1,103 +0,0 @@
-From ad1e877d8e32bc3f573d92cadf697f0bb67a7da2 Mon Sep 17 00:00:00 2001
-From: Jack Todaro <solpeth@posteo.org>
-Date: Fri, 10 Jul 2020 07:01:08 +1000
-Subject: [PATCH] Data.Git.Monad.hs: port to MonadFail proposal
-
-Signed-off-by: Jack Todaro <solpeth@posteo.org>
----
- Data/Git/Monad.hs | 30 ++++++++++++++++++++++--------
- 1 file changed, 22 insertions(+), 8 deletions(-)
-
-diff --git a/Data/Git/Monad.hs b/Data/Git/Monad.hs
-index 480af9f..44a7018 100644
---- a/Data/Git/Monad.hs
-+++ b/Data/Git/Monad.hs
-@@ -17,7 +17,7 @@
- --
- -- You can also easily create a new commit: see 'CommitM' and 'withNewCommit'
- --
--
-+{-# LANGUAGE CPP #-}
- {-# LANGUAGE FlexibleInstances #-}
- {-# LANGUAGE OverloadedStrings #-}
- {-# LANGUAGE Rank2Types #-}
-@@ -74,7 +74,9 @@ module Data.Git.Monad
- , Git.Person(..)
- ) where
-
--
-+#if !MIN_VERSION_base(4,11,0)
-+import qualified Control.Monad.Fail as Fail
-+#endif
- import Data.ByteString (ByteString)
- import qualified Data.ByteString as B
- import qualified Data.ByteString.Lazy as BL
-@@ -240,7 +242,11 @@ instance Applicative GitM where
- instance Monad GitM where
- return = returnGitM
- (>>=) = bindGitM
-- fail = failGitM
-+#if !MIN_VERSION_base(4,11,0)
-+ fail = Fail.fail
-+#endif
-+instance MonadFail GitM where
-+ fail = failGitM
-
- instance GitMonad GitM where
- getGit = getGitM
-@@ -313,7 +319,11 @@ instance Applicative CommitAccessM where
- instance Monad CommitAccessM where
- return = returnCommitAccessM
- (>>=) = bindCommitAccessM
-- fail = failCommitAccessM
-+#if !MIN_VERSION_base(4,11,0)
-+ fail = Fail.fail
-+#endif
-+instance MonadFail CommitAccessM where
-+ fail = failCommitAccessM
-
- instance GitMonad CommitAccessM where
- getGit = getCommitAccessM
-@@ -423,7 +433,7 @@ getDir fp = do
- -- > l <- getDir []
- -- > liftGit $ print l
- --
--withCommit :: (Resolvable ref, GitMonad git)
-+withCommit :: (Resolvable ref, GitMonad git, MonadFail git)
- => ref
- -- ^ the commit revision or reference to open
- -> CommitAccessM a
-@@ -474,7 +484,11 @@ instance Applicative CommitM where
- instance Monad CommitM where
- return = returnCommitM
- (>>=) = bindCommitM
-- fail = failCommitM
-+#if !MIN_VERSION_base(4,11,0)
-+ fail = Fail.fail
-+#endif
-+instance MonadFail CommitM where
-+ fail = failCommitM
-
- instance GitMonad CommitM where
- getGit = getCommitM
-@@ -599,7 +613,7 @@ deleteFile path = do
- -- > setFile ["README.md"] $ readmeContent <> "just add some more description\n"
- -- > branchWrite "master" r
- --
--withNewCommit :: (GitMonad git, Resolvable rev)
-+withNewCommit :: (GitMonad git, MonadFail git, Resolvable rev)
- => Git.Person
- -- ^ by default a commit must have an Author and a Committer.
- --
-@@ -670,7 +684,7 @@ withNewCommit p mPrec m = do
- -- )
- -- @
- --
--withBranch :: GitMonad git
-+withBranch :: (GitMonad git, MonadFail git)
- => Git.Person
- -- ^ the default Author and Committer (see 'withNewCommit')
- -> Git.RefName
---
-2.27.0
-
diff --git a/dev-haskell/git/git-0.3.0.ebuild b/dev-haskell/git/git-0.3.0.ebuild
deleted file mode 100644
index 521fbe6b0456..000000000000
--- a/dev-haskell/git/git-0.3.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.2
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Git operations in haskell"
-HOMEPAGE="https://github.com/vincenthz/hs-git"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-haskell/basement:=[profile?]
- >=dev-haskell/cryptonite-0.22:=[profile?]
- >=dev-haskell/hourglass-0.2:=[profile?]
- >=dev-haskell/memory-0.13:=[profile?]
- dev-haskell/random:=[profile?]
- dev-haskell/system-fileio:=[profile?]
- dev-haskell/system-filepath:=[profile?]
- dev-haskell/unix-compat:=[profile?]
- dev-haskell/utf8-string:=[profile?]
- dev-haskell/vector:=[profile?]
- dev-haskell/zlib:=[profile?]
- >=dev-haskell/zlib-bindings-0.1:=[profile?] <dev-haskell/zlib-bindings-0.2:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( >=dev-haskell/bytedump-1.0
- dev-haskell/tasty
- dev-haskell/tasty-quickcheck )
-"
-
-PATCHES=( "${FILESDIR}/${P}-monadfail.patch" )
diff --git a/dev-haskell/git/metadata.xml b/dev-haskell/git/metadata.xml
deleted file mode 100644
index ec9c4b301b93..000000000000
--- a/dev-haskell/git/metadata.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
-
- A Haskell implementation of git storage operations, allowing users
- to manipulate git repositories (read and write).
-
- This implementation is fully interoperable with the main C implementation.
-
- This is strictly only manipulating the git store (what's inside the .git directory),
- and doesn't do anything with the index or your working directory files.
-
- </longdescription>
-</pkgmetadata>