summaryrefslogtreecommitdiff
path: root/dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
commit265dbe5dbc14c199299496c6db8fce3f76647015 (patch)
treeab18b5617d138f6684566b619405090989d55a2c /dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0-r1.ebuild
parent586819755b4dbfdffdc8a725ab7c0f86095b8489 (diff)
gentoo resync : 21.09.2018
Diffstat (limited to 'dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0-r1.ebuild')
-rw-r--r--dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0-r1.ebuild b/dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0-r1.ebuild
new file mode 100644
index 000000000000..23370ec0b510
--- /dev/null
+++ b/dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-mysql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="MySQL driver for HDBC"
+HOMEPAGE="https://github.com/ryantm/hdbc-mysql"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-haskell/hdbc-2.1.0:2=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+ dev-libs/openssl:0=
+ sys-libs/zlib
+ dev-db/mysql-connector-c:0=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug)
+}