summaryrefslogtreecommitdiff
path: root/dev-haskell/hdbc-sqlite3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/hdbc-sqlite3
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/hdbc-sqlite3')
-rw-r--r--dev-haskell/hdbc-sqlite3/Manifest4
-rw-r--r--dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild18
-rw-r--r--dev-haskell/hdbc-sqlite3/metadata.xml5
3 files changed, 9 insertions, 18 deletions
diff --git a/dev-haskell/hdbc-sqlite3/Manifest b/dev-haskell/hdbc-sqlite3/Manifest
index 845ec15cf86c..96d626196fc7 100644
--- a/dev-haskell/hdbc-sqlite3/Manifest
+++ b/dev-haskell/hdbc-sqlite3/Manifest
@@ -1,3 +1,3 @@
DIST HDBC-sqlite3-2.3.3.1.tar.gz 15544 BLAKE2B ba1ae8142dd8122a158499623e6a64e64f4d54490565f70e58e083a4993280b73d901a97b1e29cc43d57efd184f931f4cf8a6f107d318bf756dcb9c830c0103e SHA512 17b2929aca806d0672ae83e1aa6122a38596504a4f23f868f1a3ff4e68f97c3aef6499f995659fa4ce82b1e8aab9a107172a7265309d4c3f4e9754e4cf756ec0
-EBUILD hdbc-sqlite3-2.3.3.1-r1.ebuild 1069 BLAKE2B 7038615418c13599e2bc06e96cc66b0fc1c84bfc687ed690da6c2fc33796ace38989e1a4612cf84715c3982c12695e8ffad0ca3883abf5d41b2fccf0c240fb70 SHA512 986c0e0b013b99a7a5b94072d05bf9c855c722f65f85e60b7b487b930acd6740e7418fb17e69da13cd8e41a13d2e39b812560538280e4fe953122d3a012ff9b5
-MISC metadata.xml 621 BLAKE2B 43b6c2fa50d30996dd81df963a724f9758496d58ee0548d53c5e54ddfe1bbf0781e068d653754979bd85a880f78827ae9ef4851d72ded4b637288a2d5ace1576 SHA512 6bc01a1eb9e0e327824849d9bd87eb06074e02ba0ded646ddcf3ab5dede95940a28be8d3d3c2a5df46e1589d9ef2eba767f31b85da3f9a3a45c596d22f11dae3
+EBUILD hdbc-sqlite3-2.3.3.1-r1.ebuild 878 BLAKE2B 6c1387458024da6d620bc82023a2ab441ccde82519a85e392c03c063046acc4877173aff2c50b2be9df26d2855d53c2131f41a78d6cec1ee74dddeb729340abf SHA512 43ab887a5a292b801afeccf5fb6e136535fc0c2d85aaa5630579a884d50edd6c47940b57661ae1c19891e826fdcc849b368fc81a599283ca30c5a2ecaf0ff43e
+MISC metadata.xml 420 BLAKE2B ca9007cc3eea0809489c8f97516379efaf5c7fa3d9e3924e27cf8e6e05596e897590982b268f73aa7670a7091132c07d20a3ed326065da8d1d728e3040342072 SHA512 1afc18db23f00c7cbe77dcadfd8310ac18b488f1d8f13eca8ec5b1873663961b71a9ec3114423551b68c743cdbac58b8d493cdda7f2eaefb3326e25afa5bf9b9
diff --git a/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild b/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild
index 6f71fc5a2a92..5cb19571040f 100644
--- a/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild
+++ b/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-# ebuild generated by hackport 0.5.1
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: -buildtests
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
@@ -18,27 +19,22 @@ SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="buildtests +splitbase"
+IUSE="+splitbase"
RDEPEND=">=dev-db/sqlite-3.0
>=dev-haskell/hdbc-2.3.0.0:2=[profile?]
dev-haskell/mtl:=[profile?]
dev-haskell/utf8-string:=[profile?]
>=dev-lang/ghc-7.4.1:=
- buildtests? ( dev-haskell/convertible:=[profile?]
- dev-haskell/hunit:=[profile?]
- dev-haskell/old-locale:=[profile?]
- dev-haskell/old-time:=[profile?]
- dev-haskell/testpack:=[profile?] )
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.2.3
+ >=dev-haskell/cabal-1.2
"
S="${WORKDIR}/${MY_P}"
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag buildtests buildtests) \
+ --flag=-buildtests \
$(cabal_flag splitbase splitbase)
}
diff --git a/dev-haskell/hdbc-sqlite3/metadata.xml b/dev-haskell/hdbc-sqlite3/metadata.xml
index a6dc7b001d95..b9f67a8436a4 100644
--- a/dev-haskell/hdbc-sqlite3/metadata.xml
+++ b/dev-haskell/hdbc-sqlite3/metadata.xml
@@ -6,13 +6,8 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
- <flag name="buildtests">Build the executable to run unit tests</flag>
<flag name="splitbase">Choose the new smaller, split-up package.</flag>
</use>
- <longdescription>
- This is the Sqlite v3 driver for HDBC, the generic
- database access system for Haskell
- </longdescription>
<upstream>
<remote-id type="github">hdbc/hdbc-sqlite3</remote-id>
</upstream>