summaryrefslogtreecommitdiff
path: root/dev-haskell/hoauth2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/hoauth2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/hoauth2')
-rw-r--r--dev-haskell/hoauth2/Manifest5
-rw-r--r--dev-haskell/hoauth2/hoauth2-0.4.8.ebuild35
-rw-r--r--dev-haskell/hoauth2/hoauth2-0.5.7.ebuild35
-rw-r--r--dev-haskell/hoauth2/metadata.xml22
4 files changed, 97 insertions, 0 deletions
diff --git a/dev-haskell/hoauth2/Manifest b/dev-haskell/hoauth2/Manifest
new file mode 100644
index 000000000000..b1a8a3c3b0c6
--- /dev/null
+++ b/dev-haskell/hoauth2/Manifest
@@ -0,0 +1,5 @@
+DIST hoauth2-0.4.8.tar.gz 8599 BLAKE2B 9cfaf6bf26937a5b3e9e03489843cd9173aea20d4360bfbbdbb9e083f7ec0c2191f19b6c8b86f07d5216c8fa064558183203d0f3d05e8390afb2a7d3a2f82455 SHA512 b2abf00d0ae7d15911f4a1e17d90d6f0b3931800bc66d77545c566fc64de527cfc86121b57a4ff4187a4a0aa81aea2e150412bf928fdec8e506ab24f9e1bea29
+DIST hoauth2-0.5.7.tar.gz 12245 BLAKE2B 641c30f90c4420c40e0c73397d5a830c1b9f24095bf31108531303fbfc8d56e4a614a09c2e2fdc11204521d2299faf2c15fd8dc6a0541627c0804ce485cd8bc6 SHA512 218c5cb722861af099efa1cf66025b3fbdaba3574b19fbe39db5bb3ca8431c8436329b9bf9cd7a642227e2bca964843bba6b94cb70d5020321b3f743cc020569
+EBUILD hoauth2-0.4.8.ebuild 964 BLAKE2B a73e30606dc5d53cd5c8f2e86aa276932c243904a3d9a0ec758ba1763da42b04441c24f1f00f0e67187255e81d0c6b1bc4009c4deacf76749f13985fb583a249 SHA512 d7d0a0769b46595ddf82206dcfe6984b7ef3486a5a222b31a8d6dee51411d8c75678466fb001a0fa518a1625aa80b6e9535e089809f69e786fe0425c4b5b2a29
+EBUILD hoauth2-0.5.7.ebuild 999 BLAKE2B 9a1411df326c0393d7b7e9f83460ee0879496122ad5a1c53207a2e18d2a28473e168716ea3f21d7f20cb7a93a39a8089ad9b30c86873f045f9d504364e791523 SHA512 63b481adf04376f29cf55ada974f38aa1f25cbb94fe315ce205b69ebd288623cae4cedec2ab17831347bb49d3ffbe3a3b96852b897a62ca2beff781016eea526
+MISC metadata.xml 655 BLAKE2B 19a9e440b04b5bf2e3bc9847baf82c2dba9e10f0c1156ddea8346f1c7511b9447874916b8ffdbac637fd5e41e2cc78a0d7ee6fe9034d13366920c7bf27e80072 SHA512 e8ea432f6d8785580b6486b34c43423dd0e141a102abf18ff4a5b1b418df23101d82e6f3cffac71b749af75793f61f645ee5074abe79f633127c82ce740d1f72
diff --git a/dev-haskell/hoauth2/hoauth2-0.4.8.ebuild b/dev-haskell/hoauth2/hoauth2-0.4.8.ebuild
new file mode 100644
index 000000000000..15d726a7c80f
--- /dev/null
+++ b/dev-haskell/hoauth2/hoauth2-0.4.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell OAuth2 authentication"
+HOMEPAGE="https://github.com/freizl/hoauth2"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT=test # missing files
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?] <dev-haskell/aeson-0.10:=[profile?]
+ >=dev-haskell/http-conduit-2.0:=[profile?] <dev-haskell/http-conduit-2.2:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?] <dev-haskell/http-types-0.9:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test test)
+}
diff --git a/dev-haskell/hoauth2/hoauth2-0.5.7.ebuild b/dev-haskell/hoauth2/hoauth2-0.5.7.ebuild
new file mode 100644
index 000000000000..11d19920caeb
--- /dev/null
+++ b/dev-haskell/hoauth2/hoauth2-0.5.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -test
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell OAuth2 authentication client"
+HOMEPAGE="https://github.com/freizl/hoauth2"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-1.0:=[profile?] <dev-haskell/aeson-1.1:=[profile?]
+ >=dev-haskell/http-conduit-2.2:=[profile?] <dev-haskell/http-conduit-2.3:=[profile?]
+ >=dev-haskell/http-types-0.9:=[profile?] <dev-haskell/http-types-0.10:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-test
+}
diff --git a/dev-haskell/hoauth2/metadata.xml b/dev-haskell/hoauth2/metadata.xml
new file mode 100644
index 000000000000..409b57ebc713
--- /dev/null
+++ b/dev-haskell/hoauth2/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Haskell OAuth2 authentication.
+
+ Tested following services
+
+ * google web oauth: &lt;https://developers.google.com/accounts/docs/OAuth2WebServer&gt;
+
+ * weibo oauth2: &lt;http://open.weibo.com/wiki/Oauth2&gt;
+
+ * github oauth: &lt;https://developer.github.com/v3/oauth/&gt;
+ </longdescription>
+ <upstream>
+ <remote-id type="github">freizl/hoauth2</remote-id>
+ </upstream>
+</pkgmetadata>