summaryrefslogtreecommitdiff
path: root/dev-haskell/hs3/hs3-0.5.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/hs3/hs3-0.5.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/hs3/hs3-0.5.9.ebuild')
-rw-r--r--dev-haskell/hs3/hs3-0.5.9.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/hs3/hs3-0.5.9.ebuild b/dev-haskell/hs3/hs3-0.5.9.ebuild
new file mode 100644
index 000000000000..e4dfbfe877e6
--- /dev/null
+++ b/dev-haskell/hs3/hs3-0.5.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="hS3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Interface to Amazon's Simple Storage Service (S3)"
+HOMEPAGE="http://gregheartsfield.com/hS3/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/crypto-4.1.0:=[profile?]
+ dev-haskell/dataenc:=[profile?]
+ >=dev-haskell/http-4000.0.0:=[profile?]
+ >=dev-haskell/hxt-9.0.0:=[profile?] <dev-haskell/hxt-10:=[profile?]
+ >=dev-haskell/missingh-0.18.6:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/regex-compat:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?]
+ <dev-haskell/network-uri-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}