summaryrefslogtreecommitdiff
path: root/dev-haskell/hstringtemplate/hstringtemplate-0.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/hstringtemplate/hstringtemplate-0.7.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/hstringtemplate/hstringtemplate-0.7.3.ebuild')
-rw-r--r--dev-haskell/hstringtemplate/hstringtemplate-0.7.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/hstringtemplate/hstringtemplate-0.7.3.ebuild b/dev-haskell/hstringtemplate/hstringtemplate-0.7.3.ebuild
new file mode 100644
index 000000000000..75759dddbfc2
--- /dev/null
+++ b/dev-haskell/hstringtemplate/hstringtemplate-0.7.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HStringTemplate"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="StringTemplate implementation in Haskell"
+HOMEPAGE="http://hackage.haskell.org/package/HStringTemplate"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ <dev-haskell/parsec-4:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ dev-haskell/void:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+S="${WORKDIR}/${MY_P}"