summaryrefslogtreecommitdiff
path: root/dev-haskell/hsyaml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/hsyaml
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/hsyaml')
-rw-r--r--dev-haskell/hsyaml/Manifest6
-rw-r--r--dev-haskell/hsyaml/hsyaml-0.2.1.0.ebuild19
-rw-r--r--dev-haskell/hsyaml/hsyaml-0.2.1.2.ebuild37
-rw-r--r--dev-haskell/hsyaml/metadata.xml20
4 files changed, 56 insertions, 26 deletions
diff --git a/dev-haskell/hsyaml/Manifest b/dev-haskell/hsyaml/Manifest
index b26d5770182c..145c508bb1ca 100644
--- a/dev-haskell/hsyaml/Manifest
+++ b/dev-haskell/hsyaml/Manifest
@@ -1,3 +1,5 @@
DIST HsYAML-0.2.1.0.tar.gz 83976 BLAKE2B fff32d30eb6cb76c852c9cb1909b8be06e4818d23322397271594dfe60895ea79ffa8cc4c4944173de30d46e1ef8a2872972434aeacec44fff8d52dc169264e5 SHA512 f8ad41a99e48183835093ad8bf6a3fbdf4b9ad9df3bea46b12efd55a9555c22bd2595c72b1ac2e73379ab47e21f6cbf9022412db8971e1c7c02a32e824f53304
-EBUILD hsyaml-0.2.1.0.ebuild 1370 BLAKE2B a76395e22fa60f90e47f1c041a5caa417dad9cfc21cd2e8b406124460433c8f18a288582bbc6871d1088cbf111b1d932b96531c7ab66b38a546a9409827cd05d SHA512 8ea42db4ebb86ca71a6fbfb749089499098fb6e3a1be0d6399e54213d8425a145c2a2439b543709e77c7d1bfa283ebfda1f129de02187b964b31c1ac5e876d3a
-MISC metadata.xml 1214 BLAKE2B 2ad5ccf74658e95737dd7b9dc517f9f1d639539176d6c84f768ed3e2711308f48a54514be0d0f63f9d47c77a5a1ee8174628f53220989671378835ba929494b6 SHA512 0dbb8dceea8003b461dff9bec9c9f771c90b3229222e89f9c0ab5e3a87650653f6cfd93d34b20ae38a6e315edfb7ebaa8168cc239722175b9337681b39fbdeca
+DIST hsyaml-0.2.1.2.tar.gz 84263 BLAKE2B 1fb534a31cdcc41536e3f0114f27b4f140142293aca052d72d5d5993ff5ff686fea30a893e30efe34c2969ad9237228a43960f8adac201470568628d60464237 SHA512 4ade814924422a0985096be48ce0305f8491df03985511b408fefcf68a044f9ec4a0d29d978c2bb72b36315c49ee3faea69d8336cd5d88ca3d2d86077f46d003
+EBUILD hsyaml-0.2.1.0.ebuild 1330 BLAKE2B 92ade5fbea8d7a8b566ce7c19255d7c03ea8f57720d36e6fe73399c52a99193216860ef0191a288583d7cdf236ea9615c66ca93a102b7bcbdd6120b020ae9d70 SHA512 2b722a6d0b8df285dff6dc7c627800ff9de7a4cd1ff871dbd4728fbd086c512af0669c81db8154cbb2416c1c9893cf65a8254b9aa52f3d17e56687cc21388bb2
+EBUILD hsyaml-0.2.1.2.ebuild 1124 BLAKE2B da7e0b1ca373d240893c38136a3634af74bc8558fc584e54d28f2b462645c4a9121bbe762475485c2933b115751903aea34bc517058abc2098829cb231f9bf53 SHA512 f845fdd861fa4be89ccde3c4afd1378dcfce86dc8516b1adc8461aa635b0842f7dd88853e2b3556052a8f7554ab6c6cb425fa688a92d6761be6500456b629b35
+MISC metadata.xml 454 BLAKE2B 1c3a24fa12d19087e4c7855b78dfc46e4076e72b6b9a2494205e5958147cf062c3a89be33ac6c44eee27a2633297249d05b5e735e1c8aaf8d4dc730f10797312 SHA512 e993d5d58ed36c547280a43d0295a4ddd87598c1d5f7607e040ac7f663559306d6ab233bf36510b138df4c2aca7814a2378335dc50318c133fca7fad8c2f10cc
diff --git a/dev-haskell/hsyaml/hsyaml-0.2.1.0.ebuild b/dev-haskell/hsyaml/hsyaml-0.2.1.0.ebuild
index 631459a7d467..4602f8d4b850 100644
--- a/dev-haskell/hsyaml/hsyaml-0.2.1.0.ebuild
+++ b/dev-haskell/hsyaml/hsyaml-0.2.1.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -34,13 +34,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
-src_prepare() {
- default
-
- cabal_chdeps \
- 'base >=4.5 && <4.14' 'base >=4.5' \
- 'containers >=0.4.2 && <0.7' 'containers >=0.4.2' \
- 'QuickCheck == 2.13.*' 'QuickCheck >= 2.13' \
- 'tasty == 1.2.*' 'tasty >= 1.2' \
- 'tasty-quickcheck == 0.10.*' 'tasty-quickcheck >= 0.10'
-}
+CABAL_CHDEPS=(
+ 'base >=4.5 && <4.14' 'base >=4.5'
+ 'containers >=0.4.2 && <0.7' 'containers >=0.4.2'
+ 'QuickCheck == 2.13.*' 'QuickCheck >= 2.13'
+ 'tasty == 1.2.*' 'tasty >= 1.2'
+ 'tasty-quickcheck == 0.10.*' 'tasty-quickcheck >= 0.10'
+)
diff --git a/dev-haskell/hsyaml/hsyaml-0.2.1.2.ebuild b/dev-haskell/hsyaml/hsyaml-0.2.1.2.ebuild
new file mode 100644
index 000000000000..162f34b60644
--- /dev/null
+++ b/dev-haskell/hsyaml/hsyaml-0.2.1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_PN="HsYAML"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Pure Haskell YAML 1.2 processor"
+HOMEPAGE="https://github.com/haskell-hvr/HsYAML"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="exe"
+
+RDEPEND=">=dev-haskell/parsec-3.1.13.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/text-1.2.3:=[profile?] <dev-haskell/text-2.2:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+ exe? ( >=dev-haskell/megaparsec-7.0:=[profile?] <dev-haskell/megaparsec-10:=[profile?]
+ >=dev-haskell/microaeson-0.1:=[profile?] <dev-haskell/microaeson-0.2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? ( >=dev-haskell/quickcheck-2.14 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/tasty-1.4 <dev-haskell/tasty-1.6
+ >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag exe exe)
+}
diff --git a/dev-haskell/hsyaml/metadata.xml b/dev-haskell/hsyaml/metadata.xml
index 298c3553c5d9..b11316eec0dc 100644
--- a/dev-haskell/hsyaml/metadata.xml
+++ b/dev-haskell/hsyaml/metadata.xml
@@ -5,17 +5,11 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- @HsYAML@ is a [YAML 1.2](http://yaml.org/spec/1.2/spec.html) parser implementation for Haskell.
-
- Features of @HsYAML@ include:
-
- * Pure Haskell implementation with small dependency footprint and emphasis on strict compliance with the [YAML 1.2 specification](http://yaml.org/spec/1.2/spec.html).
- * Direct decoding to native Haskell types via (@aeson@-inspired) typeclass-based API (see "Data.YAML").
- * Support for constructing custom YAML node graph representation (including support for cyclic YAML data structures).
- * Support for the standard (untyped) /Failsafe/, (strict) /JSON/, and (flexible) /Core/ \"schemas\" providing implicit typing rules as defined in the YAML 1.2 specification (including support for user-defined custom schemas).
- * Event-based API resembling LibYAML's Event-based API (see "Data.YAML.Event").
- * Low-level API access to lexical token-based scanner (see "Data.YAML.Token").
-
- </longdescription>
+ <use>
+ <flag name="exe">Enable @exe:yaml-test@ component</flag>
+ </use>
+ <upstream>
+ <remote-id type="hackage">HsYAML</remote-id>
+ <remote-id type="github">haskell-hvr/HsYAML</remote-id>
+ </upstream>
</pkgmetadata>