summaryrefslogtreecommitdiff
path: root/dev-haskell/http-api-data
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/http-api-data
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/http-api-data')
-rw-r--r--dev-haskell/http-api-data/Manifest3
-rw-r--r--dev-haskell/http-api-data/http-api-data-0.3.3.ebuild42
-rw-r--r--dev-haskell/http-api-data/metadata.xml14
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-haskell/http-api-data/Manifest b/dev-haskell/http-api-data/Manifest
new file mode 100644
index 000000000000..b7d0e9360648
--- /dev/null
+++ b/dev-haskell/http-api-data/Manifest
@@ -0,0 +1,3 @@
+DIST http-api-data-0.3.3.tar.gz 17668 BLAKE2B 8b4dfbf237312cd89413d45d31fd0730eecc4459e63d3e6f66bc1fb128f5c1d0358c3726df453e805014f5607373b2883fab0e38b54ede83ac4417cc6be81296 SHA512 125240fe0da41ff118937864cc5386d50b58cba98fa9d463202ac73a07b2d530563c3a7c41f81be42f25d99bcfc12ed01dca095a000f0cefc655d8046c3aa00c
+EBUILD http-api-data-0.3.3.ebuild 1316 BLAKE2B 923b09ea2ff113e3fc64991b32ea7ef5c00a2a9b505d38c760159f59122c4ad9eb694b687ed4b096398be0ec94c933b735cef85b596dad07ed800a634adbf5f1 SHA512 55d11acc2835eaa3b1bfe70e624b0dab85c05195c99fe2776a6589df90bc6f12628e3b1bb133affb50ebee97a461892279ea7cf84bd3a19773708e633f2ae2ec
+MISC metadata.xml 451 BLAKE2B 8c5f2ff5dd8eb41a933d14573e09c78963212aeac180065cc12eb69708f76d5fe7d7843384e4ff2095d3daf5764388a9cb14b96aeb37bbf3da7207178b3c28ca SHA512 c1d1bbb22c5eda41eecfd560624513271598fa334ff36eb58fed7aac29e1631296ca2ee53fd05b1157615a0d394dfa8e1dbc23257d4e7f5ce8d0456ebf342a7f
diff --git a/dev-haskell/http-api-data/http-api-data-0.3.3.ebuild b/dev-haskell/http-api-data/http-api-data-0.3.3.ebuild
new file mode 100644
index 000000000000..de3935c12d39
--- /dev/null
+++ b/dev-haskell/http-api-data/http-api-data-0.3.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Converting to/from HTTP API data like URL pieces, headers and query parameters"
+HOMEPAGE="https://github.com/fizruk/http-api-data"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="use-text-show"
+
+RDEPEND="dev-haskell/hashable:=[profile?]
+ >=dev-haskell/text-0.5:=[profile?]
+ >=dev-haskell/time-locale-compat-0.1.1.0:=[profile?] <dev-haskell/time-locale-compat-0.2:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/uri-bytestring:=[profile?]
+ >=dev-haskell/uuid-types-1.0.2:=[profile?] <dev-haskell/uuid-types-1.1:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+ use-text-show? ( >=dev-haskell/text-show-2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/doctest-0.11 <dev-haskell/doctest-0.12
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.9
+ >=dev-haskell/quickcheck-instances-0.3.12
+ dev-haskell/uuid )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag use-text-show use-text-show)
+}
diff --git a/dev-haskell/http-api-data/metadata.xml b/dev-haskell/http-api-data/metadata.xml
new file mode 100644
index 000000000000..249526e7aece
--- /dev/null
+++ b/dev-haskell/http-api-data/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="use-text-show">Use text-show library for efficient ToHttpApiData implementations</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">fizruk/http-api-data</remote-id>
+ </upstream>
+</pkgmetadata>