summaryrefslogtreecommitdiff
path: root/dev-haskell/http-client-conduit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/http-client-conduit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/http-client-conduit')
-rw-r--r--dev-haskell/http-client-conduit/Manifest5
-rw-r--r--dev-haskell/http-client-conduit/http-client-conduit-0.2.0.1.ebuild28
-rw-r--r--dev-haskell/http-client-conduit/http-client-conduit-0.3.0.ebuild25
-rw-r--r--dev-haskell/http-client-conduit/metadata.xml14
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-haskell/http-client-conduit/Manifest b/dev-haskell/http-client-conduit/Manifest
new file mode 100644
index 000000000000..f1ef93b76583
--- /dev/null
+++ b/dev-haskell/http-client-conduit/Manifest
@@ -0,0 +1,5 @@
+DIST http-client-conduit-0.2.0.1.tar.gz 2104 BLAKE2B 2f8bb34e48bdc4671c51013fe81a2a0fc90f4e01cb6e22ff9bcdd8507f5f02606ca8eb2199892fa8d2106a5e86a110b4feee100a77b08815419656dfe40edf32 SHA512 1fd691f613cf874ea6f596a1d178bee034aef48923d8665b33cb7519d49034c56198a1b98786f3b65e9b5fce36d7bea8e76bafd696c52f01a240da29a06696ab
+DIST http-client-conduit-0.3.0.tar.gz 1176 BLAKE2B 29a8da8e051c31b24c710db783d330eb25316f500968df8b546cf085ca179526b26f1709d2e05cfb4d32703cf1233a8b9e9d0e0b04bc66b15fb38bbf6ce1ae7b SHA512 c6d3a2ee7d2b3efca346835d226421bf18443d7248d743b0467b32a9697d845697267a5fa9ee5a7bdf2c6918c60f4f6897f3df109b9337ab3967b3b9ef2528fe
+EBUILD http-client-conduit-0.2.0.1.ebuild 721 BLAKE2B df907da2d08525ece30c49ef4e6398a350a9f682cca1f827aa37a61837e7b1a743364d6b6a928958f2e433394be3a622d4748ca5424b14e121178ba1b5fb65b9 SHA512 a8f9145285324a04e72846d9429bf97464a8bd465b66e2e9d225fa7d0ae494c5c959d095af43de8fe37400c95a596e88e98e098cab6254d2374f656c53d0f9ab
+EBUILD http-client-conduit-0.3.0.ebuild 629 BLAKE2B bb527df25dac6c8db3dcd8fb6be1f1c1f1dbe9e66c5a2e3d09d7deec37037e78b31ca5f1bf8d26d730799c8b8db1c96a64c4635b5fe771c728fbbe2c9ecd7c6d SHA512 de9560196b9b1100818c89284dea78ff491f300c08dfd3fbe5e7390e377c365ab75d32cd9903202e06ebf02e3534f8a06ca94d22aaa0fbc07ebf3c78c4eb11ec
+MISC metadata.xml 441 BLAKE2B 33456ac8ae2845eed00ed66ca3d754b83e90c33a57f6e84dc0ce31dedd9f2fd2b711397759b8024629dd011e18b5942db3567093a3226bced39a8abcdd6c6d44 SHA512 dbea66c32c3fface3c17b221436091de83efa7368384bdfdc76acc36672e6d7afbb3c5ffd08afe627c43d0e891dac4fc8053ea6de6294e0d1a7a0eb87edf4988
diff --git a/dev-haskell/http-client-conduit/http-client-conduit-0.2.0.1.ebuild b/dev-haskell/http-client-conduit/http-client-conduit-0.2.0.1.ebuild
new file mode 100644
index 000000000000..8d85de5bc9c1
--- /dev/null
+++ b/dev-haskell/http-client-conduit/http-client-conduit-0.2.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Frontend support for using http-client with conduit"
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/conduit:=[profile?]
+ >=dev-haskell/http-client-0.2:=[profile?]
+ >=dev-haskell/resourcet-0.4.6:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
diff --git a/dev-haskell/http-client-conduit/http-client-conduit-0.3.0.ebuild b/dev-haskell/http-client-conduit/http-client-conduit-0.3.0.ebuild
new file mode 100644
index 000000000000..462e15796ad9
--- /dev/null
+++ b/dev-haskell/http-client-conduit/http-client-conduit-0.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile" # haddock hoogle hscolour" no files
+inherit haskell-cabal
+
+DESCRIPTION="Frontend support for using http-client with conduit (deprecated)"
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/http-client-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
diff --git a/dev-haskell/http-client-conduit/metadata.xml b/dev-haskell/http-client-conduit/metadata.xml
new file mode 100644
index 000000000000..dabba697851d
--- /dev/null
+++ b/dev-haskell/http-client-conduit/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Intended for use by higher-level libraries, such as http-conduit.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">snoyberg/http-client</remote-id>
+ </upstream>
+</pkgmetadata>