summaryrefslogtreecommitdiff
path: root/dev-haskell/http-client-restricted/http-client-restricted-0.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-30 09:09:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-30 09:09:34 +0100
commitad0412d0cafb8c04ce98024155cf99a4cc27db44 (patch)
treec34688ab389c18775a322de6cd4cfd957cbe8014 /dev-haskell/http-client-restricted/http-client-restricted-0.0.5.ebuild
parentcdb747b791914a30c287a3a8e33d1b635e431707 (diff)
gentoo auto-resync : 30:07:2022 - 09:09:33
Diffstat (limited to 'dev-haskell/http-client-restricted/http-client-restricted-0.0.5.ebuild')
-rw-r--r--dev-haskell/http-client-restricted/http-client-restricted-0.0.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/http-client-restricted/http-client-restricted-0.0.5.ebuild b/dev-haskell/http-client-restricted/http-client-restricted-0.0.5.ebuild
new file mode 100644
index 000000000000..f30821e3c4f1
--- /dev/null
+++ b/dev-haskell/http-client-restricted/http-client-restricted-0.0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="restricting the servers that http-client will use"
+HOMEPAGE="https://hackage.haskell.org/package/http-client-restricted"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/connection-0.2.5:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/http-client-0.7.11:=[profile?] <dev-haskell/http-client-0.8:=[profile?]
+ >=dev-haskell/http-client-tls-0.3.6:=[profile?] <dev-haskell/http-client-tls-0.4:=[profile?]
+ >=dev-haskell/network-3.0.0.0:=[profile?]
+ dev-haskell/network-bsd:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"