summaryrefslogtreecommitdiff
path: root/dev-haskell/http-streams
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/http-streams
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/http-streams')
-rw-r--r--dev-haskell/http-streams/Manifest3
-rw-r--r--dev-haskell/http-streams/http-streams-0.8.4.0.ebuild58
-rw-r--r--dev-haskell/http-streams/metadata.xml22
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-haskell/http-streams/Manifest b/dev-haskell/http-streams/Manifest
new file mode 100644
index 000000000000..6a6d0a64eab6
--- /dev/null
+++ b/dev-haskell/http-streams/Manifest
@@ -0,0 +1,3 @@
+DIST http-streams-0.8.4.0.tar.gz 35330 BLAKE2B 6e6c0fbd9a61c6ea587d7140fb0219c5a415c798ee55b47f45642c19cc67f67a6c1098d74c8451bb6285fdc001d6cac389459a3dbd5ba9409a59e47e4bf4c9a5 SHA512 763287042b37eca43941369dd2b7a7693f545ef37d87bdadb0b5ee686648bc0c3e7d2a8edee37648bb61ebc1dfefb029ca3ce22a44519a16775eab98de0b0a1a
+EBUILD http-streams-0.8.4.0.ebuild 1974 BLAKE2B 6a9c124c4a1eea4331fdff3f107bfb698fe6e5d28bc1254c72bcdbc4b7cb517dc6f631659c69e7f331a8cc53c7a457fe961eb6557fdb78ecc6abab1663af6ec5 SHA512 4955a867406f757a4986f6e1ba93770dd60cf7dd15046d781786594d33564b5ebaaaecc838b101197a6483ac012f55526a332a61673fce8b0fc229873f7f15e7
+MISC metadata.xml 727 BLAKE2B 8fcc9f3a679e00960165b0ffe29c0a7a2f3cd17876593de0bf58ba767b3d8190e5a01d1a0132c4d1328ef4d753d908bbf448b95a5b05de5faf98e311138b594b SHA512 d3f4b4bd4d4e5e60ad7044fc662ac3577dd4e7bdfc95ac3b5b6bb16ae8cf5626e3e1c2aecdcfa1a3de4920eebac18f0a75894469cf04d72eb1f6970aff12bc5d
diff --git a/dev-haskell/http-streams/http-streams-0.8.4.0.ebuild b/dev-haskell/http-streams/http-streams-0.8.4.0.ebuild
new file mode 100644
index 000000000000..ddd5fd36a4d1
--- /dev/null
+++ b/dev-haskell/http-streams/http-streams-0.8.4.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An HTTP client using io-streams"
+HOMEPAGE="https://github.com/afcowie/http-streams/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="+network-uri"
+
+RESTRICT=test # cyclic dep: http-streams[test]->snap-server->http-streams
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/blaze-builder-0.4:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ >=dev-haskell/hsopenssl-0.10.3.5:=[profile?]
+ >=dev-haskell/http-common-0.8.2:=[profile?]
+ >=dev-haskell/io-streams-1.3:=[profile?] <dev-haskell/io-streams-1.4:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/openssl-streams-1.1:=[profile?] <dev-haskell/openssl-streams-1.4:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ network-uri? ( >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?]
+ <dev-haskell/network-uri-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/aeson-pretty
+ dev-haskell/hspec
+ dev-haskell/hspec-expectations
+ dev-haskell/hunit
+ dev-haskell/lifted-base
+ >=dev-haskell/snap-core-1.0 <dev-haskell/snap-core-1.1
+ >=dev-haskell/snap-server-1.0 <dev-haskell/snap-server-1.1
+ >=dev-haskell/system-fileio-0.3.10 <dev-haskell/system-fileio-0.4
+ >=dev-haskell/system-filepath-0.4.1 <dev-haskell/system-filepath-0.5
+ !network-uri? ( >=dev-haskell/network-2.6
+ >=dev-haskell/network-uri-2.6 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}
diff --git a/dev-haskell/http-streams/metadata.xml b/dev-haskell/http-streams/metadata.xml
new file mode 100644
index 000000000000..3e1a4d23211f
--- /dev/null
+++ b/dev-haskell/http-streams/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ /Overview/
+
+ An HTTP client, using the Snap Framework's 'io-streams' library to
+ hande the streaming IO. The API is optimized for ease of use for the
+ rather common case of code needing to query web services and deal with
+ the result.
+
+ The library is exported in a single module; see "Network.Http.Client"
+ for full documentation.
+ </longdescription>
+ <use>
+ <flag name="network-uri">Get Network.URI from the network-uri package.</flag>
+ </use>
+</pkgmetadata>