summaryrefslogtreecommitdiff
path: root/dev-haskell/http-types
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/http-types
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/http-types')
-rw-r--r--dev-haskell/http-types/Manifest5
-rw-r--r--dev-haskell/http-types/http-types-0.8.6.ebuild31
-rw-r--r--dev-haskell/http-types/http-types-0.9.1.ebuild31
-rw-r--r--dev-haskell/http-types/metadata.xml14
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-haskell/http-types/Manifest b/dev-haskell/http-types/Manifest
new file mode 100644
index 000000000000..29b6094d67fd
--- /dev/null
+++ b/dev-haskell/http-types/Manifest
@@ -0,0 +1,5 @@
+DIST http-types-0.8.6.tar.gz 10796 BLAKE2B cae66579a8aff76c97e4663ac1aece38c9fd0de72df7581febffd8db0c77e30e3659139aee4eb4812f0fa7011c5be89397657c82bcb3c0af563bb8470d7baf07 SHA512 c31dbc3e61afe42e6b279463b6c156dc343d1ca163a0c0b3f7e9afc0eee55cba31e655cbf7e615a62f32fa7ca1a52da288310c3b749e2d11b9c27268191cb8d1
+DIST http-types-0.9.1.tar.gz 12284 BLAKE2B 8e724b4abf896678a495fc21d942c93287e11480785730a8b79b4d158cf01ab9710c6cddb5e5287ad327f627d4eb7c1478d22c537fd9455aca5e14a0adebd18f SHA512 b51c0f6946d1952fa0e91db1164d77ab12e0709fdf9555b53f5c25ed7c55365b433733a933dd2765ce14d0ca2685edce7573c9dbfb75ae49443b4f177d170c40
+EBUILD http-types-0.8.6.ebuild 935 BLAKE2B c41534a13eb5662f09bd1389f430ce59fbdb89332e3f08b22d9c2e9d7c2600184ad2c1ee61158e91d6edc0cbe78c727b593bb21d9c86464435784824e6bbce85 SHA512 09635b76aee6f93c1ac0546f0109044ebcd23482a2d24b0d27d70554bd3c5dbf46dcb8e5d3c754862c4afa8a47757f49190018d6fbe61dfe44669104b43b7705
+EBUILD http-types-0.9.1.ebuild 937 BLAKE2B 92bc0b44ccca241ac705a63cdbc80fede85daf37ec5880346dacc32ad5c7143a803553387cba93471db24e655bb01030731d58149dd387ba0d4c91a4fc773d58 SHA512 c4a1bcd33634b2959a9d8f718f47926de72ff4efb290b62745150ea50287023e4a5a25540f281a1e8dba5397a11082f39de92154504ac4ce7e1ae1b8d593e4af
+MISC metadata.xml 440 BLAKE2B 9fdb72e1574ff398f9d96b4cfb8b08a65dddca263a16b21de2452bb63fbba0e642a131558b1781ba80b72b6ac8fd3f0be45ed0f03571c885c7462024ad50a5ca SHA512 02b64578c5df0d78fbe83d5f8fdaba84cfca92d267e220b559fc2b3f0341a2d1978b4f0a16f32c596d2a1aa31407206b96e802d6041830a8d3b5551c2141c3c2
diff --git a/dev-haskell/http-types/http-types-0.8.6.ebuild b/dev-haskell/http-types/http-types-0.8.6.ebuild
new file mode 100644
index 000000000000..870d52a5714b
--- /dev/null
+++ b/dev-haskell/http-types/http-types-0.8.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generic HTTP types for Haskell (for both client and server code)"
+HOMEPAGE="https://github.com/aristidb/http-types"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/text-0.11.0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/doctest-0.9.3
+ >=dev-haskell/hspec-1.3
+ dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances )
+"
diff --git a/dev-haskell/http-types/http-types-0.9.1.ebuild b/dev-haskell/http-types/http-types-0.9.1.ebuild
new file mode 100644
index 000000000000..63febfdc6ce2
--- /dev/null
+++ b/dev-haskell/http-types/http-types-0.9.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generic HTTP types for Haskell (for both client and server code)"
+HOMEPAGE="https://github.com/aristidb/http-types"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/text-0.11.0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/doctest-0.9.3
+ >=dev-haskell/hspec-1.3
+ dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances )
+"
diff --git a/dev-haskell/http-types/metadata.xml b/dev-haskell/http-types/metadata.xml
new file mode 100644
index 000000000000..2bca572a7264
--- /dev/null
+++ b/dev-haskell/http-types/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Generic HTTP types for Haskell (for both client and server code).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">aristidb/http-types</remote-id>
+ </upstream>
+</pkgmetadata>