summaryrefslogtreecommitdiff
path: root/dev-haskell/lifted-async
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/lifted-async
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/lifted-async')
-rw-r--r--dev-haskell/lifted-async/Manifest6
-rw-r--r--dev-haskell/lifted-async/lifted-async-0.10.2.3.ebuild32
-rw-r--r--dev-haskell/lifted-async/lifted-async-0.10.2.ebuild2
-rw-r--r--dev-haskell/lifted-async/metadata.xml5
4 files changed, 38 insertions, 7 deletions
diff --git a/dev-haskell/lifted-async/Manifest b/dev-haskell/lifted-async/Manifest
index 5b36afcff78f..75ab16c4a811 100644
--- a/dev-haskell/lifted-async/Manifest
+++ b/dev-haskell/lifted-async/Manifest
@@ -1,3 +1,5 @@
+DIST lifted-async-0.10.2.3.tar.gz 10685 BLAKE2B 86699670329fe040f1dab3eef317ba717fdfb7c6e69a444190a270280c90e5a59f54378f61d77c63175b06f41bb63100e98e5034d8d4a7df92c4af17fac37293 SHA512 b21ab3ccf04de748d3b0bf0ca8ae2c490fdfad4bcc5b9053a196da424923866d58bb735bc208ca600ae2d4d1d66545adc52e0826ba6bb63a7089d4946493e59a
DIST lifted-async-0.10.2.tar.gz 10607 BLAKE2B 79ef9e4f11e5d41d3886473f2443a7345a1b52fd0aaf50a96a338f3958fdfef0a00846adf04cf8d310935c130a583544829685ad895c238544fd3ca5558973cd SHA512 eb2b33693ab1617fdeca934c6ede73c530e578425049804c3a0322a63b5262411453f80cb730dabd338590fc6b3093cd13872b9922f5cda4806741fc74ea63ee
-EBUILD lifted-async-0.10.2.ebuild 1213 BLAKE2B 4151ec42964bfff30cb8ce5ecef53e2ea30df83a251122fb8fbe8c95abf885c69b54dbc172abb73f4135de5beeb7e150da284a4ea0039f93a8e5192986d72a4b SHA512 a585c8e8480991efbac5ec40c1e578400cfe64dccc2eb0afb4fb8b44884fda103b2403429bc366f6dfec42fe8f68445da6bdc482939c0ab6f73389dd160bbcca
-MISC metadata.xml 493 BLAKE2B 729e6d6ac41bcbd2aa1621517020220d43bc49cf492774dd3b1ecc1d13b84d515d7dd6cb4385d9864adfdc4a2f02a5dd923835016fadb26b03e238f23d6be7cd SHA512 f8da79f548bcf39aeb61e6aadef259d12bb4d29bace4868cdd84be19d72b6b5d333da26aec9667aae36bbcd171a6991309678474e52a8bf6bea26fad135d2297
+EBUILD lifted-async-0.10.2.3.ebuild 1130 BLAKE2B 65d3b1e8045b227f9591bb6a882e0e36d34f431580eeaa4d73a8d3a18a041283a7da5f912845f63be8f57eb98858d87468bd32e9bee215074df2494cbd1f5377 SHA512 cbd689fdf94c349a932d82fd6dac5a5d417db088001a881e2f0879149f4ec4de5780501bd69c443c5cdcce800d5b6d7819b21835f6fe31b46c9abc5813fbb4c6
+EBUILD lifted-async-0.10.2.ebuild 1213 BLAKE2B a0db97d14ae0dad8d439880c3d92e1bead5811b426d65ed7162a4e15189339fe39422421fed90354de9c93a11923657c25c2b5d03e88b765b0c96128de27f837 SHA512 f66d4e41916900f9c1392ad913a471a045ff6c3af84b6b3ff2195dc105b1642b7ed015f03c288959ae65d456e720704dda5c9d7746d01b2e09d417f443045586
+MISC metadata.xml 385 BLAKE2B d9c4dee6b2e31162387873ac0022d7202bb9a730ed306dda087230bb4dac48b60ef1e92733799519c51cffd2c485ba4744d1f7502be9dff6370050c9b9846944 SHA512 73f83a184596a35c10e5650c46b277fe177cf19953e4dbd84e39e098b7bd2227ba9f28d8cdf53e19f0902ec8ee95f66b942440750a7b763ca594ceacab67d718
diff --git a/dev-haskell/lifted-async/lifted-async-0.10.2.3.ebuild b/dev-haskell/lifted-async/lifted-async-0.10.2.3.ebuild
new file mode 100644
index 000000000000..42c5ecac4aa8
--- /dev/null
+++ b/dev-haskell/lifted-async/lifted-async-0.10.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Run lifted IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/maoe/lifted-async"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/async-2.2:=[profile?] <dev-haskell/async-2.3:=[profile?]
+ >=dev-haskell/constraints-0.2:=[profile?] <dev-haskell/constraints-0.14:=[profile?]
+ >=dev-haskell/lifted-base-0.2:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
+ >=dev-haskell/monad-control-1.0:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ >=dev-haskell/transformers-base-0.4:=[profile?] <dev-haskell/transformers-base-0.5:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/hunit
+ dev-haskell/tasty
+ <dev-haskell/tasty-expected-failure-0.13
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.11
+ dev-haskell/tasty-th )
+"
diff --git a/dev-haskell/lifted-async/lifted-async-0.10.2.ebuild b/dev-haskell/lifted-async/lifted-async-0.10.2.ebuild
index 7d91929f794f..969bc7417d56 100644
--- a/dev-haskell/lifted-async/lifted-async-0.10.2.ebuild
+++ b/dev-haskell/lifted-async/lifted-async-0.10.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# ebuild generated by hackport 0.6.7.9999
diff --git a/dev-haskell/lifted-async/metadata.xml b/dev-haskell/lifted-async/metadata.xml
index 50b995cb320b..159a65915cec 100644
--- a/dev-haskell/lifted-async/metadata.xml
+++ b/dev-haskell/lifted-async/metadata.xml
@@ -5,11 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This package provides IO operations from @async@ package lifted to any
- instance of 'MonadBase' or 'MonadBaseControl'.
- </longdescription>
<upstream>
+ <remote-id type="hackage">lifted-async</remote-id>
<remote-id type="github">maoe/lifted-async</remote-id>
</upstream>
</pkgmetadata>