summaryrefslogtreecommitdiff
path: root/dev-haskell/mtl-compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/mtl-compat
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/mtl-compat')
-rw-r--r--dev-haskell/mtl-compat/Manifest3
-rw-r--r--dev-haskell/mtl-compat/metadata.xml28
-rw-r--r--dev-haskell/mtl-compat/mtl-compat-0.2.1.3.ebuild40
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-haskell/mtl-compat/Manifest b/dev-haskell/mtl-compat/Manifest
new file mode 100644
index 000000000000..4f28ce323a91
--- /dev/null
+++ b/dev-haskell/mtl-compat/Manifest
@@ -0,0 +1,3 @@
+DIST mtl-compat-0.2.1.3.tar.gz 4584 BLAKE2B 47cfbaf9f60f586318a0aa838e64d0ae13fe69386b738e3c45eb393acb77176c85a9e99f7c81384704d177bf7c895f866813880ba0f2285116a566f24114645c SHA512 c9afa97eb5dc1bddcbf0e088352141d56b603562f80fcbde6811610a4e71e1496dd5f07e4338644930bf06b403bc08d35799f7063ae845ecdb71e619b2342a18
+EBUILD mtl-compat-0.2.1.3.ebuild 1004 BLAKE2B b0eb2790a1b583883896859b36d457ff62425f3170934acca32df549a651395ff0f90f2a29da1f3d4c082507f2f91cce316be49308d3a337727491a772c02543 SHA512 9a709056bb20e2d5e6e18fb0fd6672c0d25321ca404d4318f446c26984e8a751c7e4cee22017d8b45d5bd1c3684bba6a5420ec090465c3c36a664dbc1c6e95cd
+MISC metadata.xml 1161 BLAKE2B 1ad804c5c754f337f5a046fe2b386d10149d9f05f8afbd5beb4a6a8bb4ddcc0a2e8e5c44f6c0b3f422ad93e3a59f80633210592681faea074a0e03a150d9332e SHA512 3a51b3c6dd7b62ef720aa1fcefd0bd810c36b8ac0322e83ca0d1552ace59bea71f55e4e77fc97a9aafd304b833ab8b3c11dee0ccac29b46418b99d367510cdbd
diff --git a/dev-haskell/mtl-compat/metadata.xml b/dev-haskell/mtl-compat/metadata.xml
new file mode 100644
index 000000000000..033f9421a7a1
--- /dev/null
+++ b/dev-haskell/mtl-compat/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package backports the "Control.Monad.Except" module from
+ @mtl@ (if using @mtl-2.2.0.1@ or earlier), which reexports the
+ @ExceptT@ monad transformer and the @MonadError@ class.
+
+ This package should only be used if there is a need to use the
+ @Control.Monad.Except@ module specifically. If you just want
+ the @mtl@ class instances for @ExceptT@, use
+ @transformers-compat@ instead, since @mtl-compat@ does nothing
+ but reexport the instances from that package.
+
+ Note that unlike how @mtl-2.2@ or later works, the
+ "Control.Monad.Except" module defined in this package exports
+ all of @ExceptT@'s monad class instances. Therefore, you may
+ have to declare @import Control.Monad.Except ()@ at the top of
+ your file to get all of the @ExceptT@ instances in scope.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">RyanGlScott/mtl-compat</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/mtl-compat/mtl-compat-0.2.1.3.ebuild b/dev-haskell/mtl-compat/mtl-compat-0.2.1.3.ebuild
new file mode 100644
index 000000000000..30aafe733b88
--- /dev/null
+++ b/dev-haskell/mtl-compat/mtl-compat-0.2.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5
+
+CABAL_FEATURES="lib profile" # haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Backported Control.Monad.Except module from mtl"
+HOMEPAGE="https://github.com/RyanGlScott/mtl-compat"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ dev-haskell/transformers-compat:=
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ local mtl_arg=()
+
+ has_version '>=dev-haskell/mtl-2.0.1' && \
+ has_version '<dev-haskell/mtl-2.2' && \
+ mtl_arg+=(--flag=two-point-one)
+ has_version '>=dev-haskell/mtl-2.2.0.1' && \
+ has_version '<dev-haskell/mtl-2.2.1' && \
+ mtl_arg+=(--flag=two-point-two)
+
+ haskell-cabal_src_configure \
+ ${mtl_arg}
+}