summaryrefslogtreecommitdiff
path: root/dev-haskell/mysql
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-haskell/mysql
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-haskell/mysql')
-rw-r--r--dev-haskell/mysql/Manifest4
-rw-r--r--dev-haskell/mysql/files/mysql-0.1.1.8-Cabal-1.24.patch29
-rw-r--r--dev-haskell/mysql/metadata.xml20
-rw-r--r--dev-haskell/mysql/mysql-0.1.7.ebuild37
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-haskell/mysql/Manifest b/dev-haskell/mysql/Manifest
new file mode 100644
index 000000000000..3b9b2789356f
--- /dev/null
+++ b/dev-haskell/mysql/Manifest
@@ -0,0 +1,4 @@
+AUX mysql-0.1.1.8-Cabal-1.24.patch 1039 BLAKE2B 581b3ce615530fd2ef339b9f7a5bbca13eed1df0fcca7f2d53f930de5c6d31a7837ba98c7cc13ff7a867af98e9cc527d5c2f7a3f1bda27bd1416ed788b10fddb SHA512 699338c70af38b3d145d621db35f3f65e8b8be8675c34da6655d89abbb100ffb02ed95a2237f541090bc9b475e4a8aec37cbcb51d78adc474ea988a996b6ac5c
+DIST mysql-0.1.7.tar.gz 16544 BLAKE2B a7617293f2dc970b9ace46c0b2a9452f23a90524181a1b37aa10176f2ba4ee3f9e967d94faa9e714a947e50b59d368c79fc59602cbc8e0792e4e396a09b4596c SHA512 45074050e17fed48f865c21ccca72cdcca02631715ee4a34b46f71fda74b50ab6332d8998d1047e6ae43df84e3fc865610153f15c3092c6b300e3e5ada30efa1
+EBUILD mysql-0.1.7.ebuild 830 BLAKE2B f2626ef99c471ff5612caaf470d97c2d751cc487bf2fc7c08bf51f511729455dadeeda7916ab51830b484fc4c9586dc6e3ce22cdf21ef9c2b070464f50e25ba6 SHA512 1bc555a73c842f8a14d063fecf6f4cc688da55c9c09ba1ed2992a2004f17ffb06432d38f9f01f6714e0e0c9b0b5928269367a25fa284e8d19061725480ef7c2a
+MISC metadata.xml 748 BLAKE2B 6ae07aa053448d068b8788e39caaece7bb54343493dbc067d57edeebe9dd4334dfe3033da8c5fb45ed40052ec60f307df79e1972e43fc6b58e7b92d23aca1a83 SHA512 ff8661d182778285dad7640382e41d32c2764f0456eca1a471b60ece089a810ccd6b6c021b8bd4099f799cf4d57d1f86617fb11f71cbfb7f3aabd260b87f6316
diff --git a/dev-haskell/mysql/files/mysql-0.1.1.8-Cabal-1.24.patch b/dev-haskell/mysql/files/mysql-0.1.1.8-Cabal-1.24.patch
new file mode 100644
index 000000000000..475d3f79722c
--- /dev/null
+++ b/dev-haskell/mysql/files/mysql-0.1.1.8-Cabal-1.24.patch
@@ -0,0 +1,29 @@
+diff --git a/Setup.lhs b/Setup.lhs
+index 2bf8d37..8fb2d3f 100644
+--- a/Setup.lhs
++++ b/Setup.lhs
+@@ -14,15 +14,2 @@ import Distribution.Verbosity
+
+--- A Cabal 1.16 vs 1.18 compatibility hack, as in 1.18
+--- findProgramLocation has a new (unused in this case) parameter.
+--- ConstOrId adds this parameter when types say it is mandatory.
+-class ConstOrId a b where
+- constOrId :: a -> b
+-
+-instance ConstOrId a a where
+- constOrId = id
+-
+-instance ConstOrId a (b -> a) where
+- constOrId = const
+-
+-
+ main = defaultMainWithHooks simpleUserHooks {
+@@ -39,5 +26,5 @@ main = defaultMainWithHooks simpleUserHooks {
+ mysqlConfigProgram = (simpleProgram "mysql_config") {
+- programFindLocation = \verbosity -> constOrId $ liftM2 mplus
+- (findProgramLocation verbosity "mysql_config")
+- (findProgramLocation verbosity "mysql_config5")
++ programFindLocation = \verbosity path -> liftM2 mplus
++ (findProgramOnSearchPath verbosity path "mysql_config")
++ (findProgramOnSearchPath verbosity path "mysql_config5")
+ }
diff --git a/dev-haskell/mysql/metadata.xml b/dev-haskell/mysql/metadata.xml
new file mode 100644
index 000000000000..a966cd047c61
--- /dev/null
+++ b/dev-haskell/mysql/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A low-level client library for the MySQL database, implemented as
+ bindings to the C @mysqlclient@ API.
+
+ /Important licensing note/: This library is BSD-licensed under the
+ terms of the MySQL FOSS License Exception
+ &lt;http://www.mysql.com/about/legal/licensing/foss-exception/&gt;.
+
+ Since this library links against the GPL-licensed @mysqlclient@
+ library, a non-open-source application that uses it /may/ be
+ subject to the terms of the GPL.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/mysql/mysql-0.1.7.ebuild b/dev-haskell/mysql/mysql-0.1.7.ebuild
new file mode 100644
index 000000000000..0e759fb01ffc
--- /dev/null
+++ b/dev-haskell/mysql/mysql-0.1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A low-level MySQL client library"
+HOMEPAGE="https://github.com/paul-rouse/mysql"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # needs local mysql
+
+RDEPEND=">=dev-haskell/semigroups-0.11:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+
+RDEPEND+=" dev-db/mysql-connector-c:="
+
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hspec )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}