summaryrefslogtreecommitdiff
path: root/dev-haskell/nanospec/nanospec-0.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/nanospec/nanospec-0.2.2.ebuild
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/nanospec/nanospec-0.2.2.ebuild')
-rw-r--r--dev-haskell/nanospec/nanospec-0.2.2.ebuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/dev-haskell/nanospec/nanospec-0.2.2.ebuild b/dev-haskell/nanospec/nanospec-0.2.2.ebuild
index 6d7b5ebd836c..c14d160d5dfb 100644
--- a/dev-haskell/nanospec/nanospec-0.2.2.ebuild
+++ b/dev-haskell/nanospec/nanospec-0.2.2.ebuild
@@ -3,24 +3,33 @@
EAPI=8
-# ebuild generated by hackport 0.5.5.9999
+# ebuild generated by hackport 0.8.0.0.9999
-CABAL_FEATURES="lib profile haddock hoogle hscolour" # drop test-suite: cyclic depend
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="A lightweight implementation of a subset of Hspec's API"
HOMEPAGE="https://github.com/hspec/nanospec#readme"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
-IUSE=""
-RESTRICT=test # cyclic depend: silently[test]->nanospec
-
-RDEPEND=">=dev-lang/ghc-7.4.1:=
+RDEPEND="
+ >=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10
+ >=dev-haskell/cabal-2.2.0.1
+ test? (
+ >=dev-haskell/hspec-1.3
+ >=dev-haskell/silently-1.2.4
+ )
"
+
+pkg_pretend() {
+ if use test; then
+ ewarn "The \"test\" USE flag for this package creates cycles within the"
+ ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
+ ewarn "It is recommended to leave it disabled unless explicitly testing the package."
+ fi
+}