summaryrefslogtreecommitdiff
path: root/dev-haskell/options
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/options
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/options')
-rw-r--r--dev-haskell/options/Manifest6
-rw-r--r--dev-haskell/options/metadata.xml59
-rw-r--r--dev-haskell/options/options-1.2.1.1.ebuild2
-rw-r--r--dev-haskell/options/options-1.2.1.2.ebuild32
4 files changed, 41 insertions, 58 deletions
diff --git a/dev-haskell/options/Manifest b/dev-haskell/options/Manifest
index e8500cd31691..63dc295e5d01 100644
--- a/dev-haskell/options/Manifest
+++ b/dev-haskell/options/Manifest
@@ -1,3 +1,5 @@
DIST options-1.2.1.1.tar.gz 25327 BLAKE2B 66611694e5beb558e185cd9a89e9368ebac035118360a4c1cb9bcba5ad2a0be74c32848e3983aec999b4cee6e3138c527fe31c869b52c84719ee89afe3aad232 SHA512 615a3767b74ca0ba2eae993f6e475963df2a0933f1e6c9bbfe35144c4dc6018af276144b2ec1b608b695dc7fca904784ebc63cd58a432f966588846cb36f94ea
-EBUILD options-1.2.1.1.ebuild 772 BLAKE2B 7056acf4bc03138f9dea38869e58780baec6dff985bd4e60f70ba35ce9728f44c8f4c7042ea40f77f6a1ac6d818576be13193fa36e9279f245eb7e6cc9b2c76f SHA512 3fd2e3ac90c663bdde829ada58939fe91eeeb02e46daf045dbb37f57bedf21177efebfe37fb044215e9c20768346b4ccf3be3678b7b8819ab1d639bd702730d6
-MISC metadata.xml 1804 BLAKE2B ed463a394c9fea003d56865cfad18d8dff43416a11fd2f3a5e81dd66025ff92f16cdee4d979a26208ab883b0db2476051e1e12de141aaad04d24c12a9d4a4463 SHA512 25c89b211c78d1563acc7425ca309449f50e1efd89880ba497a36b99f8cd6745f8d9974bda53dab2738fae18313eb53c3eb99a697e3d4c91939a8536aaed00a6
+DIST options-1.2.1.2.tar.gz 22693 BLAKE2B 4e17e038a910deb114182a5f98860cf4bef6ee6b03901105a23760cd108352e5be63ba762dadbd225ec10ef7c3b34c76184ccc927a36f2ff4720d6c0ee77ae5f SHA512 82c366adce56a27ab68a4388bc759b90ee4bfe38fd72325af954bef2eb3aee360729d5ed2de2964c8087b3b5a51d321321d9c02024b34b6167f09d7412aa2568
+EBUILD options-1.2.1.1.ebuild 772 BLAKE2B 573648243e4df815990ff060d32467caaaae6d6ead2ffdeebbc9325e3600be54e854cc39291d0c0b10aa283e9a572f7e9679c8222ad5e13a02ba39f51d150d6e SHA512 dbf3e919d40afba22ee0170e49f3ad6f3a1d4e86034e2517c0384f23d3a79746a0eb89b46050b5d0428d6f6554d26f1accc84a639d85d32034ddd11b9f60bef0
+EBUILD options-1.2.1.2.ebuild 797 BLAKE2B 044dec4381b7f1d82bb9ff55c30f86f9ad783e97dd9c69e3b4e28afee94fcd0275249d411d35aff6e9c706bf77bbe598d40187e2f5d5715f9e93b3c3f72ee308 SHA512 084a35d9811993a35d40ce663122f67851595edd29a98af899c977e37ff67f07fd30143a2db3f9577678cb2eace15de53f4250c2e46b5c2fd0207749b45af4d6
+MISC metadata.xml 382 BLAKE2B 4ad3abc9f16b9d6f14b226563fbbf455ffa7c9473e1070ff1bc6a4baf6f5ef4720a71bc632e0487df4d8651cc29174b284883955b500b475ecb39b0b4fbf09d1 SHA512 6c14a6f1e77ca8b9d13654a5288dfb420e5a6a5d3cb7e79a0c5f2668fbba23d57fd767e9a86301e4bcacb16ed6a80e6379b0efb277360c902fe60c17e7705399
diff --git a/dev-haskell/options/metadata.xml b/dev-haskell/options/metadata.xml
index 284861e4945d..c78c1cd7c4aa 100644
--- a/dev-haskell/options/metadata.xml
+++ b/dev-haskell/options/metadata.xml
@@ -5,59 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- The @options@ package lets library and application developers easily work
- with command-line options.
-
- The following example is a full program that can accept two options,
- @--message@ and @--quiet@:
-
- @
- import Control.Applicative
- import Options
-
- data MainOptions = MainOptions
- &amp;#x20; &amp;#x7b; optMessage :: String
- &amp;#x20; , optQuiet :: Bool
- &amp;#x20; &amp;#x7d;
-
- instance 'Options' MainOptions where
- &amp;#x20; defineOptions = pure MainOptions
- &amp;#x20; \&lt;*\&gt; simpleOption \"message\" \"Hello world!\"
- &amp;#x20; \"A message to show the user.\"
- &amp;#x20; \&lt;*\&gt; simpleOption \"quiet\" False
- &amp;#x20; \"Whether to be quiet.\"
-
- main :: IO ()
- main = runCommand $ \\opts args -&gt; do
- &amp;#x20; if optQuiet opts
- &amp;#x20; then return ()
- &amp;#x20; else putStrLn (optMessage opts)
- @
-
- &gt;$ ./hello
- &gt;Hello world!
- &gt;$ ./hello --message='ciao mondo'
- &gt;ciao mondo
- &gt;$ ./hello --quiet
- &gt;$
-
- In addition, this library will automatically create documentation options
- such as @--help@ and @--help-all@:
-
- &gt;$ ./hello --help
- &gt;Help Options:
- &gt; -h, --help
- &gt; Show option summary.
- &gt; --help-all
- &gt; Show all help options.
- &gt;
- &gt;Application Options:
- &gt; --message :: text
- &gt; A message to show the user.
- &gt; default: "Hello world!"
- &gt; --quiet :: bool
- &gt; Whether to be quiet.
- &gt; default: false
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">options</remote-id>
+ <remote-id type="github">typeclasses/options</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/options/options-1.2.1.1.ebuild b/dev-haskell/options/options-1.2.1.1.ebuild
index 2d8ab5fc7910..410373f86de7 100644
--- a/dev-haskell/options/options-1.2.1.1.ebuild
+++ b/dev-haskell/options/options-1.2.1.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# ebuild generated by hackport 0.4.4.9999
diff --git a/dev-haskell/options/options-1.2.1.2.ebuild b/dev-haskell/options/options-1.2.1.2.ebuild
new file mode 100644
index 000000000000..f8c85444f9d0
--- /dev/null
+++ b/dev-haskell/options/options-1.2.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Powerful and easy command-line option parser"
+HOMEPAGE="https://github.com/typeclasses/options/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+CABAL_CHDEPS=(
+ 'base ^>= 4.16 || ^>= 4.17 || ^>= 4.18' 'base >= 4.14 && < 5'
+)
+
+RDEPEND="
+ >=dev-haskell/monads-tf-0.3:=[profile?] <dev-haskell/monads-tf-0.4:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ >=dev-haskell/hspec-2.9.7 <dev-haskell/hspec-2.12
+ >=dev-haskell/patience-0.3 <dev-haskell/patience-0.4
+ )
+"