summaryrefslogtreecommitdiff
path: root/dev-haskell/parallel-io/parallel-io-0.3.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-31 09:12:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-31 09:12:05 +0100
commit100ce16c6fb75a4911f388aa77f860324607c869 (patch)
treede54fe6a6fd7ceb7a41fdf2b03b666c479794055 /dev-haskell/parallel-io/parallel-io-0.3.5.ebuild
parent6262f7e48882f381dea4a0751717f65e6abd212f (diff)
gentoo auto-resync : 31:07:2022 - 09:12:04
Diffstat (limited to 'dev-haskell/parallel-io/parallel-io-0.3.5.ebuild')
-rw-r--r--dev-haskell/parallel-io/parallel-io-0.3.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/parallel-io/parallel-io-0.3.5.ebuild b/dev-haskell/parallel-io/parallel-io-0.3.5.ebuild
new file mode 100644
index 000000000000..398ac7e2ae14
--- /dev/null
+++ b/dev-haskell/parallel-io/parallel-io-0.3.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -tests,-fuzz,-benchmark
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Combinators for executing IO actions in parallel on a thread pool"
+HOMEPAGE="https://batterseapower.github.com/parallel-io"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">dev-haskell/extensible-exceptions-0.1.0.1:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-benchmark \
+ --flag=-fuzz \
+ --flag=-tests
+}