summaryrefslogtreecommitdiff
path: root/dev-haskell/pipes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/pipes
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/pipes')
-rw-r--r--dev-haskell/pipes/Manifest5
-rw-r--r--dev-haskell/pipes/metadata.xml35
-rw-r--r--dev-haskell/pipes/pipes-4.1.7.ebuild30
-rw-r--r--dev-haskell/pipes/pipes-4.1.9.ebuild30
4 files changed, 100 insertions, 0 deletions
diff --git a/dev-haskell/pipes/Manifest b/dev-haskell/pipes/Manifest
new file mode 100644
index 000000000000..de4aba8bc251
--- /dev/null
+++ b/dev-haskell/pipes/Manifest
@@ -0,0 +1,5 @@
+DIST pipes-4.1.7.tar.gz 40008 BLAKE2B 88ed7685da4640d62d5065fe04065477191526990d517376a7cff8c97cbbcf939db5b062e45fe23f15b65f9fcca97d2f30be078354b47109e6d418f7055e2073 SHA512 95e4a24c156d34ac542a3535f71b60248850b228e96f90452dd6ddb1468f2f9db7a60540536568ac49b6a49d3b43caefa867c42d5e75f010e90b99fadf02827c
+DIST pipes-4.1.9.tar.gz 40061 BLAKE2B 038ebcb31bf85d79bc4dd0eff36b7c4265db81e70c58403dc3d2b5609453aad0b8e026428a6466905801f961b8267f111dee082b2ca00020f5dc305fbf2edd9e SHA512 4d285ff4ded925df8611f4e1882b4f29f4853aa8077892cfbbda245d455eea7bbf0969299dc65fd2a793655e69bf66463c330dfe7736a8f234f330b5dd4ab751
+EBUILD pipes-4.1.7.ebuild 1005 BLAKE2B f4f5eab0b3b01e359ef29be936df1f9e0cd7cf731585774b7cb4fe4c39fb450ea2b3ba3b5983acf2d87ab12c7982079c4e023d130ca6aaf5a89140f7e674e7c8 SHA512 363c187c43572a9e07ab941edbff8b8c66c154c78dd2621e9ad8d6f765eb294849a62a2f81ef5678c3823c253bd174beeabf6d18d6df0707d08af4ee339568c2
+EBUILD pipes-4.1.9.ebuild 1003 BLAKE2B 30ce3ff21a8cf00070540e0c415ed2397e90e868f3b7cc0717b4bc93b54ae3962628cbff2b763a4600afa0fde401b98427f934d398a6b745fc2c195201224e93 SHA512 4bb476bdbf4535752b186fe7c92e0a98260af2ef69560d08f0933fe33aac92acd65a8ad6c2aa6658c659a2be1c543679d101097a0ac760cfe5ce9987503d776f
+MISC metadata.xml 1137 BLAKE2B b09460dcaf0d62c841207279c3911029f7ca9f96e663a8758f15dcfc2b4fa8314ba072cf93567d3368e75c8ed7adb0cd9acbb177b81f5e8190f0c47db917a8c7 SHA512 737ad4a728bac17368fd8da2856d97c545f0701399cc6496ac0e488e7e9dc3e23c2b797ebb614f73c013d74808d7d2e081dc512a87f929941b9ab40578c7ccf7
diff --git a/dev-haskell/pipes/metadata.xml b/dev-haskell/pipes/metadata.xml
new file mode 100644
index 000000000000..04e0c63037a8
--- /dev/null
+++ b/dev-haskell/pipes/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ \"Coroutines done right\". This library generalizes iteratees and coroutines
+ simply and elegantly.
+
+ Advantages over traditional iteratee\/coroutine implementations:
+
+ * /Concise API/: Use three simple commands: ('&gt;-&gt;'), 'request', and 'respond'
+
+ * /Bidirectionality/: Implement duplex channels
+
+ * /Blazing fast/: Implementation tuned for speed
+
+ * /Elegant semantics/: Use practical category theory
+
+ * /Extension Framework/: Mix and match extensions and create your own
+
+ * /ListT/: Correct implementation of ListT that interconverts with pipes
+
+ * /Lightweight Dependency/: @pipes@ depends only on @transformers@ and
+ @mmorph@ and compiles rapidly
+
+ * /Extensive Documentation/: Second to none!
+
+ Import "Control.Proxy" to use the library.
+
+ Read "Control.Proxy.Tutorial" for an extensive tutorial.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/pipes/pipes-4.1.7.ebuild b/dev-haskell/pipes/pipes-4.1.7.ebuild
new file mode 100644
index 000000000000..21d7be81f5ea
--- /dev/null
+++ b/dev-haskell/pipes/pipes-4.1.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Compositional pipelines"
+HOMEPAGE="http://hackage.haskell.org/package/pipes"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mmorph-1.0.0:=[profile?] <dev-haskell/mmorph-1.1:=[profile?]
+ >=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/transformers-0.2.0.0:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-3
+ >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-1
+ >=dev-haskell/test-framework-quickcheck2-0.2.0 <dev-haskell/test-framework-quickcheck2-0.4 )
+"
diff --git a/dev-haskell/pipes/pipes-4.1.9.ebuild b/dev-haskell/pipes/pipes-4.1.9.ebuild
new file mode 100644
index 000000000000..22da3eca8507
--- /dev/null
+++ b/dev-haskell/pipes/pipes-4.1.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Compositional pipelines"
+HOMEPAGE="http://hackage.haskell.org/package/pipes"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mmorph-1.0.0:=[profile?] <dev-haskell/mmorph-1.1:=[profile?]
+ >=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/transformers-0.2.0.0:=[profile?] <dev-haskell/transformers-0.6:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-3
+ >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-1
+ >=dev-haskell/test-framework-quickcheck2-0.2.0 <dev-haskell/test-framework-quickcheck2-0.4 )
+"