summaryrefslogtreecommitdiff
path: root/dev-haskell/project-template
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/project-template
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/project-template')
-rw-r--r--dev-haskell/project-template/Manifest3
-rw-r--r--dev-haskell/project-template/metadata.xml14
-rw-r--r--dev-haskell/project-template/project-template-0.2.0.ebuild33
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/project-template/Manifest b/dev-haskell/project-template/Manifest
new file mode 100644
index 000000000000..9f3c2b2e2b43
--- /dev/null
+++ b/dev-haskell/project-template/Manifest
@@ -0,0 +1,3 @@
+DIST project-template-0.2.0.tar.gz 8251 BLAKE2B d8f15dbb5ffb221dbcfff8152ecbba1701cca7c70a4e5c1c62a4603de15ea028b78035d8b0a97550aed6a4eba0fe8f213b0fe3d957cb259da79f73dbb90d3dfa SHA512 923c0d9e5cac14c05474adc743cfb8030ed8e08e69c4eb35b77c2cb1c64b44f10058693d1a5880ba983040ea9dbf1f28f815cd274a75de302f3afdb928210cad
+EBUILD project-template-0.2.0.ebuild 947 BLAKE2B 5640df1ad2c10ef0956737f1fab20a0b718734b8b13d75160691b4be648ace6a44dc4c3695edff3fca49559e7c49f73e1e1224e49ad22a8865f547f8cb69b4cc SHA512 ef33955e13e174f60d6412e2aae7e67a453e0d656b3b6953ba5bb5c77327ee51d3e1805518fc065deedf25d737efcdc6ec989eea48f60e9ca739706ba43553e3
+MISC metadata.xml 473 BLAKE2B 44833b539388eff5933fd11cfbd44e13e8ab4e2467db43abd30f3dd1ad1321d138fefa5f8159addae0055549dc2b9079246291c8d4e2d1376f578e65d660fecd SHA512 01ad6354d405c737c1e54aef0ff5f3d643c2abe73239a0e3663c7d23d31bbf3cc8f187c98a77393ad13df105e344af384bce6e33570e7a4d60aa2f7e1b307de0
diff --git a/dev-haskell/project-template/metadata.xml b/dev-haskell/project-template/metadata.xml
new file mode 100644
index 000000000000..7d1ebfc1027f
--- /dev/null
+++ b/dev-haskell/project-template/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ See initial blog post for explanation: &lt;http://www.yesodweb.com/blog/2012/09/project-templates&gt;
+ </longdescription>
+ <upstream>
+ <remote-id type="github">fpco/haskell-ide</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/project-template/project-template-0.2.0.ebuild b/dev-haskell/project-template/project-template-0.2.0.ebuild
new file mode 100644
index 000000000000..eb5556792443
--- /dev/null
+++ b/dev-haskell/project-template/project-template-0.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Specify Haskell project templates and generate files"
+HOMEPAGE="https://github.com/fpco/haskell-ide"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/conduit-extra:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?]
+ >=dev-haskell/resourcet-0.4.3:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/quickcheck )
+"