summaryrefslogtreecommitdiff
path: root/dev-haskell/shakespeare-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/shakespeare-text
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/shakespeare-text')
-rw-r--r--dev-haskell/shakespeare-text/Manifest5
-rw-r--r--dev-haskell/shakespeare-text/metadata.xml22
-rw-r--r--dev-haskell/shakespeare-text/shakespeare-text-1.0.2.ebuild28
-rw-r--r--dev-haskell/shakespeare-text/shakespeare-text-1.1.0.ebuild25
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-haskell/shakespeare-text/Manifest b/dev-haskell/shakespeare-text/Manifest
new file mode 100644
index 000000000000..b523755410cf
--- /dev/null
+++ b/dev-haskell/shakespeare-text/Manifest
@@ -0,0 +1,5 @@
+DIST shakespeare-text-1.0.2.tar.gz 4623 BLAKE2B 3e0b501cfffb883e0876d95424ab199bed46dcca24dae48622d79c2ab614b9ca93b03721e77860962c4118f8903060c43cf54a18e5657d632ac3bb3a37036898 SHA512 45ad9251e9aeda71c29b1350e0c3e6dd8ce7d3695d6be89fbcb82dc47aff6d9aaceaa00b514a885691c546c709782f0f2318bb835fea711863c04f6f9c5798ea
+DIST shakespeare-text-1.1.0.tar.gz 1810 BLAKE2B a352a5efde2437233460a7aa3544f2c2f0d6bb6e68a8b3763fa49ece62e922a89cd8ee11baddff846467756014aa2e44df2fd1cee99ca97523226402bc5d1eef SHA512 45dce0a8ef5e0b45466110fdae3ce73fa6fa053d1c68afc0f7aab20726474b34e7ca3ddde6882e40cd2cd8d37ba2e0f7f4064260879c4dbb81ccd2dd5daadb5b
+EBUILD shakespeare-text-1.0.2.ebuild 769 BLAKE2B b17edb1bf6df834627f51ee52bc405a357268bfc4fb0e2fbdc3ea645e4c8652ab3587f0d5c2e25c55a155e8c1e25a705d4fda997551223733bacdcdb47e1a9e0 SHA512 febd9a34cf9af7892f3f3a59941c23a9b6abb04c88b8a5f52276380a75ba16cad6965e4d02b721babd68b2bb4ecada35466ab6ce919e505948297a49eb40db26
+EBUILD shakespeare-text-1.1.0.ebuild 615 BLAKE2B 9f62a93c03027aa04bf6078f5263f6766ee61af4fe336520c51c9cc7b7b39c41a4159834fffbab5803373c6831586b07b0172007604bc23bf078029c233c5b76 SHA512 9b4cfac47f5c34148bb8a79667c44ce3464240aeaee1eb3e6afde1eaabd5dce6b7cce63bc57232d44d5cf488b36f70ac634ccf20ec2107ca2a71721ae32db8e7
+MISC metadata.xml 1564 BLAKE2B 86ee591e45ff13cf0aa6474ce4d4c9569bb63515f233d4635fec3151f2f5b8a88f8c04c90b97878cf1f521de70af6036ace1e690989575f2258896dd21def0e2 SHA512 39742b1ffaf3052e1e79465a3b0fa0e9792b898256d3bf9c5beca2908678305eaa28a942c671ff6cd653bcf4621b05cc96b16869c58f1b9ec87399707aae20dd
diff --git a/dev-haskell/shakespeare-text/metadata.xml b/dev-haskell/shakespeare-text/metadata.xml
new file mode 100644
index 000000000000..3ce699212101
--- /dev/null
+++ b/dev-haskell/shakespeare-text/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ interpolation with quasi-quotation: stick haskell variables into haskell strings
+
+ Note there is no dependency on haskell-src-extras. If you don't mind that dependency, you may want to look at using these packages: Interpolation, interpolatedstring-perl6, interpolatedstring-qq.
+
+ This package has 1 other general feature that those others may not (but would be easy to duplicate): instead of using quasi-quoting you can also use an external file. It also has url/embeding interpolation, with \@ and \^, which are used in Yesod.
+
+ This package also uses blaze-builder for efficiently constructing strings (I am not sure what the other packages use). This might be of interest to you for large templates or performance sensitive code, or otherwise having a nice interface to blaze-builder
+
+ Shakespeare is a template family for type-safe, efficient templates with simple variable interpolation . Shakespeare templates can be used inline with a quasi-quoter or in an external file. Shakespeare interpolates variables according to the type being inserted.
+ In this case, the variable type needs a ToText instance.
+
+ Please see http://docs.yesodweb.com/book/templates for a more thorough description and examples of the shakespeare family of template languages.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/shakespeare-text/shakespeare-text-1.0.2.ebuild b/dev-haskell/shakespeare-text/shakespeare-text-1.0.2.ebuild
new file mode 100644
index 000000000000..48a9e84b9b2b
--- /dev/null
+++ b/dev-haskell/shakespeare-text/shakespeare-text-1.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Interpolation with quasi-quotation: put variables strings"
+HOMEPAGE="https://www.yesodweb.com/book/shakespearean-templates"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/shakespeare-1.0:=[profile?] <dev-haskell/shakespeare-1.3:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/hunit )
+"
diff --git a/dev-haskell/shakespeare-text/shakespeare-text-1.1.0.ebuild b/dev-haskell/shakespeare-text/shakespeare-text-1.1.0.ebuild
new file mode 100644
index 000000000000..09de57854562
--- /dev/null
+++ b/dev-haskell/shakespeare-text/shakespeare-text-1.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile"
+inherit haskell-cabal
+
+DESCRIPTION="Interpolation with quasi-quotation: put variables strings (deprecated)"
+HOMEPAGE="https://www.yesodweb.com/book/shakespearean-templates"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/shakespeare-2.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"