summaryrefslogtreecommitdiff
path: root/dev-haskell/skylighting
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/skylighting
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/skylighting')
-rw-r--r--dev-haskell/skylighting/Manifest4
-rw-r--r--dev-haskell/skylighting/metadata.xml13
-rw-r--r--dev-haskell/skylighting/skylighting-0.14.ebuild39
3 files changed, 44 insertions, 12 deletions
diff --git a/dev-haskell/skylighting/Manifest b/dev-haskell/skylighting/Manifest
index df10e6bf96d2..088dd1cba03d 100644
--- a/dev-haskell/skylighting/Manifest
+++ b/dev-haskell/skylighting/Manifest
@@ -1,3 +1,5 @@
DIST skylighting-0.12.3.1.tar.gz 1218260 BLAKE2B 78f26d3477a6327a8e3c99f31ffe3c1d1b57c86730c06f715d8b2db9d267526bf3d0605639679fc38e4faff06e81edc3d2c9d85e7ce3c557b73f47ae8e81b999 SHA512 3eb93400612992d5aed828ebe0c1b76dbfbd7ec9cd0d0d667b524df51968997ffd429bfdbecbaa32a6108903872e119614b16f8aedf00eaf6d9a7b79ccb06c58
+DIST skylighting-0.14.tar.gz 1393626 BLAKE2B 884f990b77d38c71287486ec0c2d652bf408a21878b11cac071053616b78ea759e83cd8f4c54befdffb2d4b32dbd352e2adc5db20bfacb1209866e1992c645b1 SHA512 33d36f7181c0a6b94d3319707d6ea68199239a7699c18c6392e8ae49d97d7249f57f4d42a9fb09fa9df643268aa57b8e42e2204a6a002f8222ef00284dfd25d4
EBUILD skylighting-0.12.3.1.ebuild 889 BLAKE2B 4f51ea6b53c5da6427549ec099627de7e7d39d1e3f4ed1e9957a9c03ec907359ff55729b625dcf919532f8d2ebe0ecfe18061e178c2c1e794038dec6aa0337c5 SHA512 d7662b3d5ef055f637a9923cb8d37ecb9509ba8818599917b0c09311e40676ad7ec8fb41ae8db535646eb316be2f4289a062f23c4d83b383a2d2e5b8e9c55dc1
-MISC metadata.xml 825 BLAKE2B b862bc0c5008560c8891833b873e74ef8d492992004dd96113e518064b348bd9e152ba36d557cfdd1951251b43498312e8973506748d9880c4c71b12b0af9b41 SHA512 abab3be7afa35a67923015eeab7c21b419a1a299c6c728a7ea226c648dc5611e50f332cb3d5f061bcec3a0b25dffd97dfa708707e690f0fcce6b5757df7cb6df
+EBUILD skylighting-0.14.ebuild 1308 BLAKE2B 530ad2e6ed884334878a79e1e7384a7f01810ea4057d8de136da1a473fae656aad80d4a8d8b102795eb07efea85a5f59fac81ff10eb2c8453b7e224fc9d3a5da SHA512 d8eeb796ed91fe7f07d5ccd890d3443d013f110f9238847f2478d8ba0c52662e10d5d593ace75b9bce1ff161684077cb6bec4220ca1e2c57892c9fdf4579f0b4
+MISC metadata.xml 471 BLAKE2B e8b92bf49ac2f4ba1be4ab690f9c7590820af83dcf5d98664b2e85283478adeb624b86581b03d3a30e00ba316d92115f02b95db8092fc01d741b32cd525bf8ac SHA512 7a03298de1c08d135da43705e9a6f17414f36820fa49726d722d78dce6b9a7c466b957007569d62c9d0fe28fffbf09372af32ed98746b915517eef8b17743d74
diff --git a/dev-haskell/skylighting/metadata.xml b/dev-haskell/skylighting/metadata.xml
index 05c0818ed2d1..bd25baabc366 100644
--- a/dev-haskell/skylighting/metadata.xml
+++ b/dev-haskell/skylighting/metadata.xml
@@ -6,19 +6,10 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
- <flag name="executable">Build the skylighting executable.</flag>
+ <flag name="executable">Whether to build the skylighting program</flag>
</use>
- <longdescription>
- Skylighting is a syntax highlighting library with
- support for over one hundred languages. It derives
- its tokenizers from XML syntax definitions used
- by KDE's KSyntaxHighlighting framework, so any
- syntax supported by that framework can be added.
- An optional command-line program is provided.
- Skylighting is intended to be the successor to
- highlighting-kate.
- </longdescription>
<upstream>
+ <remote-id type="hackage">skylighting</remote-id>
<remote-id type="github">jgm/skylighting</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/skylighting/skylighting-0.14.ebuild b/dev-haskell/skylighting/skylighting-0.14.ebuild
new file mode 100644
index 000000000000..a7b302f95c3b
--- /dev/null
+++ b/dev-haskell/skylighting/skylighting-0.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: -bootstrap,+system-pcre
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="syntax highlighting library"
+HOMEPAGE="https://github.com/jgm/skylighting"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="executable"
+
+RDEPEND="~dev-haskell/skylighting-core-0.14:=[profile?]
+ >=dev-haskell/skylighting-format-ansi-0.1:=[profile?] <dev-haskell/skylighting-format-ansi-0.2:=[profile?]
+ >=dev-haskell/skylighting-format-blaze-html-0.1:=[profile?] <dev-haskell/skylighting-format-blaze-html-0.2:=[profile?]
+ >=dev-haskell/skylighting-format-context-0.1:=[profile?] <dev-haskell/skylighting-format-context-0.2:=[profile?]
+ >=dev-haskell/skylighting-format-latex-0.1:=[profile?] <dev-haskell/skylighting-format-latex-0.2:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+ executable? ( >=dev-haskell/blaze-html-0.5:=[profile?]
+ dev-haskell/pretty-show:=[profile?]
+ dev-haskell/text:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bootstrap \
+ $(cabal_flag executable executable) \
+ --flag=system-pcre
+}