summaryrefslogtreecommitdiff
path: root/dev-haskell/stack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-24 08:52:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-24 08:52:43 +0100
commit28267a5e528b273fbd1b0f5f52ecaab4b03016ab (patch)
treef2c2ddc5cf19fcbc848cc9fe427df5abd8ac0339 /dev-haskell/stack
parente19b21c73e5feac42ade97baf3eeb45c58a2f234 (diff)
gentoo auto-resync : 24:07:2022 - 08:52:43
Diffstat (limited to 'dev-haskell/stack')
-rw-r--r--dev-haskell/stack/Manifest7
-rw-r--r--dev-haskell/stack/files/stack-2.5.1.1-disable-network-tests.patch22
-rw-r--r--dev-haskell/stack/metadata.xml7
-rw-r--r--dev-haskell/stack/stack-2.3.3.ebuild114
-rw-r--r--dev-haskell/stack/stack-2.7.6_pre20220421.ebuild120
5 files changed, 148 insertions, 122 deletions
diff --git a/dev-haskell/stack/Manifest b/dev-haskell/stack/Manifest
index 284fe433110c..383d776bb556 100644
--- a/dev-haskell/stack/Manifest
+++ b/dev-haskell/stack/Manifest
@@ -1,3 +1,4 @@
-DIST stack-2.3.3.tar.gz 572406 BLAKE2B 4b88614ede72ea3704e3bfad433a7931860c1c098bb65aeabca46d3abc5364ea132b8a7f0f559f1b07463d4b753b5501081841fa388a5d817389d91371214236 SHA512 cb93e3bcb8f92e01f374806f07f366ca318d66e3b7bd3cfa3fe3b72dce954d2bb371f51e3f79fca8aec19d1d3adef370bb09237bf29340a1bc851a9a103d77a3
-EBUILD stack-2.3.3.ebuild 4423 BLAKE2B 5177202463107ecff37070acb36e00364e58605ca2b03595d39b4f663d626b9005fa6ecba453fb88044371dbeb50fc8ce9ea01a9194d565137f4f4f1cce1dde5 SHA512 18123b478813591ae8a820163ce37881dc8c5df9d0c91039cb2e115c5318a15b7857429424cdcb0bf42fafd3451b58e9ba40e5809256b09c0f516233e03749a8
-MISC metadata.xml 1015 BLAKE2B 4f3ec198f368de207d8d7e4ea07efc279ef6693ca8a200c280f6527d607f83139fbae82cc403552098c4d17e0d215d614e8d03828ca317ee7f96204e2227de34 SHA512 210f4aa3465a9a212c1b7775713bd77f683f3695888f7304b067fd3e3d861b003144bf08435dce7d9294b3b6850b60ea3d73c74c833b8c0c7fa82f64cb7d1132
+AUX stack-2.5.1.1-disable-network-tests.patch 1044 BLAKE2B 79c15a2c5f6f704454e4f36702a872a70d7074729daf885017a41bc976ef2d3d2c29fdec202724865d6b3742fb10f70444e2e17e68848300652290da1db5321f SHA512 8c023c8313c82b3b0f952318d6ca3bb979855bf504a77584124c0cc154ea0484fe05de0eec3b83a0f6f74b2b05d79a9fe12b14cd696bcd7396cad713d1eef4fb
+DIST stack-dcf7bb31815c7505e809a1707909832e02614501.tar.gz 692782 BLAKE2B 75cebf81e57c33bd694f5b3ee99e6eeb61b185f2a92a41f4bf5c6433de356d6bc5e79995ed5564146abbc549d83b6ffcceece1304a9ed7edafb63dfdb75b26cc SHA512 defe35a301decb950ea5aaa595e1f3b49aaeadbd0ff81f1b22e9967b35f5ce5a934e102aa87049d4bfb40df58ca0180f1788dfc2a987c5b0ad56437b4d49eab7
+EBUILD stack-2.7.6_pre20220421.ebuild 3937 BLAKE2B dd4e69f8aa573a46ff7c650f09b0f8e186f6181ac647e47c0d4e12987cf6acfc4524f7917bcd5dbf1529319fa14ffbfaf85e5f7ec8160b59049546743b10a2e9 SHA512 128c83adc01293c7491375f6d853565169e21074f07ca1de61e614128a5eb625db458303f4100391d9c2f391d1547f1b2410188c3f0d28416aaf693cc95956b2
+MISC metadata.xml 901 BLAKE2B 7db40fadaf36879895676507e84b87c97350dd723745691251691cee5055a1e388c2949edd9e5fd9cc5d3e2e46c9009bb3b42fdf6c9ce4c998dff3be0671c709 SHA512 310b07321f02b3f771ea736187c9e5546dee435ef5a074603735eba721edba983796f3af0e023a415c7baf598b8904f14aaa297b44ba20408816453b5ecdaf5d
diff --git a/dev-haskell/stack/files/stack-2.5.1.1-disable-network-tests.patch b/dev-haskell/stack/files/stack-2.5.1.1-disable-network-tests.patch
new file mode 100644
index 000000000000..d3890d16af9a
--- /dev/null
+++ b/dev-haskell/stack/files/stack-2.5.1.1-disable-network-tests.patch
@@ -0,0 +1,22 @@
+diff --git a/src/test/Stack/ConfigSpec.hs b/src/test/Stack/ConfigSpec.hs
+index 0b1b93f..d047d86 100644
+--- a/src/test/Stack/ConfigSpec.hs
++++ b/src/test/Stack/ConfigSpec.hs
+@@ -183,7 +183,7 @@ spec = beforeAll setup $ do
+ boptsReconfigure `shouldBe` True
+ boptsCabalVerbose `shouldBe` True
+
+- it "finds the config file in a parent directory" $ inTempDir $ do
++ xit "finds the config file in a parent directory" $ inTempDir $ do
+ writeFile "package.yaml" "name: foo"
+ writeFile (toFilePath stackDotYaml) sampleConfig
+ parentDir <- getCurrentDirectory >>= parseAbsDir
+@@ -194,7 +194,7 @@ spec = beforeAll setup $ do
+ bc <- runRIO config $ withBuildConfig ask
+ view projectRootL bc `shouldBe` parentDir
+
+- it "respects the STACK_YAML env variable" $ inTempDir $ do
++ xit "respects the STACK_YAML env variable" $ inTempDir $ do
+ withSystemTempDir "config-is-here" $ \dir -> do
+ let stackYamlFp = toFilePath (dir </> stackDotYaml)
+ writeFile stackYamlFp sampleConfig
diff --git a/dev-haskell/stack/metadata.xml b/dev-haskell/stack/metadata.xml
index ca426bb23b02..cf86fa7b9a08 100644
--- a/dev-haskell/stack/metadata.xml
+++ b/dev-haskell/stack/metadata.xml
@@ -5,19 +5,16 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <use>
- <flag name="developer-mode">By default, should extra developer information be output?</flag>
- </use>
<longdescription>
Please see the documentation at &lt;https://docs.haskellstack.org&gt;
for usage information.
-
+
If building a 'stack' executable for distribution, please download the
source code from &lt;https://github.com/commercialhaskell/stack/releases&gt;
and build it using Stack itself in order to ensure identical behaviour
to official binaries. This package on Hackage is provided for convenience
and bootstrapping purposes.
-
+
Note that the API for the library is not currently stable, and may
change significantly, even between minor releases. It is
currently only intended for use by the executable.
diff --git a/dev-haskell/stack/stack-2.3.3.ebuild b/dev-haskell/stack/stack-2.3.3.ebuild
deleted file mode 100644
index 3b0a49f834fc..000000000000
--- a/dev-haskell/stack/stack-2.3.3.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.6.9999
-#hackport: flags: -disable-git-info,-hide-dependency-versions,-integration-tests,-static,-supported-build
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="The Haskell Tool Stack"
-HOMEPAGE="https://haskellstack.org"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="developer-mode"
-
-RESTRICT=test # requires network access
-
-RDEPEND=">=dev-haskell/aeson-1.4.6.0:=[profile?]
- >=dev-haskell/annotated-wl-pprint-0.7.0:=[profile?]
- >=dev-haskell/ansi-terminal-0.9.1:=[profile?]
- >=dev-haskell/async-2.2.2:=[profile?]
- >=dev-haskell/attoparsec-0.13.2.3:=[profile?]
- >=dev-haskell/base64-bytestring-1.0.0.3:=[profile?]
- >=dev-haskell/cabal-3.0.0.0:=[profile?]
- >=dev-haskell/casa-client-0.0.1:=[profile?]
- >=dev-haskell/casa-types-0.0.1:=[profile?]
- >=dev-haskell/colour-2.3.5:=[profile?]
- >=dev-haskell/conduit-1.3.1.2:=[profile?]
- >=dev-haskell/conduit-extra-1.3.4:=[profile?]
- >=dev-haskell/cryptonite-0.25:=[profile?]
- >=dev-haskell/cryptonite-conduit-0.2.2:=[profile?]
- >=dev-haskell/echo-0.1.3:=[profile?]
- >=dev-haskell/exceptions-0.10.4:=[profile?]
- >=dev-haskell/extra-1.6.19:=[profile?]
- >=dev-haskell/file-embed-0.0.11.1:=[profile?]
- >=dev-haskell/filelock-0.1.1.5:=[profile?]
- >=dev-haskell/fsnotify-0.3.0.1:=[profile?]
- >=dev-haskell/generic-deriving-1.12.4:=[profile?]
- >=dev-haskell/githash-0.1.3.3:=[profile?]
- >=dev-haskell/hackage-security-0.5.3.0:=[profile?]
- >=dev-haskell/hashable-1.2.7.0:=[profile?]
- >=dev-haskell/hi-file-parser-0.1.0.0:=[profile?]
- >=dev-haskell/hpack-0.33.0:=[profile?]
- >=dev-haskell/http-client-0.6.4:=[profile?]
- >=dev-haskell/http-client-tls-0.3.5.3:=[profile?]
- >=dev-haskell/http-conduit-2.3.7.3:=[profile?]
- >=dev-haskell/http-download-0.2.0.0:=[profile?]
- >=dev-haskell/http-types-0.12.3:=[profile?]
- >=dev-haskell/memory-0.14.18:=[profile?]
- >=dev-haskell/microlens-0.4.10:=[profile?]
- >=dev-haskell/mintty-0.1.2:=[profile?]
- >=dev-haskell/mono-traversable-1.0.15.1:=[profile?]
- >=dev-haskell/mtl-2.2.2:=[profile?]
- >=dev-haskell/mustache-2.3.1:=[profile?]
- >=dev-haskell/neat-interpolation-0.3.2.6:=[profile?]
- >=dev-haskell/network-uri-2.6.2.0:=[profile?]
- >=dev-haskell/open-browser-0.2.1.0:=[profile?]
- >=dev-haskell/optparse-applicative-0.14.3.0:=[profile?]
- >=dev-haskell/optparse-simple-0.1.1.2:=[profile?]
- >=dev-haskell/pantry-0.4:=[profile?] <dev-haskell/pantry-0.5:=[profile?]
- >=dev-haskell/path-0.6.1:=[profile?]
- >=dev-haskell/path-io-1.4.2:=[profile?]
- >=dev-haskell/persistent-2.9.2:=[profile?]
- >=dev-haskell/persistent-sqlite-2.9.3:=[profile?]
- >=dev-haskell/persistent-template-2.6.0:=[profile?]
- >=dev-haskell/primitive-0.6.4.0:=[profile?]
- >=dev-haskell/project-template-0.2.0.1:=[profile?]
- >=dev-haskell/regex-applicative-text-0.1.0.1:=[profile?]
- >=dev-haskell/retry-0.8.1.0:=[profile?]
- >=dev-haskell/rio-0.1.14.0:=[profile?]
- >=dev-haskell/rio-prettyprint-0.1.0.0:=[profile?]
- >=dev-haskell/semigroups-0.18.5:=[profile?]
- >=dev-haskell/split-0.2.3.3:=[profile?]
- >=dev-haskell/stm-2.5.0.0:=[profile?]
- >=dev-haskell/streaming-commons-0.2.1.2:=[profile?]
- >=dev-haskell/tar-0.5.1.1:=[profile?]
- >=dev-haskell/temporary-1.3:=[profile?]
- >=dev-haskell/text-1.2.3.1:=[profile?]
- >=dev-haskell/text-metrics-0.3.0:=[profile?]
- >=dev-haskell/th-reify-many-0.1.9:=[profile?]
- >=dev-haskell/tls-1.4.1:=[profile?]
- >=dev-haskell/typed-process-0.2.6.0:=[profile?]
- >=dev-haskell/unicode-transforms-0.3.6:=[profile?]
- >=dev-haskell/unix-compat-0.5.2:=[profile?]
- >=dev-haskell/unliftio-0.2.12:=[profile?]
- >=dev-haskell/unordered-containers-0.2.10.0:=[profile?]
- >=dev-haskell/vector-0.12.1.2:=[profile?]
- >=dev-haskell/yaml-0.11.2.0:=[profile?]
- >=dev-haskell/zip-archive-0.4.1:=[profile?]
- >=dev-haskell/zlib-0.6.2.1:=[profile?]
- >=dev-lang/ghc-8.6.5:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.4.0.1
- test? ( >=dev-haskell/hspec-2.7.1
- >=dev-haskell/quickcheck-2.13.2
- >=dev-haskell/raw-strings-qq-1.1
- >=dev-haskell/smallcheck-1.1.5 )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag developer-mode developer-mode) \
- --flag=-disable-git-info \
- --flag=-hide-dependency-versions \
- --flag=-integration-tests \
- --flag=-static \
- --flag=-supported-build
-}
diff --git a/dev-haskell/stack/stack-2.7.6_pre20220421.ebuild b/dev-haskell/stack/stack-2.7.6_pre20220421.ebuild
new file mode 100644
index 000000000000..dba4ac39a16a
--- /dev/null
+++ b/dev-haskell/stack/stack-2.7.6_pre20220421.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: -disable-git-info,-hide-dependency-versions,-integration-tests,-static,-supported-build,-developer-mode
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="The Haskell Tool Stack"
+HOMEPAGE="https://haskellstack.org"
+
+# hololeap <hololeap@protonmail.com> (2022-04-21)
+# Current released version (2.7.5) has issues with Cabal-3.4,
+# use latest upstream HEAD which has fixes.
+REPO_URI="https://github.com/commercialhaskell/stack"
+COMMIT="dcf7bb31815c7505e809a1707909832e02614501"
+BRANCH="master"
+SRC_URI="${REPO_URI}/archive/${COMMIT}.tar.gz -> ${PN}-${COMMIT}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+CABAL_FILE="${S}/${PN}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}/${PN}-2.5.1.1-disable-network-tests.patch" )
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/annotated-wl-pprint:=[profile?]
+ dev-haskell/ansi-terminal:=[profile?]
+ dev-haskell/async:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ dev-haskell/cabal:=[profile?]
+ dev-haskell/casa-client:=[profile?]
+ dev-haskell/casa-types:=[profile?]
+ dev-haskell/colour:=[profile?]
+ dev-haskell/conduit:=[profile?]
+ dev-haskell/conduit-extra:=[profile?]
+ dev-haskell/cryptonite:=[profile?]
+ dev-haskell/cryptonite-conduit:=[profile?]
+ dev-haskell/echo:=[profile?]
+ dev-haskell/extra:=[profile?]
+ dev-haskell/file-embed:=[profile?]
+ dev-haskell/filelock:=[profile?]
+ dev-haskell/fsnotify:=[profile?]
+ dev-haskell/generic-deriving:=[profile?]
+ dev-haskell/githash:=[profile?]
+ dev-haskell/hackage-security:=[profile?]
+ dev-haskell/hashable:=[profile?]
+ dev-haskell/hi-file-parser:=[profile?]
+ dev-haskell/hpack:=[profile?]
+ dev-haskell/http-client:=[profile?]
+ dev-haskell/http-client-tls:=[profile?]
+ dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-download:=[profile?]
+ dev-haskell/http-types:=[profile?]
+ dev-haskell/memory:=[profile?]
+ dev-haskell/microlens:=[profile?]
+ dev-haskell/mintty:=[profile?]
+ dev-haskell/mono-traversable:=[profile?]
+ dev-haskell/mustache:=[profile?]
+ dev-haskell/neat-interpolation:=[profile?]
+ dev-haskell/network-uri:=[profile?]
+ dev-haskell/open-browser:=[profile?]
+ >=dev-haskell/optparse-applicative-0.14.3.0:=[profile?]
+ dev-haskell/optparse-simple:=[profile?]
+ >=dev-haskell/pantry-0.5.3:=[profile?]
+ dev-haskell/path:=[profile?]
+ dev-haskell/path-io:=[profile?]
+ dev-haskell/persistent:=[profile?]
+ dev-haskell/persistent-sqlite:=[profile?]
+ dev-haskell/persistent-template:=[profile?]
+ dev-haskell/primitive:=[profile?]
+ dev-haskell/project-template:=[profile?]
+ dev-haskell/retry:=[profile?]
+ >=dev-haskell/rio-0.1.21.0:=[profile?]
+ >=dev-haskell/rio-prettyprint-0.1.1.0:=[profile?]
+ dev-haskell/semigroups:=[profile?]
+ dev-haskell/split:=[profile?]
+ dev-haskell/stm:=[profile?]
+ dev-haskell/streaming-commons:=[profile?]
+ dev-haskell/tar:=[profile?]
+ dev-haskell/temporary:=[profile?]
+ dev-haskell/text-metrics:=[profile?]
+ dev-haskell/th-reify-many:=[profile?]
+ dev-haskell/tls:=[profile?]
+ dev-haskell/typed-process:=[profile?]
+ dev-haskell/unicode-transforms:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ dev-haskell/unliftio:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ dev-haskell/yaml:=[profile?]
+ dev-haskell/zip-archive:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? (
+ dev-haskell/hspec
+ dev-haskell/quickcheck
+ dev-haskell/raw-strings-qq
+ dev-haskell/smallcheck
+ )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer-mode \
+ --flag=-disable-git-info \
+ --flag=-hide-dependency-versions \
+ --flag=-integration-tests \
+ --flag=-static \
+ --flag=-supported-build
+}