summaryrefslogtreecommitdiff
path: root/dev-haskell/tasty/tasty-1.4.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
commitfd70f5e3ed54d5e013c11a3f3e632e80838171d0 (patch)
treec6bf0dac8239e644ccc09b184e4eb9cca9701dcf /dev-haskell/tasty/tasty-1.4.2.3.ebuild
parent5deadca7219297a3c1f90eca00544a00e33efdbc (diff)
gentoo auto-resync : 23:07:2022 - 02:48:51
Diffstat (limited to 'dev-haskell/tasty/tasty-1.4.2.3.ebuild')
-rw-r--r--dev-haskell/tasty/tasty-1.4.2.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/tasty/tasty-1.4.2.3.ebuild b/dev-haskell/tasty/tasty-1.4.2.3.ebuild
new file mode 100644
index 000000000000..4f69152fb684
--- /dev/null
+++ b/dev-haskell/tasty/tasty-1.4.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: +clock,+unix
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Modern and extensible testing framework"
+HOMEPAGE="https://github.com/UnkindPartition/tasty"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.9:=[profile?]
+ >=dev-haskell/clock-0.4.4.0:=[profile?]
+ >=dev-haskell/optparse-applicative-0.14:=[profile?]
+ >=dev-haskell/stm-2.3:=[profile?]
+ >=dev-haskell/tagged-0.5:=[profile?]
+ >=dev-haskell/unbounded-delays-0.1:=[profile?]
+ dev-haskell/wcwidth:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=clock \
+ --flag=unix
+}