summaryrefslogtreecommitdiff
path: root/dev-haskell/text-short
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/text-short
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/text-short')
-rw-r--r--dev-haskell/text-short/Manifest3
-rw-r--r--dev-haskell/text-short/metadata.xml16
-rw-r--r--dev-haskell/text-short/text-short-0.1.3.ebuild44
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-haskell/text-short/Manifest b/dev-haskell/text-short/Manifest
new file mode 100644
index 000000000000..76d78d0019ff
--- /dev/null
+++ b/dev-haskell/text-short/Manifest
@@ -0,0 +1,3 @@
+DIST text-short-0.1.3.tar.gz 24435 BLAKE2B f0d571f2c84ca47ee2d4f0aef0a98812880f68d9971e73abd40f2b8d27cce50052a67f6f2a5d19d683093fabed490082df72e29bc8e43123b53b388b9962018c SHA512 6d7a5379dbaf28a201dd44229959a293acb5ff57c4659a6a34af37e46b2e6fc5eb61a00ba26d36dd08795456246429ec20236af8e342fd0d03bfcf6d06d69428
+EBUILD text-short-0.1.3.ebuild 1348 BLAKE2B 9dce2c4775e803c5620c336d74e39b303928368af2fab518cbff7291fcf86f3ba9e71af05c29aee99eb74e70e92a756d139612d3e28ec90f6d6bfd80cf6fb983 SHA512 9fa66fef824be7dcfde5be75a08f59e0c2125a80a8e653a349cb233a6f3907ca2c6eaadd0dc082d4d545fb2d0fa2fd215e8f569405323f79ef49a1c2019ff726
+MISC metadata.xml 931 BLAKE2B 9bd6ec4b5cea39dcc84dbb660a1a6392c6912b9662661cf73a1d782f491a3c27b17bc081da399bcbea394708078fbe1db0d15a00ccf663e3579c0daf659232c3 SHA512 577f354740c15b8381bf3321f19f76233a6dd4f92552bf52f2b60f1bd68024b8f6723b543c015088fbfe538bbe152a50160e2bd4ebdb8c2a92c9ec1ac1586658
diff --git a/dev-haskell/text-short/metadata.xml b/dev-haskell/text-short/metadata.xml
new file mode 100644
index 000000000000..02b8c54225a2
--- /dev/null
+++ b/dev-haskell/text-short/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="asserts">Enable runtime-checks via 'assert'</flag>
+ </use>
+ <longdescription>
+ This package provides the &#39;ShortText&#39; type which is suitable for keeping many short strings in memory. This is similiar to how &#39;ShortByteString&#39; relates to &#39;ByteString&#39;.
+
+ The main difference between &#39;Text&#39; and &#39;ShortText&#39; is that &#39;ShortText&#39; uses UTF-8 instead of UTF-16 internally and also doesn&#39;t support zero-copy slicing (thereby saving 2 words). Consequently, the memory footprint of a (boxed) &#39;ShortText&#39; value is 4 words (2 words when unboxed) plus the length of the UTF-8 encoded payload.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/text-short/text-short-0.1.3.ebuild b/dev-haskell/text-short/text-short-0.1.3.ebuild
new file mode 100644
index 000000000000..a6f10f5a7f4d
--- /dev/null
+++ b/dev-haskell/text-short/text-short-0.1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Memory-efficient representation of Unicode text strings"
+HOMEPAGE="https://hackage.haskell.org/package/text-short"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="asserts"
+
+RDEPEND=">=dev-haskell/hashable-1.2.6:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
+ >=dev-haskell/semigroups-0.18.2:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
+ >=dev-haskell/text-1.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/quickcheck-instances-0.3.14 <dev-haskell/quickcheck-instances-0.4
+ >=dev-haskell/tasty-1.0.0 <dev-haskell/tasty-1.3
+ >=dev-haskell/tasty-hunit-0.10.0 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.7 && < 4.13' 'base >= 4.7' \
+ 'ghc-prim >= 0.3.1 && < 0.6' 'ghc-prim >= 0.3.1'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag asserts asserts)
+}