summaryrefslogtreecommitdiff
path: root/dev-haskell/text-show
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/text-show
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/text-show')
-rw-r--r--dev-haskell/text-show/Manifest4
-rw-r--r--dev-haskell/text-show/metadata.xml37
-rw-r--r--dev-haskell/text-show/text-show-3.10.4.ebuild42
3 files changed, 46 insertions, 37 deletions
diff --git a/dev-haskell/text-show/Manifest b/dev-haskell/text-show/Manifest
index 93efa53ff57a..627bdb6a126a 100644
--- a/dev-haskell/text-show/Manifest
+++ b/dev-haskell/text-show/Manifest
@@ -1,3 +1,5 @@
+DIST text-show-3.10.4.tar.gz 101876 BLAKE2B a51a0a536dab520c924516171703ebe6a71cfdb22a46b4f4aaccab7f69b78aa3d07c14a2b7226f14ffa89ffff84adcc7abcb1646d3add7f2ff0fa7a494175ea3 SHA512 f74eec545cd2994b3ebde9552e15e8b26c60ff00f6438f0c7bc2d92148a34fa85d41b8c04de0a960d468bc928346a5a8cd676a604f9dd81fc14d2ad5667a9d7f
DIST text-show-3.9.7.tar.gz 96683 BLAKE2B 402b41fe0ea539fb2bc98f5271dda37605e86751622dda6136bca8b8ec92917b15ab69e606c4b8fbb6e055f1ee14aed2cd5d446be4c6f494662a0ce153075328 SHA512 d32c2c5c9ea833ac2b996ef299bc7fa2736dfb0ccd86117cd964512ccc25af5eda126fc6dee0537d4740bd38fa9a73ea899e1dd73a30bec775f9966f2121a748
+EBUILD text-show-3.10.4.ebuild 1645 BLAKE2B 26750454301669466a617ac3237580f16ef95a1b26f27fb4dca9cb8ac7f64cba66fe3bac8de202abc682f13741f46969815eb2f612e8e85d8bd2280a40cf1743 SHA512 5f6a7dcd7d21f15b6ff29a651b41d4c6e9e28d776aa247089f308e5fae980594d43880f13dd7f9924086476f7964800f5b094e5a15d94882e1bcc3921ad810fd
EBUILD text-show-3.9.7.ebuild 1629 BLAKE2B fa22509fcbcd8313f1e6fddf79e18f2ddfb11943abd49f0ed37e492fa382be670b5629ffc4e8132cd12f26ad17a0e3278966cc59d9b2ee196e4d21607542334a SHA512 aa5be6d12d48ca3ad316cce87332f67d1b84026975ff8bf0504be093a75acaf41dedf2a318ed0bd6720e17c614c0be7755b4c0d5e25d17dd61766c02172da8a5
-MISC metadata.xml 1746 BLAKE2B 1174753d4508e36c7f34fb5fedb029c986e0617bdfc1e8c01108f9b4da706061499ed85ec2cf83b8f89e99f5bbfeef6d33b3a3ed6dfbff6a8e66bbfd8b3c2dd7 SHA512 a1e739ea4af2b136a91ae3cd8d8e2a8c7936327185cab1326eb96d43f9f39e8e914530753e996133f321e625015fbe4325065edd321b1a512931d204131213d9
+MISC metadata.xml 386 BLAKE2B 1db1d0b49a1308b1e8fc76e5b9ab8e013c0508f64304c2c25a0b7a6e2dfb4a2c9153e38beeebad6cbadfc130d506f0b3874f555940a802058926e19345ccaed1 SHA512 1258f1cdd5b0724f3ba2bf6461352a5ba472f07d813c35905af50c6caeedf9a3ea9c7b3687d81773d8b8addeb7550b54bf462b574c161c505cb23a9a6aa7d819
diff --git a/dev-haskell/text-show/metadata.xml b/dev-haskell/text-show/metadata.xml
index eca7e7acbe42..4f3fc546038a 100644
--- a/dev-haskell/text-show/metadata.xml
+++ b/dev-haskell/text-show/metadata.xml
@@ -5,43 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- @text-show@ offers a replacement for the @Show@ typeclass intended
- for use with @Text@ instead of @String@s. This package was created
- in the spirit of
- @&lt;http://hackage.haskell.org/package/bytestring-show bytestring-show&gt;@.
-
- At the moment, @text-show@ provides instances for most data
- types in the @&lt;http://hackage.haskell.org/package/array array&gt;@,
- @&lt;http://hackage.haskell.org/package/base base&gt;@,
- @&lt;http://hackage.haskell.org/package/bytestring bytestring&gt;@, and
- @&lt;http://hackage.haskell.org/package/text text&gt;@ packages.
- Therefore, much of the source code for @text-show@ consists of
- borrowed code from those packages in order to ensure that the
- behaviors of @Show@ and @TextShow@ coincide.
-
- For most uses, simply importing "TextShow"
- will suffice:
-
- @
- module Main where
-
- import TextShow
-
- main :: IO ()
- main = printT (Just \"Hello, World!\")
- @
-
- If you desire it, there are also monomorphic versions of the @showb@
- function available in the submodules of "TextShow". See the
- &lt;https://github.com/RyanGlScott/text-show/wiki/Naming-conventions naming conventions&gt;
- page for more information.
-
- Support for automatically deriving @TextShow@ instances can be found
- in the "TextShow.TH" and "TextShow.Generic" modules. If you don't
- know which one to use, use "TextShow.TH".
- </longdescription>
<upstream>
+ <remote-id type="hackage">text-show</remote-id>
<remote-id type="github">RyanGlScott/text-show</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/text-show/text-show-3.10.4.ebuild b/dev-haskell/text-show/text-show-3.10.4.ebuild
new file mode 100644
index 000000000000..c40812157058
--- /dev/null
+++ b/dev-haskell/text-show/text-show-3.10.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: -developer,-integer-gmp
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient conversion of values into Text"
+HOMEPAGE="https://github.com/RyanGlScott/text-show"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/base-compat-batteries-0.11:=[profile?] <dev-haskell/base-compat-batteries-0.14:=[profile?]
+ >=dev-haskell/bifunctors-5.1:=[profile?] <dev-haskell/bifunctors-6:=[profile?]
+ dev-haskell/bytestring-builder:=[profile?]
+ >=dev-haskell/generic-deriving-1.14.1:=[profile?] <dev-haskell/generic-deriving-2:=[profile?]
+ >=dev-haskell/text-0.11.1:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-haskell/th-abstraction-0.4:=[profile?] <dev-haskell/th-abstraction-0.7:=[profile?]
+ >=dev-haskell/th-lift-0.7.6:=[profile?] <dev-haskell/th-lift-1:=[profile?]
+ >=dev-haskell/transformers-compat-0.5:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( >=dev-haskell/base-orphans-0.8.5 <dev-haskell/base-orphans-0.10
+ >=dev-haskell/deriving-compat-0.6.5 <dev-haskell/deriving-compat-1
+ >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ >=dev-haskell/quickcheck-2.14.3 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/quickcheck-instances-0.3.28 <dev-haskell/quickcheck-instances-0.4 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer \
+ --flag=-integer-gmp
+}