summaryrefslogtreecommitdiff
path: root/dev-haskell/text-show
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/text-show
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/text-show')
-rw-r--r--dev-haskell/text-show/Manifest3
-rw-r--r--dev-haskell/text-show/metadata.xml47
-rw-r--r--dev-haskell/text-show/text-show-3.4.ebuild49
3 files changed, 99 insertions, 0 deletions
diff --git a/dev-haskell/text-show/Manifest b/dev-haskell/text-show/Manifest
new file mode 100644
index 000000000000..453ccd9d86e0
--- /dev/null
+++ b/dev-haskell/text-show/Manifest
@@ -0,0 +1,3 @@
+DIST text-show-3.4.tar.gz 105127 BLAKE2B 4ea8f7cddaaad4630f0c8317dbe4d5505f27f3008c5e17117d9100f94bb49439edd2761acef60696ef8a97dc8412964d0a9750353f91b30257b025c9e88fd054 SHA512 48b7fdd801c4fc31e12f14a9ba0589e0971481a2f8562d00c697a9fd48f6420e73df0a7318ff4579a786cd606a1fda2287eab3f8c423810c0d00919c68eeebed
+EBUILD text-show-3.4.ebuild 2024 BLAKE2B 8d55cb9316c90d3fba95b4b8ad356a702878490ef0a5933e3e4d96461ea35ae56c3d394c8a31fe63a8528138d4ba598da8ceb828f64f5095d81bdd7a36be60f5 SHA512 ad337b2cb8e35f51d48e4430251334fa94f70a8cff40a764213b8ca0caa009dcdc9b204044e1cf8d04486a867180a93ce0ded829acdeb65cab13bdd9f02d4a99
+MISC metadata.xml 1745 BLAKE2B d094818a5099ee07ad3d768a300b456f1d5e62b11fcf1c5bbfcf6fb4ec0417709d96bb1f6f76eceb89e5154dfd19ce57fd281ef1011c1885e947992ebdaaeb05 SHA512 ee8e1085322a3ecfc53b35f651757515b214be5e3511931390e0e79b65d449a8cc15af6d50b695cd777abe5508c662b0bb9bb5cf4943399bd01809c9b124b2c7
diff --git a/dev-haskell/text-show/metadata.xml b/dev-haskell/text-show/metadata.xml
new file mode 100644
index 000000000000..a6729c09cb4b
--- /dev/null
+++ b/dev-haskell/text-show/metadata.xml
@@ -0,0 +1,47 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ @text-show@ offers a replacement for the @Show@ typeclass intended
+ for use with @Text@ instead of @String@s. This package was created
+ in the spirit of
+ @&lt;http://hackage.haskell.org/package/bytestring-show bytestring-show&gt;@.
+
+ At the moment, @text-show@ provides instances for most data
+ types in the @&lt;http://hackage.haskell.org/package/array array&gt;@,
+ @&lt;http://hackage.haskell.org/package/base base&gt;@,
+ @&lt;http://hackage.haskell.org/package/bytestring bytestring&gt;@, and
+ @&lt;http://hackage.haskell.org/package/text text&gt;@ packages.
+ Therefore, much of the source code for @text-show@ consists of
+ borrowed code from those packages in order to ensure that the
+ behaviors of @Show@ and @TextShow@ coincide.
+
+ For most uses, simply importing "TextShow"
+ will suffice:
+
+ @
+ module Main where
+
+ import TextShow
+
+ main :: IO ()
+ main = printT (Just \"Hello, World!\")
+ @
+
+ If you desire it, there are also monomorphic versions of the @showb@
+ function available in the submodules of "TextShow". See the
+ &lt;https://github.com/RyanGlScott/text-show/wiki/Naming-conventions naming conventions&gt;
+ page for more information.
+
+ Support for automatically deriving @TextShow@ instances can be found
+ in the "TextShow.TH" and "TextShow.Generic" modules. If you don't
+ know which one to use, use "TextShow.TH".
+ </longdescription>
+ <upstream>
+ <remote-id type="github">RyanGlScott/text-show</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/text-show/text-show-3.4.ebuild b/dev-haskell/text-show/text-show-3.4.ebuild
new file mode 100644
index 000000000000..c6ed34cc4d8d
--- /dev/null
+++ b/dev-haskell/text-show/text-show-3.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient conversion of values into Text"
+HOMEPAGE="https://github.com/RyanGlScott/text-show"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base-compat-0.8.1:=[profile?] <dev-haskell/base-compat-1:=[profile?]
+ >=dev-haskell/bifunctors-5.1:=[profile?] <dev-haskell/bifunctors-6:=[profile?]
+ dev-haskell/bytestring-builder:=[profile?]
+ >=dev-haskell/contravariant-0.5:=[profile?] <dev-haskell/contravariant-2:=[profile?]
+ >=dev-haskell/generic-deriving-1.11:=[profile?] <dev-haskell/generic-deriving-2:=[profile?]
+ >=dev-haskell/nats-0.1:=[profile?] <dev-haskell/nats-2:=[profile?]
+ >=dev-haskell/semigroups-0.17:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/tagged-0.4.4:=[profile?] <dev-haskell/tagged-1:=[profile?]
+ >=dev-haskell/text-0.11.1:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/th-lift-0.7.6:=[profile?] <dev-haskell/th-lift-1:=[profile?]
+ >=dev-haskell/transformers-compat-0.5:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
+ >=dev-haskell/void-0.5:=[profile?] <dev-haskell/void-1:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/base-compat-0.8.2 <dev-haskell/base-compat-1
+ >=dev-haskell/base-orphans-0.5.2 <dev-haskell/base-orphans-1
+ >=dev-haskell/deriving-compat-0.3 <dev-haskell/deriving-compat-1
+ >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ >=dev-haskell/quickcheck-2.5 <dev-haskell/quickcheck-3
+ >=dev-haskell/quickcheck-instances-0.1 <dev-haskell/quickcheck-instances-0.4
+ >=dev-haskell/tagged-0.8.3 <dev-haskell/tagged-1 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}