summaryrefslogtreecommitdiff
path: root/dev-haskell/tree-diff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/tree-diff
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/tree-diff')
-rw-r--r--dev-haskell/tree-diff/Manifest3
-rw-r--r--dev-haskell/tree-diff/metadata.xml36
-rw-r--r--dev-haskell/tree-diff/tree-diff-0.1.ebuild58
3 files changed, 97 insertions, 0 deletions
diff --git a/dev-haskell/tree-diff/Manifest b/dev-haskell/tree-diff/Manifest
new file mode 100644
index 000000000000..4fb4173725df
--- /dev/null
+++ b/dev-haskell/tree-diff/Manifest
@@ -0,0 +1,3 @@
+DIST tree-diff-0.1.tar.gz 21644 BLAKE2B 0cd1633970216a994100f852b0982d43b6f1d0dc1b0550e759009250e016d271c5358460ef3999267da597b4e58dd28c3094e0ba4f618ba5990e91740eb63881 SHA512 a4ee703e4b6a18055c7749020863a9571af4620dbb7ea05903693c752e10e3ffa4fee8da0dacc0e4bbf92173e34c9070251881597ca1cd9f7c8ed365e840563c
+EBUILD tree-diff-0.1.ebuild 2823 BLAKE2B ce0c3e0649f9eaebdfc5d2258e7c2f446d907a6be243ecc2dff98ff9e2a332f1fa73dc5788d899b6f27a0a1fa1b81ba782e4178d3ab0ff157436754f4f2108a8 SHA512 b7f398db5d2c1c18ef2a62ce5c8e11fc1fc3f5f73c010feb178a25a9609deccb8604e74917e3d84ce507e2ad6f21b5946e08eb24133a3bce8bfc8bdeeb0f8997
+MISC metadata.xml 1099 BLAKE2B 24140fae7689e6b927d38a271444695b72e4459e2eebf9e90df4be94736829bc2ed23c6112ef71087a9c85d96df7f1270d508ff09698592eadd8b387cce18c81 SHA512 45ad2e28881f1f58c608134b1f33c2797732716b33bbe20fd1bd8e076a0fa3ea24fb457adc8e48240d0eaa34b8067dedb9bbaf231def7f3270b47be96f866784
diff --git a/dev-haskell/tree-diff/metadata.xml b/dev-haskell/tree-diff/metadata.xml
new file mode 100644
index 000000000000..214ee1271465
--- /dev/null
+++ b/dev-haskell/tree-diff/metadata.xml
@@ -0,0 +1,36 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Common diff algorithm works on list structures:
+
+ @
+ diff :: Eq a =&gt; [a] -&gt; [a] -&gt; [Edit a]
+ @
+
+ This package works on trees.
+
+ @
+ treeDiff :: Eq a =&gt; Tree a -&gt; Tree a -&gt; Edit (EditTree a)
+ @
+
+ This package also provides a way to diff arbitrary ADTs,
+ using @Generics@-derivable helpers.
+
+ This package differs from &lt;http://hackage.haskell.org/package/gdiff gdiff&gt;,
+ in a two ways: @tree-diff@ doesn&#39;t have patch function,
+ and the &quot;edit-script&quot; is a tree itself, which is useful for pretty-printing.
+
+ @
+ &gt;&gt;&gt; prettyEditExpr $ ediff (Foo 42 [True, False] &quot;old&quot;) (Foo 42 [False, False, True] &quot;new&quot;)
+ Foo
+ {fooBool = [-True, +False, False, +True],
+ fooInt = 42,
+ fooString = -&quot;old&quot; +&quot;new&quot;}
+ @
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/tree-diff/tree-diff-0.1.ebuild b/dev-haskell/tree-diff/tree-diff-0.1.ebuild
new file mode 100644
index 000000000000..36faec98079a
--- /dev/null
+++ b/dev-haskell/tree-diff/tree-diff-0.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Diffing of (expression) trees"
+HOMEPAGE="https://github.com/phadej/tree-diff"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-1.4.0.0:=[profile?] <dev-haskell/aeson-1.5:=[profile?]
+ >=dev-haskell/ansi-terminal-0.8.1:=[profile?]
+ >=dev-haskell/ansi-wl-pprint-0.6.8.2:=[profile?] <dev-haskell/ansi-wl-pprint-0.7:=[profile?]
+ >=dev-haskell/base-compat-0.9.3:=[profile?]
+ >=dev-haskell/bytestring-builder-0.10.8.2.0:=[profile?] <dev-haskell/bytestring-builder-0.11:=[profile?]
+ >=dev-haskell/generic-deriving-1.12.4:=[profile?] <dev-haskell/generic-deriving-1.14:=[profile?]
+ >=dev-haskell/generics-sop-0.3.1.0:=[profile?] <dev-haskell/generics-sop-0.6:=[profile?]
+ >=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
+ >=dev-haskell/memotrie-0.6.8:=[profile?] <dev-haskell/memotrie-0.7:=[profile?]
+ >=dev-haskell/nats-1.1.2:=[profile?] <dev-haskell/nats-1.2:=[profile?]
+ >=dev-haskell/parsec-3.1.13.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/parsers-0.12.10:=[profile?] <dev-haskell/parsers-0.13:=[profile?]
+ >=dev-haskell/quickcheck-2.10.0.1:2=[profile?] <dev-haskell/quickcheck-2.14:2=[profile?]
+ >=dev-haskell/scientific-0.3.6.2:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.18.5:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
+ >=dev-haskell/tagged-0.8.6:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.8.0:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/uuid-types-1.0.3:=[profile?] <dev-haskell/uuid-types-1.1:=[profile?]
+ >=dev-haskell/vector-0.12:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-haskell/void-0.7.3:=[profile?] <dev-haskell/void-0.8:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/tasty-1.2 <dev-haskell/tasty-1.3
+ >=dev-haskell/tasty-golden-2.3.1.1 <dev-haskell/tasty-golden-2.4
+ >=dev-haskell/tasty-quickcheck-0.10.1 <dev-haskell/tasty-quickcheck-0.11
+ >=dev-haskell/trifecta-2.0 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'ansi-terminal ^>=0.8.2 || ^>=0.9.1' 'ansi-terminal >=0.8.2' \
+ 'base >=4.5 && <4.13' 'base >=4.5' \
+ 'time ^>=1.4 || ^>=1.5.0.1 || ^>=1.6.0.1 || ^>=1.8.0.2' 'time >=1.4' \
+ 'base-compat ^>=0.10.5' 'base-compat >=0.10.5' \
+ 'trifecta ^>=2' 'trifecta >=2'
+}