summaryrefslogtreecommitdiff
path: root/dev-haskell/typst
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/typst
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/typst')
-rw-r--r--dev-haskell/typst/Manifest3
-rw-r--r--dev-haskell/typst/metadata.xml15
-rw-r--r--dev-haskell/typst/typst-0.3.2.0.ebuild47
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-haskell/typst/Manifest b/dev-haskell/typst/Manifest
new file mode 100644
index 000000000000..8318e7940842
--- /dev/null
+++ b/dev-haskell/typst/Manifest
@@ -0,0 +1,3 @@
+DIST typst-0.3.2.0.tar.gz 6421514 BLAKE2B 622f49edd8fb362a07c2a81a59f227c82228bbf09b4708d2dc119deda66cb028838546f826e9729f350cb1ae20399e319b71fcdbd5707951e821b60c76e11a3b SHA512 1bb5dd8158c528d52c2411c3acb2ada2061ce5ef27eb387135e61140232815b15f5d3aaee3264ef3a11a09d8f4d10dfd3d246836f77d018ee0fcce8d37d3ccd5
+EBUILD typst-0.3.2.0.ebuild 1358 BLAKE2B d0fbf0b5348a7eae09cf6deb9d2c75e15e1d2bb5800d0a23ca6f888b1948806e0b156b72c56635dc13280ba08df998cc9d158684e77c318b119a4322aed2b262 SHA512 3d47492e1c8833cb6a198f0b93930734fc983c67e60a83953f46e390450a1f1a99d079964e33c5b65a723c4d70ecb4d2b0d0188af9b2a602294ed0494776e630
+MISC metadata.xml 479 BLAKE2B 5909019771d287ce2fe83b56e35fa89914336c912b940faf4a7f3a6df2690e4c25fc195805776dfb2052bdd7969d831520f70874422be529bdda8cf596699ecf SHA512 8c55315d4d10c563d1b212e5dc1213a896dd6e8444e738811dc44223d03d2ee5588a86887c811e44297a016fa885e9b61b24e770ab881c3adb87fa9eeff5e697
diff --git a/dev-haskell/typst/metadata.xml b/dev-haskell/typst/metadata.xml
new file mode 100644
index 000000000000..faf481d753d0
--- /dev/null
+++ b/dev-haskell/typst/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="executable">Compile executable to be used in testing and development.</flag>
+ </use>
+ <upstream>
+ <remote-id type="hackage">typst</remote-id>
+ <remote-id type="github">jgm/typst-hs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/typst/typst-0.3.2.0.ebuild b/dev-haskell/typst/typst-0.3.2.0.ebuild
new file mode 100644
index 000000000000..8ac27b1ee400
--- /dev/null
+++ b/dev-haskell/typst/typst-0.3.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Parsing and evaluating typst syntax"
+HOMEPAGE="https://hackage.haskell.org/package/typst"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="executable"
+
+RESTRICT=test # one test case fails
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/cassava:=[profile?]
+ dev-haskell/digits:=[profile?]
+ dev-haskell/ordered-containers:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/regex-tdfa:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/toml-parser-1.3.0.0:=[profile?] <dev-haskell/toml-parser-1.4:=[profile?]
+ >=dev-haskell/typst-symbols-0.1.4:=[profile?] <dev-haskell/typst-symbols-0.1.5:=[profile?]
+ dev-haskell/vector:=[profile?]
+ dev-haskell/xml-conduit:=[profile?]
+ dev-haskell/yaml:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+ executable? ( dev-haskell/pretty-show:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-golden
+ !executable? ( dev-haskell/pretty-show ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}