summaryrefslogtreecommitdiff
path: root/dev-haskell/uhc-light
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/uhc-light
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/uhc-light')
-rw-r--r--dev-haskell/uhc-light/Manifest3
-rw-r--r--dev-haskell/uhc-light/metadata.xml14
-rw-r--r--dev-haskell/uhc-light/uhc-light-1.1.9.5.ebuild35
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/uhc-light/Manifest b/dev-haskell/uhc-light/Manifest
new file mode 100644
index 000000000000..aa7d7f0c1ce6
--- /dev/null
+++ b/dev-haskell/uhc-light/Manifest
@@ -0,0 +1,3 @@
+DIST uhc-light-1.1.9.5.tar.gz 4546645 SHA256 eabaf3cdac62afb5c8d37f8ceb0997fd85647493d2d4cc1b0d00d954d586681d SHA512 1d31cf2be92689dc0fd989db158623ba36455f33dad70905063cd0849e65cd3f2b78d29a6ed7a943a371e14afc45c95dc552c5a6c64109b192b9ca57cacc7fea WHIRLPOOL fe38131bb100ef2968d2329a921b7fad00a105a7afe0fc0394f425631597765aaa43b763cb1130f68221bb1a6a9f7ffb802d55cf56a5ad11588001d9d5832ff8
+EBUILD uhc-light-1.1.9.5.ebuild 1057 SHA256 faf4d0557c3418014059d1bb7f8a76e887d310f7bcf472b5b3a0b4bed822b60a SHA512 0ce624da7dd02944a0ef58834268b9023ff942a2e15cd51b504a68895421271e73c9cdcd47233de1a533aaef66ce62f8e6dd511b31a32f412177e55656f1454a WHIRLPOOL 7415ee433ed044574e957f92e5233b314f3d4d47111a8909495c835b496866452046770e88902afdfc1af7b94200b88e64d161b62e9c74c727e36520367b9a2b
+MISC metadata.xml 710 SHA256 a78f84d5dc967706cf53b45a2f09851c92313283211f393e0eb3c4f0701b6fa8 SHA512 e652a332e09923a7cb6c132c0b86bb87eb3d3d6cfe3f16d443514ad5cf48aafa4ef5ebbe00cab08a6a4987841df9ea240977a7326975ceaa6e6cf3b42c1e7fd1 WHIRLPOOL 43eb20b074e27518279c925fe722076ae7e14a2b9733e8a379acca11fe56800df472dfb3012008ae3a06623af57934825f29d515418ef579fdacd3a6a11213c4
diff --git a/dev-haskell/uhc-light/metadata.xml b/dev-haskell/uhc-light/metadata.xml
new file mode 100644
index 000000000000..cd3392e2775f
--- /dev/null
+++ b/dev-haskell/uhc-light/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A 'light' variant of UHC including only an API and executables for compiling to Core representation (uhcl) and running CoreRun (uhcr). This version is just to test the infrastructure. Later versions will provide a fleshing out of the API and completion of the now rudimentary platform independent (Haskell) interpreted running etc..
+ </longdescription>
+ <upstream>
+ <remote-id type="github">UU-ComputerScience/uhc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/uhc-light/uhc-light-1.1.9.5.ebuild b/dev-haskell/uhc-light/uhc-light-1.1.9.5.ebuild
new file mode 100644
index 000000000000..ecb05424cbe2
--- /dev/null
+++ b/dev-haskell/uhc-light/uhc-light-1.1.9.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile" # broken markup: haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Part of UHC packaged as cabal/hackage installable library"
+HOMEPAGE="https://github.com/UU-ComputerScience/uhc"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/fgl:=[profile?]
+ >=dev-haskell/hashable-1.2.4:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/network:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ dev-haskell/primitive:=[profile?]
+ dev-haskell/syb:=[profile?]
+ >=dev-haskell/uhc-util-0.1.6.7:=[profile?] <dev-haskell/uhc-util-0.1.7:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-haskell/uulib-0.9.19:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"