summaryrefslogtreecommitdiff
path: root/dev-haskell/unbounded-delays
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/unbounded-delays
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/unbounded-delays')
-rw-r--r--dev-haskell/unbounded-delays/Manifest4
-rw-r--r--dev-haskell/unbounded-delays/metadata.xml9
-rw-r--r--dev-haskell/unbounded-delays/unbounded-delays-0.1.1.1.ebuild24
3 files changed, 27 insertions, 10 deletions
diff --git a/dev-haskell/unbounded-delays/Manifest b/dev-haskell/unbounded-delays/Manifest
index fd3001a60976..337074a0b45e 100644
--- a/dev-haskell/unbounded-delays/Manifest
+++ b/dev-haskell/unbounded-delays/Manifest
@@ -1,3 +1,5 @@
DIST unbounded-delays-0.1.1.0.tar.gz 4166 BLAKE2B 158b05e35afd4c2b8f33caeea748466ee8cb6348f4505649c442f76777b41326128b84b8b7559e06d031c1486886e99e95bf69ac7e80eb16ec1c17cc5b5354e3 SHA512 70e26055abe40b38e20bc5dadc3ae32b699613698d0fc36bbd519fe011128fbdda7e963a69f25375b4e8a26b2ebfa2cdd4496d9d045e9f19672224654e5e7948
+DIST unbounded-delays-0.1.1.1.tar.gz 4114 BLAKE2B 97ffa71675906f9eef6ae297369f9668273ffcb4cc8d9d7efb43b152b5abbeae888ca67e1f77568636feeb3eb4d1bd8549a1446a4f56c7db5ef5570a43da7c57 SHA512 7439c8976498bd84e966b7e08e8d868d65debe3ffc7fd77dc6de345258b4532f2203415abf9530fdaa5feba0bfdc1031303b343502d1f3dc401058125babd41b
EBUILD unbounded-delays-0.1.1.0.ebuild 566 BLAKE2B 4ad773d778a71708869664cb4757c7b089c68d466126dce5bf17472ae8d70598c07987e08e686971d0d910de58f367c8a60b918a7b707850e055b424b392a87f SHA512 9f92b8872d856e0c123f67604d794b710b63b42887c7263e3aaebcb13027b3975b8e5dc23399159837f8ab60892e21d60f6874ffae64876cc13d035191d27fd6
-MISC metadata.xml 602 BLAKE2B 59648665fefaec4e52733d3eb4d5ca541bfeb96a83ac6e9a197a60938d3267fc592cd598a721f3374f0208f14a61dbfa0ce9c36b806e592fa8b255f378b1373d SHA512 b1ea21fcb650fc08d965a0b865cd1f010855b406751c81c20f80981a91814f4f4f5ef5506e02a71511853f5a00f7da200e2d35c478d05aac17db9f760fec9357
+EBUILD unbounded-delays-0.1.1.1.ebuild 568 BLAKE2B 7cf4d12b8b0c5b74dee82778dc95644ffe16b7b878929f626ebfa05d0e2c9bd5f3b4889243cc857542baa4fb12065724795348eef6ba5175a5eb075270e527f6 SHA512 7bf6c38f1d3e77088d4ba7e5343692d6b884d6f14eafe0d9be277f6175a8811f7ef0f154f5e913c9d23d13d168366c5abdc50f2a413721d84d33a2aadf7a3616
+MISC metadata.xml 250 BLAKE2B 3adf9597d5114c480b4cc9fb5c3e231d8475b795cd6dce77986e13583ab6e59b43857cf2328570490abef0062a8b8a6b73d231867f9b62124855515cdc044d6d SHA512 5ef2c1d34a3438b39a38c041d45bb06bd0f1ae8a3f8b971bd5aaf36dee560f380e9abefab0c2a4cd7b518e151f5c6a0d0c7cd53caee9a384818f1bdc7deeadc4
diff --git a/dev-haskell/unbounded-delays/metadata.xml b/dev-haskell/unbounded-delays/metadata.xml
index cb2204836918..937381521944 100644
--- a/dev-haskell/unbounded-delays/metadata.xml
+++ b/dev-haskell/unbounded-delays/metadata.xml
@@ -5,13 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- The @threadDelay@ and @timeout@ functions from the @base@ library
- use the bounded @Int@ type for specifying the delay or timeout
- period. This packages provides alternatives which use the
- unbounded @Integer@ type.
- </longdescription>
- <upstream>
- <remote-id type="github">basvandijk/unbounded-delays</remote-id>
- </upstream>
</pkgmetadata>
diff --git a/dev-haskell/unbounded-delays/unbounded-delays-0.1.1.1.ebuild b/dev-haskell/unbounded-delays/unbounded-delays-0.1.1.1.ebuild
new file mode 100644
index 000000000000..5a8fc9f85dd2
--- /dev/null
+++ b/dev-haskell/unbounded-delays/unbounded-delays-0.1.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Unbounded thread delays and timeouts"
+HOMEPAGE="https://github.com/basvandijk/unbounded-delays"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"