summaryrefslogtreecommitdiff
path: root/dev-haskell/uniqueid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-22 02:42:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-22 02:42:13 +0100
commite7f37e03b952768321c8c943a80eff4152ea7bbd (patch)
tree355a9efb62297418cdadbc424b09dbafc54257e5 /dev-haskell/uniqueid
parent2518522472e5de9c52c78dc0246475fe0ae3cc05 (diff)
gentoo auto-resync : 22:08:2022 - 02:42:13
Diffstat (limited to 'dev-haskell/uniqueid')
-rw-r--r--dev-haskell/uniqueid/Manifest4
-rw-r--r--dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch46
-rw-r--r--dev-haskell/uniqueid/metadata.xml18
-rw-r--r--dev-haskell/uniqueid/uniqueid-0.1.1.ebuild24
4 files changed, 0 insertions, 92 deletions
diff --git a/dev-haskell/uniqueid/Manifest b/dev-haskell/uniqueid/Manifest
deleted file mode 100644
index 3929ece7a968..000000000000
--- a/dev-haskell/uniqueid/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX uniqueid-0.1.1-ghc-7.8.patch 1383 BLAKE2B 92ea3035b38b4f86559fff85d346940cd9f2222e4ef2e922128b14051db2b48ac70531146289bcd7a526d8498ab6f9440f1a8a4b6e38d5b3a88353f80a4acdec SHA512 2cb2bc04bc8ee52279ec953ed1435411d4715dec009012d191bd07df4ccd334ca4a60be123d00bf9a74a8f9e94e01b2fcea0c0692fdcf77c7d7a0c5d7b0948e5
-DIST uniqueid-0.1.1.tar.gz 2779 BLAKE2B 73ad9af177f20575caaefb12261d58801a391bfcbaa6b8ef1596538fd7536ec8b6aa35997277a39454250bc779c4c6174b1b3e7853bad5cc21d9ed72764ce517 SHA512 4a1f753a320a5ddae8dd47c3e3729144cf28effaaa6f16a8cf13ad614e4aba3f720f82025f86d7c04ae5c28d03825b4d3442caa01cd534dfa05a70c6c9cadc68
-EBUILD uniqueid-0.1.1.ebuild 581 BLAKE2B 686c9d445fc7ad98c7a302d0a8cf827c2761ab5202caf71d53fc0589a7982461fcb3ab3cabc7741ab711401a9e13e0a63d45e1141e0bd23abb1f72e9e3145769 SHA512 44f22b9a1b0942385d6725a2a89584a1f52db423df52112263c3e47dc586afcb0cbe2ce106fba952b11c30149f540374dff49c4b53c6d61fe3875bc228c7d8f3
-MISC metadata.xml 629 BLAKE2B 000053dcdf2a0e7977d161a4a6cd540fef0fc30f9d2fb65e71c013e83cb1038662716ca34664dd84c812fb0883988adf6f0cb308b608531c2153d91e629defbc SHA512 dcda3d4088caebbcc229bb386f9a245adc659623c0248c7e3766dcff80fa49ec57b0b479ff3c198a7cdea1c50ea5d95571d831300e9550fa8a970aacb298e97a
diff --git a/dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch b/dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch
deleted file mode 100644
index a48815ecda0e..000000000000
--- a/dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff --git a/Data/Unique/Id.hs b/Data/Unique/Id.hs
-index f41127e..56853d9 100644
---- a/Data/Unique/Id.hs
-+++ b/Data/Unique/Id.hs
-@@ -14,7 +14,7 @@ module Data.Unique.Id (
- ) where
-
- import GHC.Exts
--import GHC.IOBase ( unsafeDupableInterleaveIO )
-+import GHC.IO ( unsafeDupableInterleaveIO )
-
- import Data.IORef
- import System.IO.Unsafe ( unsafePerformIO )
-@@ -55,15 +55,15 @@ splitIdSupplyL ids = ids1 : splitIdSupplyL ids2
- idFromSupply :: IdSupply -> Id
- idFromSupply (IdSupply n _ _) = Id (I# n)
-
--instance Eq Id where Id (I# x) == Id (I# y) = x ==# y
-+instance Eq Id where Id (I# x) == Id (I# y) = isTrue# (x ==# y)
-
- instance Ord Id
- where
-- Id (I# x) < Id (I# y) = x <# y
-- Id (I# x) <= Id (I# y) = x <=# y
-+ Id (I# x) < Id (I# y) = isTrue# (x <# y)
-+ Id (I# x) <= Id (I# y) = isTrue# (x <=# y)
-
- compare (Id (I# x)) (Id (I# y)) =
-- if x ==# y then EQ else if x <# y then LT else GT
-+ if isTrue# (x ==# y) then EQ else if isTrue# (x <# y) then LT else GT
-
- instance Show Id
- where
-diff --git a/uniqueid.cabal b/uniqueid.cabal
-index 8099520..83aaa39 100644
---- a/uniqueid.cabal
-+++ b/uniqueid.cabal
-@@ -18,7 +18,7 @@ Build-Type: Simple
- Stability: experimental
-
- Library
-- Build-Depends: base >= 3 && < 5
-+ Build-Depends: base >= 3 && < 5, ghc-prim
- Exposed-Modules: Data.Unique.Id
- Extensions: MagicHash
- Ghc-Options: -Wall
diff --git a/dev-haskell/uniqueid/metadata.xml b/dev-haskell/uniqueid/metadata.xml
deleted file mode 100644
index 5e894ac2443c..000000000000
--- a/dev-haskell/uniqueid/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- This package provides splittable supplies of unique
- identifiers. The implementation mimics (only) essential
- parts of the code that is used internally in GHC for
- the same purpose. After improvements of the value-supply
- package it is now deprecated.
- </longdescription>
- <upstream>
- <remote-id type="github">sebfisch/uniqueid</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-haskell/uniqueid/uniqueid-0.1.1.ebuild b/dev-haskell/uniqueid/uniqueid-0.1.1.ebuild
deleted file mode 100644
index e229c4991267..000000000000
--- a/dev-haskell/uniqueid/uniqueid-0.1.1.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.3.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Splittable Unique Identifier Supply"
-HOMEPAGE="https://github.com/sebfisch/uniqueid/wikis"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-lang/ghc-7.8.1:="
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6"
-
-PATCHES=("${FILESDIR}"/${P}-ghc-7.8.patch)