summaryrefslogtreecommitdiff
path: root/dev-haskell/uri-bytestring
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/uri-bytestring
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/uri-bytestring')
-rw-r--r--dev-haskell/uri-bytestring/Manifest3
-rw-r--r--dev-haskell/uri-bytestring/metadata.xml14
-rw-r--r--dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild41
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-haskell/uri-bytestring/Manifest b/dev-haskell/uri-bytestring/Manifest
new file mode 100644
index 000000000000..c4c23b96a94c
--- /dev/null
+++ b/dev-haskell/uri-bytestring/Manifest
@@ -0,0 +1,3 @@
+DIST uri-bytestring-0.2.2.1.tar.gz 20755 BLAKE2B a91e0de79e3493e342349dfb45d443bbed19265dc78fbd52f9c20e4ff66e2a64433d0dd4f0e3ccee280091ddb843392ae1e8fac15dd5eaa293ac9a80d55eb74a SHA512 d540722657b80039de25a6893067ea8fa50228420725ea22b95a6b7fb3e99803e41b18006b307973fd38fe5ba58d611d3115d1b677e3a36c38168b92289fee97
+EBUILD uri-bytestring-0.2.2.1.ebuild 1091 BLAKE2B 4dc425445d788d22aff0caac070202fd2a56fcc9249c0c0c2a10e941cd02af83ff10b116399d681c2f60a1efde79e011af25fb95da62360de51a77857d2d3e1c SHA512 23875303ea0a540ef864e0f754f29b8f86e7dcc4e0a9ff823c6afa2c2efb980b199c13e0ff976b6132ec704611e964bb6b005ec2be23ed3902478067c1c0175a
+MISC metadata.xml 511 BLAKE2B eb475c8f280a44c0f4b09e34c344ed478a2503d2821711b57d12c40971d4c75081455e1cb4e13350846a4cd2cc0a92bc1b69228f4e8ecfa9d90439fcc10a5d27 SHA512 d21aadfa0df81fe2542de2a92f94fe055c0040e5c963d33bbdab5a8a2da085b64788f4141fad8ddf6c5e0959c275ae650be95298e7a984e7535045503b257a42
diff --git a/dev-haskell/uri-bytestring/metadata.xml b/dev-haskell/uri-bytestring/metadata.xml
new file mode 100644
index 000000000000..16a771dc5920
--- /dev/null
+++ b/dev-haskell/uri-bytestring/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ uri-bytestring aims to be an RFC3986 compliant URI parser that uses efficient ByteStrings for parsing and representing the URI data.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Soostone/uri-bytestring</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild b/dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild
new file mode 100644
index 000000000000..4c8313e17e44
--- /dev/null
+++ b/dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -lib-werror
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell URI parsing as ByteStrings"
+HOMEPAGE="https://github.com/Soostone/uri-bytestring"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.12:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/blaze-builder-0.3.0.0:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/generics-sop-0.2
+ dev-haskell/hunit
+ dev-haskell/lens-simple
+ dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances
+ dev-haskell/semigroups
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-lib-werror
+}