summaryrefslogtreecommitdiff
path: root/dev-haskell/uuid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/uuid
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/uuid')
-rw-r--r--dev-haskell/uuid/Manifest5
-rw-r--r--dev-haskell/uuid/metadata.xml16
-rw-r--r--dev-haskell/uuid/uuid-1.3.11-r2.ebuild41
-rw-r--r--dev-haskell/uuid/uuid-1.3.12.ebuild41
4 files changed, 103 insertions, 0 deletions
diff --git a/dev-haskell/uuid/Manifest b/dev-haskell/uuid/Manifest
new file mode 100644
index 000000000000..7c097bd4a9e5
--- /dev/null
+++ b/dev-haskell/uuid/Manifest
@@ -0,0 +1,5 @@
+DIST uuid-1.3.11.tar.gz 8578 BLAKE2B ab865736dda4ca4188b9b21b06649fde81d8de1ef4939bf0a5945353d17da691fcd267faded8f64edec7371727a99239f961b25b3402f8fb68b5f0ad89052bae SHA512 3b94c13ff8b6a631f9411a313a99251ee961234d0322e446e22b04110728a4acb687f4bb4b83f9b09268fed9238b1265dc53c5214ae4bb8e18c12455c41c41e5
+DIST uuid-1.3.12.tar.gz 8738 BLAKE2B a6e8fe96d6c20b9294c1535d367ad3ce0a91dfec4c9cd408d5b7e2ec0988326721db3d7a6ea3addded81c12f86692ed898e14612c20fcaf16f0ea6be6f2ef21c SHA512 53d1a9e69dbc3ce2cb2e35aeca9b116e5fbf176fe048d4afaaff1bfaae80445da8e3d53c4652ada41791fb3e237e2cd24d3ac15e6a786242844fdf076588dae9
+EBUILD uuid-1.3.11-r2.ebuild 1426 BLAKE2B 5f66a85c5a55e29b1a56b3ec26892d4e793de6a65bebfa334ea0e324ffbc9e8f0e1a556a04c1c276fa229a9a9fd906c6bea33ef0d63679665422134524974c7c SHA512 b32a34fcdecc7398bc15cf24b2cf5aaa204780f73b3e6cc4b66a26f40d25ed3e897dd55874c2c352dda67ad6fc29f56406a26dadf4cddd66a2f3a36db7c60853
+EBUILD uuid-1.3.12.ebuild 1402 BLAKE2B 8ef15b537d8b5cf13325518f383b49ee0aad3fe9bc5d095eb7facd0769c2603d2f0d24d9a0c037baab3b197b335798ffda07a8bc2155cca0d61e7c9729ab7598 SHA512 1d4eebd9532a0ee3932e8cc4bc2be536d9345e367c38676f5457bc88ae885f59bdc60f40fbb936754093e1d8503f3098145da1c564c611d244e10a648eb4b83f
+MISC metadata.xml 542 BLAKE2B 043a99892b12c9c72f1f89226f5e82edf49ae91fa5f9c4fad7c15d06893266f9ce1bff7acaa06f83e62c3639116e23dbf9c67daba5791673b4c349e79393a370 SHA512 8088a28c040b916c0aa47ca6a1e05dae3b834da258a747c2d4836d8d1b44cb6ac85ebf3c6c88b948e08ff6baff09002c5dda486b1553e5f416f17949e0b571e3
diff --git a/dev-haskell/uuid/metadata.xml b/dev-haskell/uuid/metadata.xml
new file mode 100644
index 000000000000..7c9c76c8d405
--- /dev/null
+++ b/dev-haskell/uuid/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This library is useful for creating, comparing, parsing and
+ printing Universally Unique Identifiers.
+ See &lt;https://en.wikipedia.org/wiki/UUID&gt; for the general idea.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">aslatter/uuid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/uuid/uuid-1.3.11-r2.ebuild b/dev-haskell/uuid/uuid-1.3.11-r2.ebuild
new file mode 100644
index 000000000000..0d6d222b39c5
--- /dev/null
+++ b/dev-haskell/uuid/uuid-1.3.11-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="For creating, comparing, parsing and printing Universally Unique Identifiers"
+HOMEPAGE="https://github.com/aslatter/uuid"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?] <dev-haskell/binary-0.8:=[profile?]
+ >=dev-haskell/cryptohash-0.7:=[profile?] <dev-haskell/cryptohash-0.12:=[profile?]
+ >=dev-haskell/network-info-0.2:=[profile?] <dev-haskell/network-info-0.3:=[profile?]
+ >=dev-haskell/random-1.0.1:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/text-1:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/uuid-types-1.0.2:=[profile?] <dev-haskell/uuid-types-2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2
+ >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-2.9
+ >=dev-haskell/tasty-0.10
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.9 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'HUnit >=1.2 && < 1.3' 'HUnit >=1.2' \
+ 'tasty == 0.10.*' 'tasty >= 0.10'
+}
diff --git a/dev-haskell/uuid/uuid-1.3.12.ebuild b/dev-haskell/uuid/uuid-1.3.12.ebuild
new file mode 100644
index 000000000000..0d2303555b0d
--- /dev/null
+++ b/dev-haskell/uuid/uuid-1.3.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="For creating, comparing, parsing and printing Universally Unique Identifiers"
+HOMEPAGE="https://github.com/aslatter/uuid"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?] <dev-haskell/binary-0.9:=[profile?]
+ dev-haskell/cryptonite:=[profile?]
+ dev-haskell/memory:=[profile?]
+ >=dev-haskell/network-info-0.2:=[profile?] <dev-haskell/network-info-0.3:=[profile?]
+ >=dev-haskell/random-1.0.1:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/text-1:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/uuid-types-1.0.2:=[profile?] <dev-haskell/uuid-types-2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.4
+ >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/tasty-0.10 <dev-haskell/tasty-0.12
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.9 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'QuickCheck >=2.4 && < 2.9' 'QuickCheck >=2.4'
+}