summaryrefslogtreecommitdiff
path: root/dev-haskell/uuid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-24 02:52:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-24 02:52:00 +0100
commite19b21c73e5feac42ade97baf3eeb45c58a2f234 (patch)
treef524a01a657ca0dd25be3a5bf70fbb6b694b0275 /dev-haskell/uuid
parentfceabcd48faf4c890719a14ac4ed93b6b7993364 (diff)
gentoo auto-resync : 24:07:2022 - 02:51:59
Diffstat (limited to 'dev-haskell/uuid')
-rw-r--r--dev-haskell/uuid/Manifest4
-rw-r--r--dev-haskell/uuid/metadata.xml5
-rw-r--r--dev-haskell/uuid/uuid-1.3.15.ebuild36
3 files changed, 39 insertions, 6 deletions
diff --git a/dev-haskell/uuid/Manifest b/dev-haskell/uuid/Manifest
index 32a61c50609a..f438f47e07a8 100644
--- a/dev-haskell/uuid/Manifest
+++ b/dev-haskell/uuid/Manifest
@@ -1,3 +1,5 @@
DIST uuid-1.3.13.tar.gz 8926 BLAKE2B d7b4850eb921467677534d33475dccb90b2e74a4f73137eb8e9a45573a337d4152b19f052dea584bb0b6ab862dcdf764106c4e35efa1e8ae3ecec41becc75a4e SHA512 e888e6350a32c6496b0b57384797925c78ab1c4dc674d296972981fa81338b4705d21a96960a63771aa5b9a785efd507ecaad195767dba7847fcab5ca7f3f923
+DIST uuid-1.3.15.tar.gz 8815 BLAKE2B fec665690dc6fe05e9b7083700ca5ba2723d9bbd7cdc7f8770359d26b9b4b32572e15b686bc4589a3bed2cd25caa02cbea96270ea2e373941451aa6f315df401 SHA512 acb5c17b809bee5ce2f1591f3382a7c3a57e9d20a47d8f47be717b0e7fbfd803603810ebaaf88597bcf98dff698f4807dc7d8122a0d7d36785a47e0e065fb59e
EBUILD uuid-1.3.13-r1.ebuild 1791 BLAKE2B 5213f5e56a0bfeba96b7a330ac7b28fce51519e30364330314ce75753ef8cbd4cb5d98e45efed1d2586716458bef4ae2aaae3c1db0cc957d0b6471eed2377341 SHA512 827a23bdb79b3b15e94cf71f385a9e3f4ec086262be8484d1003c471e9fc1905831a65510663c597a16bb659714764eacabf76ead8e09ac886538061060d604c
-MISC metadata.xml 543 BLAKE2B fb93401ef9d6f322910dd75ba41d5d9b5491dd1643029f6012a463bdf3d5015a09eb21463acccde971b1cdf57ed91c2d77412617cafb49796b70d4c12c0b45bb SHA512 bcbe8f0e107be113d1f65d1f107ead3fbab5f613ae2304c38a69295b181da967794346dd620b7d069ecac128e053af0e2b1943eb69bfd271d5105af4bd6c1ede
+EBUILD uuid-1.3.15.ebuild 1479 BLAKE2B 3b72290d246bd87aca7ce29be1da67bef5035aea6aaeb984ec875973d46cf385ef19c356ab0b1db2ccc9ced9101b981d0f94575a0878f438b226559da2375924 SHA512 fd902950410b2835b9001a6eae08f61a9bc42dd15f49d91817027eb15de285b20082f2f326b824f27859109e0113ec7e4bfaa646e178c7a8f31b51ff27a87dda
+MISC metadata.xml 328 BLAKE2B 28dc31dfc087b15e03a61a12ed766c5fe3ed9d328e8f6f461618c235cba25c3032df539920164bf31ab04ccc376c1d02815723a2d560b817bdb6533cbe9aea3b SHA512 996a273983ea1f004269779e07d8f6d0591d382980dfa8d734b4852d43e93b6b6323778342a2f9cd3072e6f1001f117b4a1be770a86b31c03e8951b48d987014
diff --git a/dev-haskell/uuid/metadata.xml b/dev-haskell/uuid/metadata.xml
index 69b916ffe552..8bd9ed7a20bf 100644
--- a/dev-haskell/uuid/metadata.xml
+++ b/dev-haskell/uuid/metadata.xml
@@ -5,11 +5,6 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This library is useful for creating, comparing, parsing and
- printing Universally Unique Identifiers.
- See &lt;https://en.wikipedia.org/wiki/UUID&gt; for the general idea.
- </longdescription>
<upstream>
<remote-id type="github">aslatter/uuid</remote-id>
</upstream>
diff --git a/dev-haskell/uuid/uuid-1.3.15.ebuild b/dev-haskell/uuid/uuid-1.3.15.ebuild
new file mode 100644
index 000000000000..2b511217050a
--- /dev/null
+++ b/dev-haskell/uuid/uuid-1.3.15.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite has too new tasty
+inherit haskell-cabal
+
+DESCRIPTION="For creating, comparing, parsing and printing Universally Unique Identifiers"
+HOMEPAGE="https://github.com/haskell-hvr/uuid"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT=test
+
+RDEPEND=">=dev-haskell/cryptohash-md5-0.11.100:=[profile?] <dev-haskell/cryptohash-md5-0.12:=[profile?]
+ >=dev-haskell/cryptohash-sha1-0.11.100:=[profile?] <dev-haskell/cryptohash-sha1-0.12:=[profile?]
+ >=dev-haskell/entropy-0.3.7:=[profile?] <dev-haskell/entropy-0.5:=[profile?]
+ >=dev-haskell/network-info-0.2:=[profile?] <dev-haskell/network-info-0.3:=[profile?]
+ >=dev-haskell/random-1.1:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-haskell/uuid-types-1.0.5:=[profile?] <dev-haskell/uuid-types-1.0.6:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-2.1:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1"
+# test? ( >=dev-haskell/quickcheck-2.14.2 <dev-haskell/quickcheck-2.15
+# >=dev-haskell/tasty-1.4.0.1 <dev-haskell/tasty-1.5
+# >=dev-haskell/tasty-hunit-0.10 <dev-haskell/tasty-hunit-0.11
+# >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11 )
+# "