summaryrefslogtreecommitdiff
path: root/dev-haskell/yaml/yaml-0.11.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/yaml/yaml-0.11.5.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/yaml/yaml-0.11.5.0.ebuild')
-rw-r--r--dev-haskell/yaml/yaml-0.11.5.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-haskell/yaml/yaml-0.11.5.0.ebuild b/dev-haskell/yaml/yaml-0.11.5.0.ebuild
new file mode 100644
index 000000000000..675db69e8dac
--- /dev/null
+++ b/dev-haskell/yaml/yaml-0.11.5.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Support for parsing and rendering YAML documents"
+HOMEPAGE="https://github.com/snoyberg/yaml#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+no-examples +no-exe"
+
+RDEPEND=">=dev-haskell/aeson-0.11:=[profile?]
+ >=dev-haskell/attoparsec-0.11.3.0:=[profile?]
+ >=dev-haskell/conduit-1.2.8:=[profile?] <dev-haskell/conduit-1.4:=[profile?]
+ >=dev-haskell/libyaml-0.1:=[profile?] <dev-haskell/libyaml-0.2:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.3:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-8.0.2:=
+ !no-examples? ( dev-haskell/raw-strings-qq:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.2.0
+ test? ( dev-haskell/base-compat
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ dev-haskell/mockery
+ dev-haskell/temporary
+ no-examples? ( dev-haskell/raw-strings-qq ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag no-examples no-examples) \
+ $(cabal_flag no-exe no-exe)
+}