summaryrefslogtreecommitdiff
path: root/dev-haskell/yesod-json
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/yesod-json
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/yesod-json')
-rw-r--r--dev-haskell/yesod-json/Manifest5
-rw-r--r--dev-haskell/yesod-json/metadata.xml11
-rw-r--r--dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild38
-rw-r--r--dev-haskell/yesod-json/yesod-json-1.2.0.ebuild23
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-haskell/yesod-json/Manifest b/dev-haskell/yesod-json/Manifest
new file mode 100644
index 000000000000..10e22be9ed2f
--- /dev/null
+++ b/dev-haskell/yesod-json/Manifest
@@ -0,0 +1,5 @@
+DIST yesod-json-1.1.2.2.tar.gz 3752 BLAKE2B fadd8b8b25d7e9e3de74ae8b7da7192065a68e015b5bf5bab8e476bbf45513b7cf59df7a60d6ea8e03e7398f83afead3ab4178cccb3c570d2cbc5512935076f9 SHA512 ab577311763850d3bdac8281761e43384bbc552e2caa7285797f7a9c8163de5b43f4d84495f2f716577a1848fa84a892789a5223752b6395bcdac7a46deb6763
+DIST yesod-json-1.2.0.tar.gz 1373 BLAKE2B d1e7d69aa98685fd6a77274a52302b9aa9b7614a1363f272209620ebd4f267062c4c7d5964c4f48a4d5a87571f02616a0b3bdbd834916f4821d271fa6257bd68 SHA512 9fa3eb964e5a543d4f38293245a8ef7f585c5ead94dd0fbc028fca5c954401eafb11e3d18a60a12baa82d3cedce871271b8320d65996f0b00021804c00da0dbb
+EBUILD yesod-json-1.1.2.2.ebuild 1156 BLAKE2B 639e2227a9b5cdbffb85c4f0fbd6747a859c7d472ef4b79a12deec4de25f69d7c019e9f2bfc366214a89b8545de848fd794e49d43418428de9d19ec09d0b85ab SHA512 28e09ec439316656796fcb99ed027ff4262a0fc1719fffdba361618fad57bd6b62c898f834d88debe5d98b81e1003d0b41c188ccbd737645df587532b33acd54
+EBUILD yesod-json-1.2.0.ebuild 604 BLAKE2B efa6a139ac0f6f014acba1baa690cdd7a7f11e8d6f5f9dfd2e378bfeb492956eed04514a8ea96e98cf89cd7fd4988d8d25b420ca79c291a8942e3ade07130dc7 SHA512 ceed0ab4ab592d40942df0bd3554ebee432375feb6d9396a85fc940df4cd29d29e326cf98dc8e20f98ccbeac59c89f5da2b78b230735a52c2f60c28bca6317ca
+MISC metadata.xml 342 BLAKE2B e6d0b6288199ce5fb8c449a477bd86464721b50606f0cb1e126930b6285df9fd7771ae1b84463fa1867e8e91fd218037d1fa57981df9579d6ef7346292488d79 SHA512 9ce57dd7b85d81330b4c2e6583530853cf8f2e7982309af25e39887c65f4567f516cb94976dd1a565ff54a7c5f2728e1dd0c7a020a6211559a0f4b2559bdcfc5
diff --git a/dev-haskell/yesod-json/metadata.xml b/dev-haskell/yesod-json/metadata.xml
new file mode 100644
index 000000000000..ee87ffcd4335
--- /dev/null
+++ b/dev-haskell/yesod-json/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Generate content for Yesod using the aeson package.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild b/dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild
new file mode 100644
index 000000000000..5a50b662d84d
--- /dev/null
+++ b/dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generate content for Yesod using the aeson package"
+HOMEPAGE="https://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.5:=[profile?]
+ >=dev-haskell/attoparsec-conduit-0.5:=[profile?]
+ dev-haskell/blaze-builder:=[profile?]
+ >=dev-haskell/conduit-0.5:=[profile?]
+ >=dev-haskell/safe-0.2:=[profile?]
+ >=dev-haskell/shakespeare-js-1.0:=[profile?]
+ >=dev-haskell/text-0.8:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?]
+ >=dev-haskell/wai-1.3:=[profile?]
+ >=dev-haskell/wai-extra-1.3:=[profile?]
+ >=dev-haskell/yesod-core-1.1:=[profile?]
+ >=dev-haskell/yesod-routes-1.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hspec
+ dev-haskell/wai-test
+ )"
diff --git a/dev-haskell/yesod-json/yesod-json-1.2.0.ebuild b/dev-haskell/yesod-json/yesod-json-1.2.0.ebuild
new file mode 100644
index 000000000000..bb2deda0286e
--- /dev/null
+++ b/dev-haskell/yesod-json/yesod-json-1.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Generate content for Yesod using the aeson package. (deprecated)"
+HOMEPAGE="https://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/yesod-core-1.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8"