summaryrefslogtreecommitdiff
path: root/dev-haskell/zlib-conduit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/zlib-conduit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/zlib-conduit')
-rw-r--r--dev-haskell/zlib-conduit/Manifest5
-rw-r--r--dev-haskell/zlib-conduit/metadata.xml14
-rw-r--r--dev-haskell/zlib-conduit/zlib-conduit-1.0.0.ebuild36
-rw-r--r--dev-haskell/zlib-conduit/zlib-conduit-1.1.0.ebuild25
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-haskell/zlib-conduit/Manifest b/dev-haskell/zlib-conduit/Manifest
new file mode 100644
index 000000000000..4a88291ebfc6
--- /dev/null
+++ b/dev-haskell/zlib-conduit/Manifest
@@ -0,0 +1,5 @@
+DIST zlib-conduit-1.0.0.tar.gz 3461 BLAKE2B 8605775bb5e801879c8017b8bd88379f200242bc021c34bf74322a578142444f013da227a9f9e7565b3f1afe27b9ab04a43666e16d9f4be81f3223b12ed07b52 SHA512 3f62701b687ab0220c2f5f18ebc2b9ba33010ed4471832523400cea4a808d02f59173c2de4ee3055f09ec6271a771745df35768612f8035d98c9dcd32be9b007
+DIST zlib-conduit-1.1.0.tar.gz 2024 BLAKE2B e7b8bcf5515cb25b2152c29db4a4f04d2050db8c999386428eaa913e296d34f6c07c136d2ff16962462b699fed20b35160ad51f079659d27b87a61bbb31c640a SHA512 5d19fa0e144b8e124486465c00b984f2e16f51e8ef0bc246fafd64b173e7dcef5b12f8cb431bb6071e4dab4a8c8f62606d47feb2cac2e36c1894216a9c8a32d9
+EBUILD zlib-conduit-1.0.0.ebuild 947 BLAKE2B 66b54eeec1352a80e2f7c36f6468022945cc81f6abeefe0ac71c46917bc428ed45d82ed920d29d5eb072b886322b92d639f9872f0a50e56c3285a5eb5528fa2c SHA512 16d43e76854ff60b4951bd9f8084eedf7d46b8bfe318bf9f67ade9f1590baec070442f3ef19362dba6608d629a86093cae385d13032bbe8307bcce17a86311b8
+EBUILD zlib-conduit-1.1.0.ebuild 583 BLAKE2B 9faa4ab27a50ed85d3aec7148b05b2f4c6ec2ecadd993c977e373014cb1540396ef91624bc93156b28c2d7ede9bfde78455b4382a5462589c37b4b409b2ca8bd SHA512 b2068fca59904a1822edff6c6690070f48306349eba8c97ac4d7d738b2008bdbd10d2d861482b85b5910a92af21c666e3bf4c6f05d65b937f6a823861cd3b310
+MISC metadata.xml 421 BLAKE2B a9003dc463b6c470053d6c36f16bdcc6eea6dae13fe7358ba5c8b5e67fdcafa60f149a72df3691e223c4a756c3facc957e813b04c0bfe82f1ac087983aa90c3d SHA512 5b01280934ed698382fb2a9ff0d8f21638ecbcd5c929824fa64a3f3520afe6b06c5fc52ef63931eb160d1dedaf1a5fe4799852ba8d006561e78098731f1e1e65
diff --git a/dev-haskell/zlib-conduit/metadata.xml b/dev-haskell/zlib-conduit/metadata.xml
new file mode 100644
index 000000000000..33070e5f5f8e
--- /dev/null
+++ b/dev-haskell/zlib-conduit/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Streaming compression/decompression via conduits.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">snoyberg/conduit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/zlib-conduit/zlib-conduit-1.0.0.ebuild b/dev-haskell/zlib-conduit/zlib-conduit-1.0.0.ebuild
new file mode 100644
index 000000000000..8203dd0c6841
--- /dev/null
+++ b/dev-haskell/zlib-conduit/zlib-conduit-1.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Streaming compression/decompression via conduits"
+HOMEPAGE="https://github.com/snoyberg/conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="+debug"
+
+RDEPEND="=dev-haskell/conduit-1.0*:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ <dev-haskell/transformers-0.4:=[profile?]
+ dev-haskell/void:=[profile?]
+ =dev-haskell/zlib-bindings-0.1*:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/quickcheck
+ dev-haskell/resourcet
+ )"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug)
+}
diff --git a/dev-haskell/zlib-conduit/zlib-conduit-1.1.0.ebuild b/dev-haskell/zlib-conduit/zlib-conduit-1.1.0.ebuild
new file mode 100644
index 000000000000..0e84f5633ed8
--- /dev/null
+++ b/dev-haskell/zlib-conduit/zlib-conduit-1.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile"
+inherit haskell-cabal
+
+DESCRIPTION="Streaming compression/decompression via conduits. (deprecated)"
+HOMEPAGE="https://github.com/snoyberg/conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/conduit-1.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"