summaryrefslogtreecommitdiff
path: root/dev-java/bnd-junit/bnd-junit-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/bnd-junit/bnd-junit-2.1.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/bnd-junit/bnd-junit-2.1.0.ebuild')
-rw-r--r--dev-java/bnd-junit/bnd-junit-2.1.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-java/bnd-junit/bnd-junit-2.1.0.ebuild b/dev-java/bnd-junit/bnd-junit-2.1.0.ebuild
new file mode 100644
index 000000000000..e4de5405feee
--- /dev/null
+++ b/dev-java/bnd-junit/bnd-junit-2.1.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Junit plugin for bndlib, a swiss army knife for OSGi"
+HOMEPAGE="http://www.aqute.biz/Bnd/Bnd"
+SRC_URI="https://github.com/bndtools/bnd/archive/${PV}.REL.tar.gz -> bndlib-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="
+ dev-java/osgi-core-api:0
+ dev-java/bndlib:0"
+
+DEPEND=">=virtual/jdk-1.5
+ test? ( dev-java/junit:4 )
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+
+S="${WORKDIR}/bnd-${PV}.REL/biz.aQute.junit"
+
+EANT_BUILD_TARGET="build"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="bndlib,junit-4,osgi-core-api"
+
+# Tests appear broken and cause a circular dependency.
+RESTRICT="test"
+
+java_prepare() {
+ # Move the correct build.xml into place, needed for testing.
+ cp ../cnf/build.xml . || die
+
+ # Remove bundled jar files.
+ find . -name '*.jar' -delete > /dev/null
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar generated/biz.aQute.junit.jar
+}