summaryrefslogtreecommitdiff
path: root/dev-java/cdegroot-db/cdegroot-db-0.08-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/cdegroot-db/cdegroot-db-0.08-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/cdegroot-db/cdegroot-db-0.08-r2.ebuild')
-rw-r--r--dev-java/cdegroot-db/cdegroot-db-0.08-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-java/cdegroot-db/cdegroot-db-0.08-r2.ebuild b/dev-java/cdegroot-db/cdegroot-db-0.08-r2.ebuild
new file mode 100644
index 000000000000..4149fbc8454c
--- /dev/null
+++ b/dev-java/cdegroot-db/cdegroot-db-0.08-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="OO database written in Java"
+HOMEPAGE="http://www.cdegroot.com/software/db/"
+SRC_URI="http://www.cdegroot.com/software/db/download/com.${P/-/.}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="amd64 ppc64 x86"
+IUSE="doc source"
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/com.${P/-/.}"
+
+PATCHES=( "${FILESDIR}/${P}-gentoo.patch" )
+src_prepare() {
+ default
+ rm -rv src/db/test lib/*.jar || die
+ cp -v "${FILESDIR}/build.xml" "${S}/build.xml" || die
+}
+
+EANT_DOC_TARGET="docs"
+
+src_install() {
+ java-pkg_dojar "dist/${PN}.jar"
+ dodoc TODO VERSION CHANGES BUGS README
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc src/*
+}