summaryrefslogtreecommitdiff
path: root/dev-java/commons-cli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-java/commons-cli
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-java/commons-cli')
-rw-r--r--dev-java/commons-cli/Manifest2
-rw-r--r--dev-java/commons-cli/commons-cli-1.5.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/commons-cli/Manifest b/dev-java/commons-cli/Manifest
index 3e032beae0e9..28d0f8d4ee0d 100644
--- a/dev-java/commons-cli/Manifest
+++ b/dev-java/commons-cli/Manifest
@@ -1,3 +1,5 @@
DIST commons-cli-1.4-src.tar.gz 148530 BLAKE2B 72460ee073b4e8c5179da03c3d599cf04b37b5b3aff89e4927b07765bd879acc9ac56f52e7dee03214e21f7ba9e5af3adf54d2f943aebb266bfa9b4983ba0380 SHA512 a5db856f6154e4340aab1865e3b34c752c0dceb8063faa64740ed470d8e6b3e7782242ae51d6bb57a535a6d6dad2943cc3130d7202223b8f89b8cbecdc3d9d4f
+DIST commons-cli-1.5.0-src.tar.gz 156731 BLAKE2B b3bc3c7426f4564187f6b2fecf2977a8d307277cb244bb51064f32e6d2fc0ddb08c539b3bae68bba5ccc2319d0e483f01f6765ae3e86ebfe99eb775564fd7c8f SHA512 aa2165695177c3e4561f68585cafb5434758138d8a863f3db1860477f660cf78664d2afb07cc3bc767bc8fa87befc7eaa5bdead423ee8b883c62ff00aec7cdda
EBUILD commons-cli-1.4.ebuild 1073 BLAKE2B 47369d5c19d43c955e2cfafed597607929c8cac3d940a7bfd07abad0a9f7527453c55e6ce47c98ec53c2f741884c1049015a5b4d02f1187c0558367865d6068c SHA512 6158af3b2d265f06499174fd392f95ac46feaad3d5b76b8e85448600e724ebbfd6de2614b35d8e3f31b6bd120baf0265403487c42d1c20e2271a1a0df0ed8750
+EBUILD commons-cli-1.5.0.ebuild 1241 BLAKE2B 04ce102c416377aa8b3d217cf6133e5de6f7cace7f013e190f6d657acb1253d7a1875617ca428af3a7b0c50efcd89e90a1468d9d93d16121a537d45ce7706e86 SHA512 6c623f4549da4d5c89e878e496637bd82a4465168ed4a70cb330530e8597316fc3d321f5ecb6ad44ebf704187d042eb073a70c882b7cbfce2717c833729eaf31
MISC metadata.xml 233 BLAKE2B 2b385ca77219f08b2874b3a4a91a0c836d3cb45ec44b05babb33d590c56ceb5337ecb93a8450a37f8e6bbf4cfc1455892e8142d22e0a1d527d40361e2dce350b SHA512 1acc975a7dc3344bc63282d652ca00d8245970b58353b4fd00f09a4859db3eaba2dcd85e1537d424b7174e4f9c01c2ffb10ec6d107b5c895c9ca20730666de7f
diff --git a/dev-java/commons-cli/commons-cli-1.5.0.ebuild b/dev-java/commons-cli/commons-cli-1.5.0.ebuild
new file mode 100644
index 000000000000..8fb0198774dc
--- /dev/null
+++ b/dev-java/commons-cli/commons-cli-1.5.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="commons-cli:commons-cli:1.5.0"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A Java library for working with the command line arguments and options"
+HOMEPAGE="https://commons.apache.org/proper/commons-cli/"
+SRC_URI="mirror://apache/commons/cli/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+DEPEND=">=virtual/jdk-1.8:*"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_SRC_DIR="src/main/java"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+
+# There were 62 failures:
+# 1) testSimpleLong(org.apache.commons.cli.ParserTestCase)
+# java.lang.InstantiationException
+# at java.base/jdk.internal.reflect.InstantiationExceptionConstructorAccessorImpl.newInstance(InstantiationExceptionConstructorAccessorImpl.java:48)
+# FAILURES!!!
+# Tests run: 444, Failures: 62
+JAVA_TEST_EXCLUDES="org.apache.commons.cli.ParserTestCase"
+
+src_install() {
+ default
+ java-pkg-simple_src_install
+}