summaryrefslogtreecommitdiff
path: root/dev-java/commons-collections/commons-collections-3.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-java/commons-collections/commons-collections-3.2.1-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-java/commons-collections/commons-collections-3.2.1-r1.ebuild')
-rw-r--r--dev-java/commons-collections/commons-collections-3.2.1-r1.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-java/commons-collections/commons-collections-3.2.1-r1.ebuild b/dev-java/commons-collections/commons-collections-3.2.1-r1.ebuild
deleted file mode 100644
index 3db3f7201fd2..000000000000
--- a/dev-java/commons-collections/commons-collections-3.2.1-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2 java-utils-2 eutils
-
-DESCRIPTION="Jakarta-Commons Collections Component"
-HOMEPAGE="http://commons.apache.org/collections/"
-SRC_URI="mirror://apache/${PN/-//}/source/${P}-src.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test-framework"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- test-framework? (
- dev-java/junit:0
- dev-java/ant-junit:0
- )
- "
-DEPEND=">=virtual/jdk-1.6
- ${CDEPEND}"
-RDEPEND=">=virtual/jre-1.6
- ${CDEPEND}"
-
-S="${WORKDIR}/${P}-src"
-
-java_prepare() {
- # Check for VM version.
- java-pkg_is-vm-version-ge 1.8
- if [[ $? -eq 0 ]]; then
- einfo "You are running a JVM greater or equal than version 1.8."
- epatch "${FILESDIR}"/${P}-Java-8.patch
- fi
-}
-
-src_compile() {
- local antflags
- if use test-framework; then
- antflags="tf.jar -Djunit.jar=$(java-pkg_getjars junit)"
- #no support for installing two sets of javadocs via dojavadoc atm
- #use doc && antflags="${antflags} tf.javadoc"
- fi
- eant jar $(use_doc) ${antflags}
-}
-
-src_test() {
- if [[ "${ARCH}" = "ppc" ]]; then
- einfo "Tests are disabled on ppc"
- else
- ANT_TASKS="ant-junit" eant testjar -Djunit.jar="$(java-pkg_getjars junit)"
- fi
-}
-
-src_install() {
- java-pkg_newjar build/${P}.jar ${PN}.jar
- use test-framework && \
- java-pkg_newjar build/${PN}-testframework-${PV}.jar \
- ${PN}-testframework.jar
-
- dodoc README.txt
- java-pkg_dohtml *.html || die
- if use doc; then
- java-pkg_dojavadoc build/docs/apidocs
- #use test-framework && java-pkg_dojavadoc build/docs/testframework
- fi
- use source && java-pkg_dosrc src/java/*
-}