summaryrefslogtreecommitdiff
path: root/dev-java/commons-dbutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/commons-dbutils
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/commons-dbutils')
-rw-r--r--dev-java/commons-dbutils/Manifest6
-rw-r--r--dev-java/commons-dbutils/commons-dbutils-1.6.ebuild52
-rw-r--r--dev-java/commons-dbutils/files/commons-dbutils-1.6-build.xml263
-rw-r--r--dev-java/commons-dbutils/metadata.xml8
4 files changed, 329 insertions, 0 deletions
diff --git a/dev-java/commons-dbutils/Manifest b/dev-java/commons-dbutils/Manifest
new file mode 100644
index 000000000000..beaa32af9277
--- /dev/null
+++ b/dev-java/commons-dbutils/Manifest
@@ -0,0 +1,6 @@
+AUX commons-dbutils-1.6-build.xml 11340 SHA256 01b77165682e5b716fe42d110335fd3b89b6fc2046b85c65263deebbea1dfa3a SHA512 6f16181ab7224e60bc34257668f31c3a2e9939f6d400e7af6e5663586fe160c1eb337c0db36e9f4773be873ab85379b069470e4d5591d48cae1d237fafade6b8 WHIRLPOOL 73c3c09c8c317b56c9a2b4b984751905f894ade241c8a323c6c0c05d4ec839873ce79d21c66686c3a7d1afceca4c18970a7a0be61440d191e05a3f96fb4ccb55
+DIST commons-dbutils-1.6-src.tar.gz 90708 SHA256 c7cb1bd7e0f9a6d509c98bb60f9941503473d6fe0fbe144736fb1819096c4524 SHA512 05aa5fb448d949ac4d5d34f1219539e57cfb550fa423af0691cb35002984036b0de62b8f618199bd2f562a441867c5b7138e9204afc36bd6d0fa2c4c5e9cd2c6 WHIRLPOOL 012a8cace08c96c136b9e9a05ec34d173d544aecad465908ad823a47ec535cfa91c609e5280e9e05967b3d863b13e999ad2c9a826a100e3faa3333869c26dd97
+EBUILD commons-dbutils-1.6.ebuild 1100 SHA256 498e302c569f0d0c08ca18ac16a9a54f953665d99d765e873f6434e7bb4013cf SHA512 3a3e973da68035e5a290a396428edbd3d6213ae918fc0090d1d65dc8379fc3bc13d92e91f3452cae5846b01b67d59601f033e040da85f43ef958a1ba3a691af8 WHIRLPOOL 5d47dc37350c57e740945c64f928fa7a9d6c74be723e7a3ccdf8009090d2e0dcf4e76369383128bc5384206c171114d02dc8e0a9818a60b7ebf7af74355ce83e
+MISC ChangeLog 2955 SHA256 16d3cbb7ff42dc67f99c71d619952f0104393f8fca4c2a9506b42484cc715b1b SHA512 455594f8308ed5c6fbfd3c4535ad0a09aea9dedac226f4eded195c8aeff0bd78e020055569dc49c5f9a34a3f54396a955f6dc4c73100a116102f3bda316a2354 WHIRLPOOL d4bf11e9669185a27aaf2b785038b00a2b3ce94d44ecc4393e869390b02bd627facce3530b23f5080223788a58275bb4fdb13b86398cf6be929052ada85da406
+MISC ChangeLog-2015 1037 SHA256 3194c624386e608c304767c776908d4de034dfd184c029f204703543465c0300 SHA512 8a56ceb0326b94ce09cc7ec423939b3b00d002209904d7a14a755ce7bc554232dd9aa6369d435d568fddc04129c82524b1823f077deafd5f7c2516bb217fb2ed WHIRLPOOL e6ce3c0727be6f28f05a50f43589593e0b9f06aed3d58c05f1af8dd7bebf5dd03c079bc3f508fa99e8338c3343e0f62db7b6b4ddb35743b71d4a7486784e17be
+MISC metadata.xml 242 SHA256 653cd0d34675fe6c6201752e96e6b035bad682c39a376c236b0a8f70dbdcc1c9 SHA512 50f4d6219b995b723d6ebbb4f2a18adbf558a685f862aea00f072254dcc0fe6c1388e4aeaf21fb3ce0fb840a2ef4851807536d037c9682b21cb1986198715a4f WHIRLPOOL 12c33e00040d7a3f4c26a8b7a6a6eaf10007a9e29af9904d192f89db5120a2760a7174fa40c40068eb6066d6a4f0dbbc57a12e852581de95cc956e210351b705
diff --git a/dev-java/commons-dbutils/commons-dbutils-1.6.ebuild b/dev-java/commons-dbutils/commons-dbutils-1.6.ebuild
new file mode 100644
index 000000000000..f58f08c36763
--- /dev/null
+++ b/dev-java/commons-dbutils/commons-dbutils-1.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+EAPI=5
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A small set of classes designed to make working with JDBC easier"
+HOMEPAGE="http://commons.apache.org/dbutils/"
+SRC_URI="mirror://apache/commons/dbutils/source/${P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/mockito:0
+ dev-java/ant-junit:0
+ dev-java/hamcrest-core:1.3
+ )"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+EANT_TEST_TARGET="test"
+EANT_TEST_GENTOO_CLASSPATH="
+ mockito
+ hamcrest-core-1.3
+"
+
+# Uses a bunch of deprecated methods.
+JAVA_RM_FILES=(
+ src/test/java/org/apache/commons/dbutils/handlers/ArrayHandlerTest.java
+)
+
+java_prepare() {
+ cp "${FILESDIR}"/"${P}-build.xml" build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java
+}
diff --git a/dev-java/commons-dbutils/files/commons-dbutils-1.6-build.xml b/dev-java/commons-dbutils/files/commons-dbutils-1.6-build.xml
new file mode 100644
index 000000000000..725d4eaca036
--- /dev/null
+++ b/dev-java/commons-dbutils/files/commons-dbutils-1.6-build.xml
@@ -0,0 +1,263 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 10/5/15 8:20 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="commons-dbutils-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="commons-dbutils-1.6"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.resourceDir.1" value="."/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.build.testResourceDir.1" value="."/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.11/junit-4.11.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"/>
+ <pathelement location="${maven.repo.local}/org/mockito/mockito-core/1.9.5/mockito-core-1.9.5.jar"/>
+ <pathelement location="${maven.repo.local}/org/objenesis/objenesis/1.0/objenesis-1.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-all/1.3/hamcrest-all-1.3.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="iso-8859-1"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.1}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="iso-8859-1"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ <mkdir dir="${maven.build.testOutputDir}/META-INF"/>
+ <copy todir="${maven.build.testOutputDir}/META-INF">
+ <fileset dir="${maven.build.testResourceDir.1}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/TestBean.java"/>
+ <exclude name="**/BaseTestCase.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/BaseTestCase.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in the test classpath or your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="iso-8859-1"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ docencoding="iso-8859-1"
+ source="1.6"
+ linksource="true"
+ breakiterator="false">
+ <link href="http://docs.oracle.com/javase/6/docs/api/"/>
+ <link href="http://docs.oracle.com/javaee/6/api/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ <manifest>
+ <attribute name="Main-Class" value="Main"/>
+ </manifest>
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+</project>
diff --git a/dev-java/commons-dbutils/metadata.xml b/dev-java/commons-dbutils/metadata.xml
new file mode 100644
index 000000000000..37998bf40746
--- /dev/null
+++ b/dev-java/commons-dbutils/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+</pkgmetadata>